2.5Gb/s nic at 1Gb/s speed Jeremyy44

jeremyy44

Member
Joined
Jan 20, 2021
Messages
44
Reaction score
8
Credits
411
Hi,

So I recently decided to switch to linux for my main OS and I have been having some problems with my nic.
So my setup is pretty straight foward I have two 2.5Gb/s nics one in my pc and one in my server that are both directly connected to one another. My problem is that I am not able to get the speed that is advertized on linux. I am on Kubuntu 21.04 for my main pc and Ubuntu Server 20.04 for my server btw. I never had this problem on windows. I have the r8125 driver installed and loaded but even then It dosnt work.

When doing "ehtool enp9s0" these are the results I get.

-------------------------------------------------------------------------------------------
Settings for enp9s0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
2500baseT/Full
Supported pause frame use: Symmetric Receive-only
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised pause frame use: Symmetric Receive-only
Advertised auto-negotiation: Yes
Advertised FEC modes: Not reported
Link partner advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
2500baseT/Full
Link partner advertised pause frame use: Symmetric Receive-only
Link partner advertised auto-negotiation: Yes
Link partner advertised FEC modes: Not reported
Speed: 1000Mb/s
Duplex: Full
Auto-negotiation: on
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
MDI-X: Unknown
Supports Wake-on: pumbg
Wake-on: g
Current message level: 0x00000033 (51)
drv probe ifdown ifup
Link detected: yes
-------------------------------------------------------------------------------------------

So it is supported but the speed is stuck at 100Mb/s for some reason.
And I have tried a new cable.

Any ideas would be greatly apreciated since I didnt buy both cards wanting them to be as slow as in integrated eth port lol.
They work perfectly fine under windows and have a problem ONLY when im on booted in kubuntu on my main pc.
 


f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
3,910
Reaction score
2,646
Credits
28,251
It does recognize that your network card supports 2500 so I wouldn't think it's a driver problem.
100baseT/Half 100baseT/Full
1000baseT/Full
2500baseT/Full
Try changing the speed temporarily using ethtool.
Code:
sudo ethtool -s enp9s0 speed 2500 duplex full autoneg on
Then check if it works using ethtool and/or transferring a file from your server to your desktop.
Code:
ethtool enp9s0 | grep -i speed
If that changes the speed you can then make it permanent by adding it to your network card configuration.
Code:
ETHTOOL_OPTS="speed 2500 duplex full autoneg on"
Check the article I linked for further explanation and details.
 
OP
jeremyy44

jeremyy44

Member
Joined
Jan 20, 2021
Messages
44
Reaction score
8
Credits
411
It does recognize that your network card supports 2500 so I wouldn't think it's a driver problem.

Try changing the speed temporarily using ethtool.
Code:
sudo ethtool -s enp9s0 speed 2500 duplex full autoneg on
Then check if it works using ethtool and/or transferring a file from your server to your desktop.
Code:
ethtool enp9s0 | grep -i speed
If that changes the speed you can then make it permanent by adding it to your network card configuration.
Code:
ETHTOOL_OPTS="speed 2500 duplex full autoneg on"
Check the article I linked for further explanation and details.
Well damn it was that easy lol
Thanks a lot had been banging my head to this for a while without finding any help anywhere, only other forum I posted got me a "did you try another cable" and a idk then.
Thanks again!
 
OP
jeremyy44

jeremyy44

Member
Joined
Jan 20, 2021
Messages
44
Reaction score
8
Credits
411
It does recognize that your network card supports 2500 so I wouldn't think it's a driver problem.

Try changing the speed temporarily using ethtool.
Code:
sudo ethtool -s enp9s0 speed 2500 duplex full autoneg on
Then check if it works using ethtool and/or transferring a file from your server to your desktop.
Code:
ethtool enp9s0 | grep -i speed
If that changes the speed you can then make it permanent by adding it to your network card configuration.
Code:
ETHTOOL_OPTS="speed 2500 duplex full autoneg on"
Check the article I linked for further explanation and details.
Forgot to ask but I could not find where the network file on kubuntu is to add the line to make the change permanant. Any ideas?
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
3,910
Reaction score
2,646
Credits
28,251
Forgot to ask but I could not find where the network file on kubuntu is to add the line to make the change permanant. Any ideas?
I think Kubuntu uses network manager, I think you would need to configure these options.
I would think something like this.
nmcli connection modify eth0 802-3-ethernet.auto-negotiate true 802-3-ethernet.duplex full 802-3-ethernet.speed 2500
nmcli connection reload
sudo systemctl restart NetworkManager
Replace eth0 with the interface name on your Kubuntu system. Then see if it picks it changes up, if not just reboot your Kubuntu system.
 
Last edited:

dos2unix

Well-Known Member
Joined
May 3, 2019
Messages
1,018
Reaction score
695
Credits
5,155
I think Kubuntu uses network manager,

Are there really very many distro's that still don't?

Replace eth0 with the interface name on your Kubuntu system. Then see if it picks it changes up, if not just reboot your Kubuntu system.

Keep in mind, the other end of whatever you're connecting to, also has to support the same speed.
If your switch only supports 1GB, guess what speed you're going to connect at.
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
3,910
Reaction score
2,646
Credits
28,251
Are there really very many distro's that still don't?
Yes you are right it's probably safe to assume that most distributions are using networkmanager.
Keep in mind, the other end of whatever you're connecting to, also has to support the same speed.
If your switch only supports 1GB, guess what speed you're going to connect at.
So my setup is pretty straight foward I have two 2.5Gb/s nics one in my pc and one in my server that are both directly connected to one another.
 
Last edited:
OP
jeremyy44

jeremyy44

Member
Joined
Jan 20, 2021
Messages
44
Reaction score
8
Credits
411
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Latest posts

Top