Acidentally deleted ethernet connection, now it doesn't detect it anymore

tesla123

New Member
Credits
58
So basically i have a orangepi3 which is running armbian buster which is based on debian, and i recently moved it to a different location and used a different ethernet cable, on my main pc i got 100 mbps, but on the orangepi only 10mbps, after hours of troubleshooting i realized that there is a gui setting for limmiting the speed and i increased it to 100mbps but i don't know why but i also deleted the ethernet connection/setting listed as armbian and now the ethernet doesn't work anymore, firstly the raise network interface failed, but now it works and idk why are there so many ethernet connections listed, eth0, armbian, armbian ethernet?, i also don't know what exactly to write in network interface, currently i have auto eth0, iface eth0 inet dhcp, also tried modifiying this, but it just assigns me a weird ip and it doesn't work, when i try to do a speedtest it says cannot retrieve speedtest configuration..., error <urlopen error [Errno -2] Name or service not found>, also if i type ethtool eth0 it says link not detected but the ethernet cable is plugged in, also tried moving the ethernet cable to different ports on the router, tried following this guide for a fix but it didn't workhttps://askubuntu.com/questions/824...-network-interfaces-after-upgrading-to-16-04#
Also start job for raise network interface lasts 1 minute before it starts, is this normal?, but then it says ok and none of the lights light up on the ethernet port
I would really appreciate some help from someone more experienced then me, because i don't know if i will be able to fix this by myself, but it's my fault because of my stupidity
 

Attachments

Last edited:


tesla123

New Member
Credits
58
Solved it, i just deleted all ethernet connections and rebooted, then a default one loaded and now it works but i still get only 10 mbps, but i should 100mbps
 


Members online

No members online now.

Top