airplane mode can’t be switched off

masRicardo

New Member
Joined
Dec 11, 2022
Messages
4
Reaction score
0
Credits
31
After I upgraded to fedora 37 and rebooted the system, the airplane mode is on and can’t be switched off anymore. Meaning, now my Wi-fi is disconnected. I am using a Lenovo machine.
Any ideas how to fix this issue? Thanks in advance.
 


Ok hard block [you call it flight mode] has caused problems quite often on this model, [even in windows]
first thing to try is reboot the bios... boot up the machine, save any work to a safe place, then PRESS AND HOLD the power button down for 60 seconds, then re-boot, [did this work]? if not, it may mean that your computer has a physical wireless switch . Press and hold the
Fn Key
key, and then press the key that has the
Single Wireless Key
 
Ok hard block [you call it flight mode] has caused problems quite often on this model, [even in windows]
first thing to try is reboot the bios... boot up the machine, save any work to a safe place, then PRESS AND HOLD the power button down for 60 seconds, then re-boot, [did this work]? if not, it may mean that your computer has a physical wireless switch . Press and hold the
Fn Key
key, and then press the key that has the
Single Wireless Key
Thank you very much for your help. Unfortunately none of your suggestions did work. I did press and hold the on/off button for more then 60 sec. and rebooted —> No effect! If I press Fn and F5 the machine just display ‘Hardware Airplane Mode’, nothing else happens… :(
 

Attachments

  • 50387DE4-448E-4E49-A17E-E3CA881076F2.jpeg
    50387DE4-448E-4E49-A17E-E3CA881076F2.jpeg
    178.6 KB · Views: 215
  • A79EDE76-0BDF-44E4-9B9F-6A946EB99E6D.jpeg
    A79EDE76-0BDF-44E4-9B9F-6A946EB99E6D.jpeg
    257.7 KB · Views: 187
Ok hard block [you call it flight mode] has caused problems quite often on this model, [even in windows]
first thing to try is reboot the bios... boot up the machine, save any work to a safe place, then PRESS AND HOLD the power button down for 60 seconds, then re-boot, [did this work]? if not, it may mean that your computer has a physical wireless switch . Press and hold the
Fn Key
key, and then press the key that has the
Single Wireless Key
I also tried
rfkill unblock all
with no effect on the airplane mode…

After another ‘60sec reboot’ I switched in the boot menu back to a fedora 36 version. Also no effect on the Airplane Mode’ :(
 
Those instructions usually work, my last thought is check the Bios settings.
It may be a problem with Fedora, but I am not fully conversant with RHEL distributions
 
Try SHIFT + FN + whatever key it was that you were pressing for airplane mode.
 
I just encountered this problem on an old Dell Studio 1749 with Fedora 38 and eventually solved it by going into the BIOS under Advanced and changed the Wireless Switch/Hotkey setting from All to None. Fn+F2 doesn't do anything anymore, but I can turn Airplane Mode on and off again at will via the GUI. I only checked whether the locked Airplane Mode problem would disappear with only one of the other Wireless Switch/Hotkey choices, but it didn't so I settled on None as the choice.

I hadn't changed any BIOS setting on this system in many years. I can only infer a software update changed the Airplane Mode behavior. Unfortunately I tried to solve the problem with a fresh Fedora 38 install only to discover the problem remained, which is what prompted me to experiment with the BIOS setting. Fortunately I only use this particular laptop for testing and convenience and didn't have to restore any data.

Hope this saves someone else some time on a very annoying problem.
 
I just encountered this problem on an old Dell Studio 1749 with Fedora 38 and eventually solved it by going into the BIOS under Advanced and changed the Wireless Switch/Hotkey setting from All to None. Fn+F2 doesn't do anything anymore, but I can turn Airplane Mode on and off again at will via the GUI. I only checked whether the locked Airplane Mode problem would disappear with only one of the other Wireless Switch/Hotkey choices, but it didn't so I settled on None as the choice.

I hadn't changed any BIOS setting on this system in many years. I can only infer a software update changed the Airplane Mode behavior. Unfortunately I tried to solve the problem with a fresh Fedora 38 install only to discover the problem remained, which is what prompted me to experiment with the BIOS setting. Fortunately I only use this particular laptop for testing and convenience and didn't have to restore any data.

Hope this saves someone else some time on a very annoying problem.
Airplane mode is stuck at ON and can't use any solution that involves internet access [am doing this at library] as only have wifi which is cut off by airplane mode. Have tried other solutions like adapter power cutoff option, but doesn't work [the advice to click on the 'RUN' when it comes up is not relevant as the 'RUN' doesn't come up despite having the registry item 'merged']. Would appreciate some method [command line sequence?] to delete the 'airplane mode' option out of the OS.
 
delete the 'airplane mode' option out of the OS.

This is normally a part of the BIOS not the OS, what make/full model number of your machine, and which distribution are you using..
Oh and welcome to the forums

edit, after doing some investigation there have been some problems [but not recently] and it may be possible to to use the rfkill command depending on your distribution
 
Last edited:
Airplane mode is stuck at ON

That's usually an Fn key combination. If the key combination doesn't work, try holding the shift button along with the Fn combination.
 

Members online


Latest posts

Top