An audio interface that doesn't need drivers [for linux]

NerdOnMeth

New Member
Credits
190
Hey everyone, i'm sure you all can relate to wanting hardware that will work without any fuss, something that you can just plug in, correct?

Well, my only issue with having switched back to dual boot on my desktop is the linux parition gives me no sound, and i've tried just about every software fix i can find. What would be nice would be an audio interface that doesn't even need drivers if this is possible. Can you think of one? I have a steinburg interface which works with a very simple installation of windows drivers, but i'm trying to stop using windows altogether eventually...

Also...what are the factors that come into play in terms of whether computer hardware needs drivers? From my understanding, printers always need drivers, obviously a lot of hardware doesn't but yes some of it does...
 


stan

Well-Known Member
Credits
7,339
What would be nice would be an audio interface that doesn't even need drivers if this is possible.
No, sorry, that is not possible. All peripheral hardware requires drivers to communicate with software (the operating system and apps). This includes mouse, keyboard, audio, video, printers, scanners, and networking devices. Hardware manufacturers often only provide Windows drivers... shame on them. Linux developers often will fill the void and create needed drivers, but there is no promise or guarantee (remember that they work for free). Sometimes the Linux drivers fail to provide full performance or features because they get no help at all from the company who sold you the device. It's a sad situation.

None of your post gives us anything to go on to try to help you. You have simply said, "Sound broke. How to fix by magic?" There are at least a couple of professional musicians on this forum, so maybe one of them (or others) can help you. It may be easy, or it may be very hard, or it may be impossible. @KGIII and @JasKinasis... take a look, please.

Consider these:

1. Find a distro that actually supports your audio hardware. Ubuntu Studio or AVLinux may have a chance. Maybe others.

2. Provide the exact Steinburg model of your device so that we can help you search for solutions.

3. Tell us exactly what you have tried that has failed... so we don't waste time looking at the same things you've already ruled out. We might ask you to try something again anyway.

4. Tell us more... computer brand and specifications, what distros you have tried, what audio applications: alsa? pulseaudio? both?

5. Is it possible to consider something other than Steinburg? Or keep Windows strictly for your audio needs? I keep Windows strictly for genealogy work, and some people keep Windows strictly for TurboTax or Quicken. There are many reasons like this to keep a special-purpose computer, and no shame in that.

Good luck!
 
Last edited:

NerdOnMeth

New Member
Credits
190
My bad, i admit i was being a little lazy. Here's my specs:

Audio:
Device-1: Intel 100 Series/C230 Series Family HD Audio
driver: snd_hda_intel
Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel
Sound Server: ALSA v: k5.8.0-55-generic

According to this Q&A question, this problem may not have a solution as there's a kernel issue. Here are some more of the methods i have tried:


There's an ubuntu audio troubleshooting page which i have not gone through. This all has to with software for sure: i currently do not have an audio interface or sound card hooked in and my sound is just fine on windows, it comes through the speakers on my monitor. I opened up my desktop case today to see if there was something i could plug in that would help, and found that there wasn't. There are lots of slots for things on my mobo for things which i'm not sure what they're there for. It's a gigabyte mobo, DDR3.
 

brickwizard

Well-Known Member
Credits
5,017
I too have c/230 on board sound, on may main box,It worked with W10 when the box arrived but failed when I installed Mint 20 [Ubuntu based] I spent several days trying to find a solution that worked, [most of the Q&A I found were not working in Ubuntu but there were other distro's as well]
the easy way out in the end was one of these...
USB 2.0 External Sound Card Adapter for Stereo Audio Y-247A
Bwiz
 

JasKinasis

Well-Known Member
Credits
7,583
I have a 2 channel, Digidesign Mbox2 USB audio interface (that came with Pro-tools) that my old band bought years ago. They gave it to me after they bought a bigger interface card for the studio PC.

Drivers for it have been in the kernel for a reasonably long time, it’s literally plug and play.

After plugging it in and using it, sometimes when I reboot, I find that all of my audio is routed to a dummy interface.
I think a couple of times, it also happened if I unplugged the Mbox at the end of a session.

To fix it, I can’t remember the exact commands offhand, but I think I stopped pulseaudio and ALSA, removed their config files and then restarted ALSA and pulseaudio. And then they reconfigured themselves to use my on-board sound card.

But I only want audio to be routed through the mbox when I’m using it. I don’t want it permanently routed through the mbox.
 

stan

Well-Known Member
Credits
7,339
i currently do not have an audio interface or sound card hooked in and my sound is just fine on windows, it comes through the speakers on my monitor.
You don't have a sound card? What do you plug your monitor/speakers into on the PC side? Are you using HDMI cable? If so, can you change it to a regular audio cable?


Device-1: Intel 100 Series/C230 Series Family HD Audio
Device-2: NVIDIA GP106 High Definition Audio
Linux-hardware.org indicates Device 1 should work.
Linux-hardware.org indicates Device 2 should work also.


this problem may not have a solution as there's a kernel issue
The first step in solving a problem is understanding the problem. You are no longer referring to the Steinburg audio interface and seem to have just a basic sound issue. You're telling us that you have TWO sound devices installed and neither work (one is probably onboard audio). Is this right?

1. Again, what kind of cables are you using? Standard audio cable or HDMI?
2. Do headphones work?
3. Please describe any errors you see. Do you get the "dummy output" problem?
4. Check your BIOS/UEFI Setup for any sound related settings. Tell us if you have any.

Sound problems can be a beast to resolve sometimes, but they usually can be fixed if you are patient enough to go through all the detailed troubleshooting steps. The reason we so often recommend people to boot on a "live USB" of different Linux distros is to identify problems such as this. It's not too late for that. I would seriously recommend at least trying 3 or 4 other distros to see if something else will work... Linux Mint and Zorin OS Lite are both Ubuntu-based, and I have had especially good luck with Zorin making hardware work that other distros will not. Fedora, Manjaro, and MX-Linux would also be good to test. Testing/switching distros is likely to be easier than chasing your problem, unless we happen to find it quickly.
 

NerdOnMeth

New Member
Credits
190
You don't have a sound card? What do you plug your monitor/speakers into on the PC side? Are you using HDMI cable? If so, can you change it to a regular audio cable?



Linux-hardware.org indicates Device 1 should work.
Linux-hardware.org indicates Device 2 should work also.



The first step in solving a problem is understanding the problem. You are no longer referring to the Steinburg audio interface and seem to have just a basic sound issue. You're telling us that you have TWO sound devices installed and neither work (one is probably onboard audio). Is this right?

1. Again, what kind of cables are you using? Standard audio cable or HDMI?
2. Do headphones work?
3. Please describe any errors you see. Do you get the "dummy output" problem?
4. Check your BIOS/UEFI Setup for any sound related settings. Tell us if you have any.

Sound problems can be a beast to resolve sometimes, but they usually can be fixed if you are patient enough to go through all the detailed troubleshooting steps. The reason we so often recommend people to boot on a "live USB" of different Linux distros is to identify problems such as this. It's not too late for that. I would seriously recommend at least trying 3 or 4 other distros to see if something else will work... Linux Mint and Zorin OS Lite are both Ubuntu-based, and I have had especially good luck with Zorin making hardware work that other distros will not. Fedora, Manjaro, and MX-Linux would also be good to test. Testing/switching distros is likely to be easier than chasing your problem, unless we happen to find it quickly.
To think of it: the problem must be related to the Nvidia card since that's what my monitor is plugged into. I was having deibilitating visual issues with it after i installed ubuntu, and the solution was using the GUI to install the drivers as doing it through bash didn't work. There's a whole list of driver alternatives i could try in the list (in "additional drivers") that i could try. I'll get back to this when i have more time.
 

NerdOnMeth

New Member
Credits
190
So here's the deal: none of the alternate driver installations fixed my issue, and my headphone jack doesn't work period, atleast on the front side of my desktop case, hooking it up to the back of it would just be a pain and inconvenient considering the current placement of it.

Looks like i'm just going to have to shrug at this problem, as i don't see any purpose in buying new hardware as i already have plenty. Also, I installed the linux partition mostly just to work on programming as i've found that linux is so much better for that.

Edit: For those of us who compartmentalize OS usage, it works really well to get rid of the grub timer. It's just as easy as it has ever been, given that you can operate bash...

 
Last edited:

Tolkem

Well-Known Member
Credits
8,314
I have a steinburg interface
Look here https://forums.steinberg.net/t/linux-support-steinberg-ur22/46903/33 It's a bit old - 2014, though last comment was in 2019 - but apparently support for steinburg devices is and has been there for some time, at least according to some comments:
HI. I have been using my UR22 (Mk 2) successfully with Ardour running in Linux Mint 17.3. No such luck running it with Ardour in Elementary (as yet). Ardour recognised the interface straight away and I set the UR22 as my input and output. Having recorded guitars a few nights ago I then downloaded the calf effects as my plug-ins and they work a treat as well.
I have not downloaded any drivers and am not running anything through WINE. The UR22 just works
And
I’m using Arch Linux, and even though the system is immediately recognizing the UR22, I’ll get this when I choose the Steinberg aus my soundcard in alsamixer
And
I can confirm that the Steinberg UR22 MKII works well on Linux (Plug and Play).
Ubuntu 18.04 and Audacity. Just select the Steinberg as Input.
Hope this helps.
And
I hope this helps somebody
I tried the UR22 on Ubuntu Desktop v15.10 and it works.
All I did was power down the machine, plug in the UR22 USB cable into the computer and turn it on.
I did not have to install any device drivers or software.
The UR22 was recognized automatically by Ubuntu 15.10
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top