An unsolved problem with Neptune installation (double boot Windows 10)


New Member
Jul 7, 2022
Reaction score
Hi everyone,

I've decided to write here because I couldn't find the answer to my problem anywhere else on the web. I managed to create a bootable USB with an ISO file of Neptune 7.0 distro. After first attempts, I was unable to boot into Neptune Live. The solution that I found was changing the Boot Mode setting in BIOS from UEFI to Legacy. That made it possible for me to normally install and run the system. The only problem that came with was the fact that in order to boot back into Windows 10 I had to change back the Boot Mode setting to UEFI and reverse that same action to boot into Linux.

At that point I realised that it's way too much hassle and decided to try and install Linux in UEFI mode so that they could boot alongside each other (with the ability to choose a system in Boot Manager). I have disabled Secure Boot and plugged in my USB. After entering into Windows Boot Manager I was able to choose my desired drive, so I did. I entered Neptune Live and started the installation as usual. Having completed all the steps, the installation manager requires you to restart your system and it should reboot into full version Neptune. However, every time I've reached this step and tried to restart into full Neptune, Windows boots. I've already tried creating separate /boot/efi partition before installing and it didn't help either. Every time this had happened and I've tried to boot into something else than Windows it would bring me back to Neptune Live as if the system had never been installed before. To me it looks like Windows (or the BIOS) doesn't realise that another system has been installed and that's why I'm not able to boot (or even choose) anything else than Windows Boot.

Do you have any ideas or possible solutions to this problem? I know it's possible to create a double-boot system from Windows 10, but I just can't seem to figure out what's blocking me from doing that on my machine.

Thanks for any replies.

BTW I'm using an Acer Aspire F5-573G laptop

is that an installable distro ? or only live

you should only need one efi partition ; efi of even 100mb should be enough to support 2 distro. if you have installed you should take out the usb, then reboot. Did you disable Fast Boot as well as secure boot. What happened when you got to grub install of neptune install /
Yes it's an installable distro and all the main problems occur after installation.
Are you saying that two separate operating systems can use just one EFI partition? (sorry if that's a dumb question)
I didn't see an option named Fast Boot anywhere in BIOS although I'm gonna check it once again.
Could you walk me through how can I get the answer to your last question?
yes; both OS can use the same EFI partition. Basically the EFI partition stores files to do with the way uefi boots , the uefi looks for those files you can look at the efi partition using : efibootmgr eg :

[andrew@darkstar:~][127]$ efibootmgr -v                                   (07-09 13:26)
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0001,9999
Boot0000* boot	HD(1,GPT,192a9aa1-9848-4329-8171-9253ffc0f920,0x800,0x32000)/File(\EFI\boot\grubx64.efi)
Boot0001* Internal Hard Disk	PciRoot(0x0)/Pci(0x11,0x0)/Sata(1,65535,0)/HD(1,GPT,192a9aa1-9848-4329-8171-9253ffc0f920,0x800,0x32000)..BO
Boot9999* USB Drive (UEFI)	PciRoot(0x0)/Pci(0x1d,0x0)/USB(16,0)..BO
[andrew@darkstar:~]$                                                                                   (07-09 13:27)

I only have one OS which is vanilla Arch and my laptop is uefi firmware. So if Neptune uses Grub as the boot manager and you installed grub uefi mode , then you should see an entry for neptune. Now there is a possibility that grub was installed to MBR and since your PC is uefi it won't find it.

Now there is an issue if you can't boot into Neptune you can't use efibootmgr . But you can use efibootmgr like this:

[andrew@darkstar:~]$ efibootmgr -v /dev/sda    
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0001,9999

So I think it would be useful to get another usb and stick on it some like Linux Mint. Unless you configure it, a live OS can install software but it will be gone next time you boot from live.

Now on the grub install, what i'm saying is that with all Linux i've installed including Slackware the OS at some point it will mention about installing the boot loader and where you want to install it. By the way when you have installed a linux OS to your hard drive using a usb, you have to take out the USB stick THEN reboot . Fast boot will be somewhere in boot options of BIOS . You have to boot from cold (PC power off ) and quickly hit keys like F9 to access BIOS. When your computer starts it should for an instant state how to access BIOS
Okay, I've tried installing Linux Mint and found it much easier, especially with the extensive pre-written installation tips for beginners. It seems to be working normally and is installed on UEFI boot mode. The only thing I have yet to do is fix the boot order but I know it can easily be done in BIOS. I believe that for now my problem is solved and I can enjoy my double-boot machine. Thanks a lot for your help.
what you can do is try :
 sudo  update-grub

What thay shoudl do is add windows to the boot menu; so that from a cold boot you get a choice of what you want to boot up Windows or Mint. Well dome by the way
I surely will, thank you very much once again and have a nice day.
try disabling windows quick start and do a full re-boot

Members online

Latest posts