Arch Linux - modifying suspend timeout?

rado84

Active Member
It's been a while since I was last here and it took me a while longer to remember the address of this forum. :)
Ever since kernel 5.5 was released I have a weird problem with system suspend: when I press the suspend key (which I have set to be Pause/Break), the system doesn't go to sleep immediately as it used to be in kernel 5.4.x but instead it waits for a few seconds and then goes to sleep. I wanna make it back to the way it used to be - to sleep immediately without waiting. I tried several files to edit, including /etc/systemd/logind.conf but nothing I did changed that waiting time. Any suggestions what else I should try?

P.S. Reporting bugs on Arch's website is as equally useless as the Microsoft support team, so my only option is to do it myself... somehow.

P.S.2. The DE is Cinnamon 4.4.8, if it matters.
 


rado84

Active Member
That was the first place to check, there's nothing there about that.
 

Alexzee

Active Member
That was the first place to check, there's nothing there about that.
So nothing in Power Management at all?

If the Cinnamon Arch WiKi wasn't helpful I don't know what else you can try. Sorry I'm out of ideas.
 

rado84

Active Member
I browsed the arch wiki last night and the only helpful thing was the information that power management is performed by systemd, so I reported this as a bug in systemd's github. It must be a bug cuz nothing of what I described has ever happened before. Plus it's not normal to wait for the system to boot up for 20 seconds or more after you reboot it:
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
G'day @rado84 - have you tried remapping the suspend key back to the way it was by way of comparison?

Wiz
 

rado84

Active Member
By default there is no key. Suspending the system by the menu options (not by key) results in the same waiting time, so I doubt the key is the problem.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
... then I do not understand this part from the bug report

,,,In the older versions of the kernel it was enough to gently touch the sleep button and it would go to sleep instantly,
Wiz
 




Latest posts


Top