ASUS Zenbook 14 UM425UA keyboard not respond during cold boot


New Member
I have ASUS Zenbook 14 UM425UA (Ryzen 5 5500U + 16GB RAM version), but builtin keyboard doesn't work in both GDM and Gnome session (both X11 and Wayland) after cold power on, but works properly after reboot. GRUB menu works properly all the time. During problematic boots I see "Can't read CTR while initializing i8042" kernel error. I tried tricks with ignore "Asus WMI hotkeys" and blacklist Intel Virtual Button driver (this model has AMD APU however), but nothing seems to work. I tried to run Ubuntu 20.04 (HWE enabled), Ubuntu 20.10, Ubuntu 21.04 and Fedora 33, however all distributions have the same problem. I tried Kernel 5.11.3 and 5.12.0rc2 for Ubuntu kernel PPA without success too. I don't have options related to keyboard in UEFI and whole UEFI is very basic. ASUS didn't provide newer UEFI yet. Touchpad works properly all the time. Did you have similar problems with your laptops?
BTW. Hibernation doesn't work too even on kernel 5.11+ (this kernel has AMD SoC PMC driver), but this is a topic for another thread. Keyboard is more problematic from my point of view.
Best regards,


New Member
I am also having the same issue with the same laptop (UM425UA Ryzen 5 5500U + 16GB RAM version)

Is there any debug information I can provide to help solve the issue?


Well-Known Member
I found the specs for your Asus laptop.

With kernel 5.11 there is support for Asus laptops but it's for Asus Gaming laptops.

If a higher version of the kernel doesn't help see if there is an update for your BIOS.

**Make sure that the update for your BIOS is for the "exact make and model" of your Asus laptop.**

This search might be useful:

Aside from that maybe try rolling back to an older version of the kernel and see if that works.
Sorry I don't know more.


New Member
Hello, I have got exactly the same issues with my ZenBook UX325 (16GB, OLED, Ryzen 7 5700U). I even had similar issues with Lenovo Yoga 7 Slim Pro. The situation with Yoga was even worse because there didn't work not only the keyboard but the touchpad too, so without an external mouse there was impossible to do the non-cold OS restart.


Well-Known Member
take a look at this article, [it has worked for others] But read it ALL before you start doing anything

$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online