Bad sound and mic quality on Ubuntu 22.04.4 LTS

paulliano

New Member
Joined
Apr 8, 2024
Messages
7
Reaction score
0
Credits
54
This is my first time trying Ubuntu and after successful setup on my HP ENVY x360 Convertible 15-cp0xxx, 16gb ram. I realize my laptop sound quality changes, it doesn't have bass anymore. If I reduce the sound to like 50%, the sound output is very low. And with the microphone, whenever I do a call on meet or discord, people hear noisy sound from their end, like a fan noise. I have tried a lot of solution out there, installed PulseAudio, configure it, tweak the meters in PulseAudio, I've also installed PulseEffect and configured it, used PavuControl, installed firmware-sof-signed, and alot of other solutions. But am still having issues with the sound and mic. Pls any idea of what I can do to fix this. Thanks.
 


G'day paulliano, Welcome to Linux.org

In Terminal, type:
Code:
alsamixer

When alsamixer is opened, then you can:

press F1 key for help to see all the options you can use,
press Esc key to return to volume bars,
press F5 to see all volume bars,
raise the volumes by using the up arrow key, and move from bar to bar with the left and right arrow keys.
press Esc to quit alsamixer when you're finished.

and also read this

Use the right and left arrow keys to navigate through the sliders.
At the bottom of each slider you see either 00 or MM. Toggle these with the M key. MM means muted, 00 is enabled.
Use the up and down arrow keys or the Page Up/Page Down keys to control the sliders. Page Up/Page Down move the sliders in increments of five, and the End key resets to zero. When there are two channels controlled by one slider, Q increases the left channel and Z decreases. E increases the right channel, and C decreases.
Press F2 to see all the system information on your sound cards. If you have more than one sound card press F6 to display a sound card chooser.

The red arrow at the bottom of this pic shows MM.....which means that in this case my headphones are muted....if I use the right arrow to move to that column....and then tap the M key, that will unmute it
1712778905832.png



This link is worth a read
and this one
Thos links do not directly address your problems but they should give you an understanding of making adjustments/moving around alsamixer in Terminal.
 
Last edited:

Attachments

  • Screenshot from 2024-04-10 20-51-11.png
    Screenshot from 2024-04-10 20-51-11.png
    38.2 KB · Views: 77
  • Screenshot from 2024-04-10 20-51-38.png
    Screenshot from 2024-04-10 20-51-38.png
    55.5 KB · Views: 85
  • Screenshot from 2024-04-10 20-55-46.png
    Screenshot from 2024-04-10 20-55-46.png
    61.9 KB · Views: 79
Note....that you are not the only one to have sound problems in Ububtu.

If you were to type Sound into the Search at top right hand side of the page, you will get many responses......not all of them are related to your problem, but some may be worth a read where there are similarities.
 
G'day paulliano, Welcome to Linux.org

In Terminal, type:
Code:
alsamixer

When alsamixer is opened, then you can:

press F1 key for help to see all the options you can use,
press Esc key to return to volume bars,
press F5 to see all volume bars,
raise the volumes by using the up arrow key, and move from bar to bar with the left and right arrow keys.
press Esc to quit alsamixer when you're finished.

and also read this

Use the right and left arrow keys to navigate through the sliders.
At the bottom of each slider you see either 00 or MM. Toggle these with the M key. MM means muted, 00 is enabled.
Use the up and down arrow keys or the Page Up/Page Down keys to control the sliders. Page Up/Page Down move the sliders in increments of five, and the End key resets to zero. When there are two channels controlled by one slider, Q increases the left channel and Z decreases. E increases the right channel, and C decreases.
Press F2 to see all the system information on your sound cards. If you have more than one sound card press F6 to display a sound card chooser.

The red arrow at the bottom of this pic shows MM.....which means that in this case my headphones are muted....if I use the right arrow to move to that column....and then tap the M key, that will unmute it
View attachment 19371


This link is worth a read
and this one
Thos links do not directly address your problems but they should give you an understanding of making adjustments/moving around alsamixer in Terminal.
I've tweaked this several times, At a point, I reboot did sudo reboot several times after increasing everything to max, nothing change for sound. I got my friend on a meet call for the mic too, it didn't get fixed by tweaking that.
 
I cannot offer any other suggestions....however, I will "call" someone who may be able to help. My mentioning his name here will alert him when he comes online next. Be patient, we arte all in different time zones and have our lives to attend to first.

@osprey
@GatorsFan
 
Ubuntu 22.04 has PipeWire partially installed and enabled as it's used by browsers (WebRTC) for recording the screen under Wayland. This in my humble opinion has caused a lot of problems on some machines. You have a couple of options to try 1) is to remove pipewire completely and just use pulseaudio or 2) Fully enable pipewire and see what happens - below is to enable pipewire

We can enable remaining parts and use PipeWire for audio and Bluetooth instead of PulseAudio
Install WirePlumber as the session manager:

sudo apt install pipewire-media-session- wireplumber

Notice '-' at the end of 'pipewire-media-session'. This is to remove it in the same command, because 'wireplumber' will be used instead. there is also a space between- wireplumber

Start WirePlumber for your user:
systemctl --user --now enable wireplumber.service
where is says --user that is Your --user name
Now install the ALSA plug-in:

sudo apt install pipewire-audio-client-libraries

And copy the config file from PipeWire docs (provided by the plug-in) into the ALSA configuration directory below
sudo cp /usr/share/doc/pipewire/examples/alsa.conf.d/99-pipewire-default.conf /etc/alsa/conf.d/

Check if you have other (like Pulse) configs in the /etc/alsa/conf.d/ installed by something else. You might want to remove them.

Install the codecs and remove Bluetooth from PulseAudio, so it would be handled directly by PipeWire:

sudo apt install libldacbt-{abr,enc}2 libspa-0.2-bluetooth pulseaudio-module-bluetooth-

The supported codecs are SBC and LDAC. AAC is not supported because of patents

Once completed reboot and check by running:

LANG=C pactl info | grep '^Server Name'
you can also have a look here for more info - https://ubuntuhandbook.org/index.php/2022/04/pipewire-replace-pulseaudio-ubuntu-2204/

hopefully @osprey or @wizardfromoz or @KGIII will chime in and see if he has anymore thoughts
 
Last edited:
I cannot offer any other suggestions....however, I will "call" someone who may be able to help. My mentioning his name here will alert him when he comes online next. Be patient, we arte all in different time zones and have our lives to attend to first.

@osprey
@GatorsFan
Okay, appreciate this, thanks
 
Ubuntu 22.04 has PipeWire partially installed and enabled as it's used by browsers (WebRTC) for recording the screen under Wayland. This in my humble opinion has caused a lot of problems on some machines. You have a couple of options to try 1) is to remove pipewire completely and just use pulseaudio or 2) Fully enable pipewire and see what happens - below is to enable pipewire

We can enable remaining parts and use PipeWire for audio and Bluetooth instead of PulseAudio
Install WirePlumber as the session manager:



Notice '-' at the end of 'pipewire-media-session'. This is to remove it in the same command, because 'wireplumber' will be used instead. there is also a space between- wireplumber

Start WirePlumber for your user:

where is says --user that is Your --user name
Now install the ALSA plug-in:



And copy the config file from PipeWire docs (provided by the plug-in) into the ALSA configuration directory below


Check if you have other (like Pulse) configs in the /etc/alsa/conf.d/ installed by something else. You might want to remove them.

Install the codecs and remove Bluetooth from PulseAudio, so it would be handled directly by PipeWire:



The supported codecs are SBC and LDAC. AAC is not supported because of patents

Once completed reboot and check by running:


you can also have a look here for more info - https://ubuntuhandbook.org/index.php/2022/04/pipewire-replace-pulseaudio-ubuntu-2204/

hopefully @osprey or @wizardfromoz or @KGIII will chime in and see if he has anymore thoughts
I've tried this and also followed the link you shared and redo it again, but it still having the low quality sound.
1712789778859.png
 
I've tried this and also followed the link you shared and redo it again, but it still having the low quality sound.View attachment 19376
The only other thing I can think of is to revert back to pulseaudio - if you need a guide have a look here - scroll down in the article it also tells you how to undo it

Also have you tried Debian 12 it is PulseAudio only unless you want to install PipeWire
 
paulliano, if you try out Debian 12, be sure to see how it reacts with sound etc etc while it is still in 'Live" mode....(in other words before you actually install it).
If you wanted another to try, Linux Mint 21.3 would be worthwhile trying as well.
 
Last edited:
paulliano, if you try out Debian 12, be sure to see how it reacts with sound etc etc while it is still in 'Live" mode....(in other words before you actually install it).
If you wanted another to try, Linux Mint 21.3 would be worthwhile trying as well.
Pls how do I try it before installing it. I have been having struggle with doing that.
 
Pls how do I try it before installing it. I have been having struggle with doing that.
download the ISO and install it to a USB stick using Etcher - one completed insert the thumb drive - reboot - tap the F12 key repeatedly when it starts , this will bring up a one time boot menu, then select your thumb drive you will be running a live version
On HP machines it may be the F9 key, just check which key it is - most use F12 but there are some exceptions
 
Pls how do I try it before installing it. I have been having struggle with doing that.
Hi there,
I have the same problem with my Lenovo W530 and Linux Mint 21.3. Earphones work fine, but the speakers are also low. YouTube has a 2x amplifier on Firefox and VLC player movies work just fine. It is only with some apps that I have this problem.
 

Staff online


Top