Bluetooth usb problem

f33dm3bits

Gold Member
Gold Supporter
Credits
12,505
Looks like all you have to do is extract the archive, then enter the directory the files are extracted into. Assuming you need the usb functionality all you have to do is.
Code:
sudo make install INTERFACE=usb
The module then gets built and copied to:
Code:
$ ls -l /lib/modules/$(uname -r)/kernel/drivers/bluetooth/rtk_btusb.ko
-rw-r--r-- 1 root root 104216 feb 19 18:25 /lib/modules/5.4.0-52-generic/kernel/drivers/bluetooth/rtk_btusb.ko
Make sure the your usb bluetooth device is plugged in, reboot and the once rebooted it should recognize it, then you can do the following to see if the module is loaded and to see if the system sees the device.
Code:
lsmod | grep rtk_btusb
lsusb
Also check if the bluetooth service is now running and seeing the device, since this is an outdated version you won't have to worry about kernel upgrade so using dkms is not needed.
 
Last edited:


Peter0623

New Member
Credits
191
Hello and good morning f33dm3bits,

Thank you for your patience. The extracted folder is on my desktop , i then open a terminal in that folder and entered :

sudo make install INTERFACE=usb

The output is as follows :

[email protected]:/media/hd/home/reel/Desktop/20200610_LINUX_BT_DRIVER$ sudo make install INTERFACE=usb
[sudo] password for reel:
mkdir -p /lib/modules/3.16.0-56-lowlatency/kernel/drivers/bluetooth
Start Realtek Bluetooth USB driver installation
mkdir -p /lib/firmware
Copy rtkbt-firmware/lib/firmware/rtl*_fw to /lib/firmware
cp -a rtkbt-firmware/lib/firmware/rtl*_fw /lib/firmware
Copy rtkbt-firmware/lib/firmware/rtl*_config /lib/firmware
cp -a rtkbt-firmware/lib/firmware/rtl*_config /lib/firmware
make -C usb install
make[1]: Entering directory `/media/hd/home/reel/Desktop/20200610_LINUX_BT_DRIVER/usb'
rmmod btusb
rmmod: ERROR: Module btusb is not currently loaded
make[1]: [install] Error 1 (ignored)
mv /lib/modules/3.16.0-56-lowlatency/kernel/drivers/bluetooth/btusb.ko /lib/modules/3.16.0-56-lowlatency/kernel/drivers/bluetooth/btusb_bak
mv: cannot stat ‘/lib/modules/3.16.0-56-lowlatency/kernel/drivers/bluetooth/btusb.ko’: No such file or directory
make[1]: [install] Error 1 (ignored)
rmmod rtk_btusb
make -C ./bluetooth_usb_driver
make[2]: Entering directory `/media/hd/home/reel/Desktop/20200610_LINUX_BT_DRIVER/usb/bluetooth_usb_driver'
make -C /lib/modules/3.16.0-56-lowlatency/build M=/media/hd/home/reel/Desktop/20200610_LINUX_BT_DRIVER/usb/bluetooth_usb_driver modules
make[3]: Entering directory `/usr/src/linux-headers-3.16.0-56-lowlatency'
CC [M] /media/hd/home/reel/Desktop/20200610_LINUX_BT_DRIVER/usb/bluetooth_usb_driver/rtk_coex.o
CC [M] /media/hd/home/reel/Desktop/20200610_LINUX_BT_DRIVER/usb/bluetooth_usb_driver/rtk_misc.o
CC [M] /media/hd/home/reel/Desktop/20200610_LINUX_BT_DRIVER/usb/bluetooth_usb_driver/rtk_bt.o
LD [M] /media/hd/home/reel/Desktop/20200610_LINUX_BT_DRIVER/usb/bluetooth_usb_driver/rtk_btusb.o
Building modules, stage 2.
MODPOST 1 modules
CC /media/hd/home/reel/Desktop/20200610_LINUX_BT_DRIVER/usb/bluetooth_usb_driver/rtk_btusb.mod.o
LD [M] /media/hd/home/reel/Desktop/20200610_LINUX_BT_DRIVER/usb/bluetooth_usb_driver/rtk_btusb.ko
make[3]: Leaving directory `/usr/src/linux-headers-3.16.0-56-lowlatency'
make[2]: Leaving directory `/media/hd/home/reel/Desktop/20200610_LINUX_BT_DRIVER/usb/bluetooth_usb_driver'
cp -f ./bluetooth_usb_driver/rtk_btusb.ko /lib/modules/3.16.0-56-lowlatency/kernel/drivers/bluetooth/rtk_btusb.ko
depmod -a 3.16.0-56-lowlatency
make -C ./bluetooth_usb_driver clean
make[2]: Entering directory `/media/hd/home/reel/Desktop/20200610_LINUX_BT_DRIVER/usb/bluetooth_usb_driver'
rm -rf *.o *.mod.c *.mod.o *.ko *.symvers *.order *.a
make[2]: Leaving directory `/media/hd/home/reel/Desktop/20200610_LINUX_BT_DRIVER/usb/bluetooth_usb_driver'
echo "install rtk_btusb success!"
install rtk_btusb success!
make[1]: Leaving directory `/media/hd/home/reel/Desktop/20200610_LINUX_BT_DRIVER/usb'
[email protected]:/media/hd/home/reel/Desktop/20200610_LINUX_BT_DRIVER$

I restarted the desktop and in the terminal :

Screenshot - 02202021 - 02:19:36 AM.png


I thought that Bluetooth was working but still no icon and getting the following error :

Screenshot - 02202021 - 02:22:38 AM.png


I think some proress has been made.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
12,505
You restart the whole system? Can you do the following and share the output.
Code:
dpkg --list | grep bluetooth
ls -l /etc/init.d/bluetooth
/etc/init.d/bluetooth start
/etc/init.d/bluetooth status
 

f33dm3bits

Gold Member
Gold Supporter
Credits
12,505
Seems I misread your first post and was right, you don't have the packages installed that allow your to run the bluetooth which you need in order to start bluethooth which you need to access the device. Your only option to get this working is to install a supported version of Ubuntu since 14.04 is EOL and the sources are offline as well as it's not safe to be running an unsupported OS, I recommend 20.04 if you are looking for an LTS release.
 

Peter0623

New Member
Credits
191
Ok f33dm3bits, i understand , but managed to get another USB Bluetooth working in virtualbox 5.22 . It is version 4.0 but installed 14.04, 16.04 ,18.04 and 20.10 and all worked out of the box in vm.

At the moment installing debian with multiple desktops and will see if this USB dongle resuscitates .

Debian still offers 32 bit support.

I also understand that kernel 5.9 has the firmware already in place to enable the mpow dongle to work . If kernel 5.9 does not work with 32 bit technology , will try to use 64 bit even if it slows down the guest system.

First off, i will try the 14.04 with it`s deprecated sources on the mpow dongle and see if it can work in the vm.

Either way i will inform as to whether success has been achieved.

My gratitude for all help received.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
12,505
In your earlier screenshot you can see that the module you installed is loaded.
Screenshot - 02202021 - 02 19 36 AM.png

It shows that from the lsmod | grep rkt_btusb command, you need the bluetooth service running so that you can enable the bluetooth adapter so that you can use blueman to scan for available bluetooth devices and pair/connect to that device from there. Then once you are paired/connected to that device it will show up when you do: lsusb. I forgot to explain how that works, just to be sure can you share the output of the following commands since I assumed the service was called bluetooth but could as well just be called something with blue in the name which we might have missed.
Code:
chkconfig list | grep blue
ls -l /etc/init.d/blue*
 
Last edited:

f33dm3bits

Gold Member
Gold Supporter
Credits
12,505
Try running the following and share the output.
Code:
sudo /etc/init.d/bluetooth.all start
 /etc/init.d/bluetooth.all status
 

f33dm3bits

Gold Member
Gold Supporter
Credits
12,505
Now open blueman and enable and the bluetooth adapter, right click on the bluetooth icon, select devices and then right click on it, then a box opens, click search but make sure you have your bluetooth headset on so your adapter can detect it. When it detects your headset, right click on the device and click on connect, that should be about it.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
12,505
Do you see the bluetooth icon in your notification area? Right click on it and then click on "Turn Bluetooth on", then right click there again and select devices. From there you can select search(or magnifying glass icon) and it will do a search for all activated bluetooth devices so make sure bluetooth is activated on your headset. Then when it finds it you can right click and then click on connect.
 
Last edited:

Peter0623

New Member
Credits
191
From there you can select search and it will do a search for all activated bluetooth devices so make sure bluetooth is activated on your headset. Then when it finds it you can right click and then click on connect.
There`s no icon, using xfce .Will logout and enter Ubuntu desktop and see if one is there.
 

Members online


Top