• We did not send an email asking for donations - please read this post.

cacti does not show graphs

zapeador

Member
Joined
Jan 15, 2022
Messages
44
Reaction score
13
Credits
401
Hello, reinstall an operating system and some graphs do not work for me and others do, especially one of the ones I need is this one and it does not show data
I show you here the debug in case anyone sees an error

Code:
Comando RRDtool:
/usr/bin/rrdtool graph - \
--imgformat=PNG \
--start='-86400' \
--end='-60' \
--pango-markup  \
--title='TITAN_5 - Memory Usage' \
--vertical-label='bytes' \
--slope-mode \
--base=1000 \
--height=200 \
--width=700 \
--tabwidth '40' \
--rigid \
--alt-autoscale-max \
--lower-limit='0' \
COMMENT:"From 2022-01-31 15\:52\:22 To 2022-02-01 15\:51\:22\c" \
COMMENT:"  \n" \
--color BACK#F3F3F3 \
--color CANVAS#FDFDFD \
--color SHADEA#CBCBCB \
--color SHADEB#999999 \
--color FONT#000000 \
--color AXIS#2C4D43 \
--color ARROW#2C4D43 \
--color FRAME#2C4D43 \
--border 1 --font TITLE:11:'Arial' \
--font AXIS:8:'Arial' \
--font LEGEND:8:'Courier' \
--font UNIT:8:'Arial' \
--font WATERMARK:6:'Arial' \
--slope-mode \
--watermark 'Generated by Zapi' \
DEF:a='/var/www/html/cacti-1.2.16/rra/titan_5_mem_total_4916.rrd':'mem_total':AVERAGE \
DEF:b='/var/www/html/cacti-1.2.16/rra/titan_5_mem_buffers_4913.rrd':'mem_buffers':AVERAGE \
DEF:c='/var/www/html/cacti-1.2.16/rra/titan_5_mem_cache_4914.rrd':'mem_cache':AVERAGE \
DEF:d='/var/www/html/cacti-1.2.16/rra/titan_5_mem_free_4915.rrd':'mem_free':AVERAGE \
DEF:e='/var/www/html/cacti-1.2.16/rra/titan_5_mem_total_4916.rrd':'mem_total':MAX \
DEF:f='/var/www/html/cacti-1.2.16/rra/titan_5_mem_buffers_4913.rrd':'mem_buffers':MAX \
DEF:g='/var/www/html/cacti-1.2.16/rra/titan_5_mem_cache_4914.rrd':'mem_cache':MAX \
DEF:h='/var/www/html/cacti-1.2.16/rra/titan_5_mem_free_4915.rrd':'mem_free':MAX \
CDEF:cdefa='a,1024,*' \
CDEF:cdefe='b,1024,*' \
CDEF:cdefi='c,1024,*' \
CDEF:cdefbc='d,1024,*' \
CDEF:cdefbg='e,1024,*' \
CDEF:cdefbh='f,1024,*' \
CDEF:cdefbi='g,1024,*' \
CDEF:cdefbj='h,1024,*' \
AREA:cdefa#15317E7F:'Memory Total  '  \
GPRINT:cdefa:LAST:'Current\:%8.2lf %s'  \
GPRINT:cdefa:AVERAGE:'Average\:%8.2lf %s'  \
GPRINT:a:MAX:'Maximum\:%8.2lf %s\n'  \
AREA:cdefe#FF57007F:'Memory Buffers'  \
GPRINT:cdefe:LAST:'Current\:%8.2lf %s'  \
GPRINT:cdefe:AVERAGE:'Average\:%8.2lf %s'  \
GPRINT:cdefe:MAX:'Maximum\:%8.2lf %s\n'  \
AREA:cdefi#FFC73B7F:'Cache Memory  ':STACK \
GPRINT:cdefi:LAST:'Current\:%8.2lf %s'  \
GPRINT:cdefi:AVERAGE:'Average\:%8.2lf %s'  \
GPRINT:cdefi:MAX:'Maximum\:%8.2lf %s\n'  \
AREA:cdefbc#8F005C7F:'Memory Free   ':STACK \
GPRINT:cdefbc:LAST:'Current\:%8.2lf %s'  \
GPRINT:cdefbc:AVERAGE:'Average\:%8.2lf %s'  \
GPRINT:cdefbc:MAX:'Maximum\:%8.2lf %s\n'  \
LINE1:cdefbg#151B8DFF:  \
LINE1:cdefbh#FF5700FF:  \
LINE1.00:cdefbi#FFC73BFF::STACK \
LINE1.00:cdefbj#8F005CFF::STACK
RRDtool Command lengths = 2373 charaters.
RRDtool dice:
OK
 


JasKinasis

Well-Known Member
Joined
Apr 25, 2017
Messages
1,570
Reaction score
2,232
Credits
11,611
You haven’t given us a lot of useful information.

You said that you’ve reinstalled an operating system, we can only assume it’s a Linux distribution. But you haven’t told us which Linux distribution you’re using.
So what Linux distribution and version are you using? And what were you using before you reinstalled. Was it the same distro/version? Or a different distro/version?

If it was a different version of Linux that you were using before, it could be that the version of rrdtool in your new installation is newer and perhaps there have been changes made to it, which is causing your original files to fail to render.

But if you’re using the same version of Linux that you were using before, perhaps you have failed to install some extra packages, or something?!

The output from rrdtool isn’t helpful either. From what I can see, there are no error messages there.

I’m not familiar with cacti, or rrdtool. So I can’t really comment with any authority on them. But I’ll do a search in a bit, to see what I can find out.
 
OP
Z

zapeador

Member
Joined
Jan 15, 2022
Messages
44
Reaction score
13
Credits
401
Sorry, you're right that I gave little data,

install the same distribution, debian 10 and in principle it has the same packages installed since the rest of the services work fine, even some other graphics on the machine are also shown, but not just that one.

Any information you need do not hesitate to ask and I will provide it
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top