Cannot connect to any WiFi network

Chirag Suthar

New Member
Credits
0
Hello, I am using the latest version of kali linux (2020.1) in my oracle vm virtual box. At first my WiFi adapter was not recognized by my machine. I tried installing many different drivers and then at last I installed "Rtl8188fu" which I was able to figure out that this is the driver i would need for my kind of adapter. Now the adapter is being recognized and also i is showing me all the available network around me but it isn't getting connected to any of it, even when i place the router very next to my PC.

I am attaching all the configurations, please help............
Screenshot (8).png
Screenshot (17).png
 


Drizzit89

Member
Credits
0
iwconfig wlan0 essid Network_Name key s:Password/key

The s: is required before the password for the command to read it as ASII/plaintext and not HEX.
 

smooth_buddha

Active Member
Credits
0
i love Kali's background. The logo is quite stylish!
Have you set your network settings in virtual box to a briged adapter instead of NAT??????????
 

smooth_buddha

Active Member
Credits
0
I have a altogether different adapter for virtual box use
Have you tried bridged adapter ??? Im running wireless on my host and when i setup virtual box using briged adapter you should have an internet connection through the eth0 on your kali virtual box which your screenshot shows above. The eth0 is up and has an ip netmask and broadcast. It should be working provided the internet on your real host machine is workong and connected
 

smooth_buddha

Active Member
Credits
0
I have a altogether different adapter for virtual box use
so go settings in virtual box on your chosen machine

Network settings you want :

attached to BRIDGED ADAPTER

name: wlp3s0 (whatever your connection is on your host machine)

name of your internet on your host machine mine is wlp3s0 but yours may be different depending on how its connencted or it could be the same
 


Members online

No members online now.

Top