Cannot connect to any WiFi network

Chirag Suthar

New Member
Mar 23, 2020
Reaction score
Hello, I am using the latest version of kali linux (2020.1) in my oracle vm virtual box. At first my WiFi adapter was not recognized by my machine. I tried installing many different drivers and then at last I installed "Rtl8188fu" which I was able to figure out that this is the driver i would need for my kind of adapter. Now the adapter is being recognized and also i is showing me all the available network around me but it isn't getting connected to any of it, even when i place the router very next to my PC.

I am attaching all the configurations, please help............
Screenshot (8).png
Screenshot (17).png

iwconfig wlan0 essid Network_Name key s:Password/key

The s: is required before the password for the command to read it as ASII/plaintext and not HEX.
i love Kali's background. The logo is quite stylish!
Have you set your network settings in virtual box to a briged adapter instead of NAT??????????
I have a altogether different adapter for virtual box use
Have you tried bridged adapter ??? Im running wireless on my host and when i setup virtual box using briged adapter you should have an internet connection through the eth0 on your kali virtual box which your screenshot shows above. The eth0 is up and has an ip netmask and broadcast. It should be working provided the internet on your real host machine is workong and connected
I have a altogether different adapter for virtual box use

so go settings in virtual box on your chosen machine

Network settings you want :


name: wlp3s0 (whatever your connection is on your host machine)

name of your internet on your host machine mine is wlp3s0 but yours may be different depending on how its connencted or it could be the same
I'll redirect you to a thread of mine; my technique was kinda primitive but it worked. It should give you an idea of the issue source and how to fix it. (It's basically drivers missing, you have to get through an online access to get the .deb file of the wifi driver, then run "sudo dpkg -i [drivers].deb" and reboot)

Members online