Cannot get Linux OS to show as an option to boot in Dual Boot Laptop

Cbrew

New Member
Joined
Oct 21, 2021
Messages
11
Reaction score
5
Credits
142
I have encountered a scenario I simply cannot find a solution for.
I have created a dual boot laptop previously. It worked flawlessly and seamlessly. I simply loaded Win10 on my primary drive. installed a second drive in my laptop, installed Ubuntu and bam. It gives me the option to select which OS to boot into (OS Boot Manager) everything works great.

I'm trying to set up another laptop in the same configuration and of course. It doesn't work at all. Worse, I've reviewed Tons of literature on this issue and have found nothing that quite matches what I'm seeing. So my laptop is an old HP Dv7t 6100. I installed the OS's on the individual drives and my PC automatically booted into Windows. I managed to figure out the command line to force my PC To prompt which OS to boot into but it only shows Win10. While Win 10 is loaded, I can view the 2nd drive (Ubuntu) in Device manager, but I cannot see it in File explorer. I can see the Disk in Disk Manager in win 10 it shows me 2 healthy partitions identifying the EFI Partition etc., but ALL options are greyed out - cannot assign a drive letter to it, nothing. In BIOS If I Click on OS Boot Manager, there is no option to select Ubuntu or windows (a commonly cited option for fixing this issue).

I've read tons of threads on similar issues, automatically it's assumed there is a problem with Ubuntu's boot manager but here's the thing, I can select F9 on start up and that brings up (Change boot device order) and i can boot into Linux, and it boots just fine.
My Options in "Boot option menu" are as follows:
*OS Boot Manager - This automatically boots the machine into Windows
*ubuntu (Toshiba MQ01ABD075 - boots into Ubuntu
*Ubuntu (Toshiba MQ01ABD075 - Gives me GNU GRUB 2.04 which has a handful of options (Ubuntu (*boots into Ubuntu*) - Advanced Options for Ubuntu - Windows Boot Manager (on /dev/sdb2) (*This just boots into windows*) - UEFI Firmware settings
*ubuntu (Toshiba MQ01ABD075 - Boots into Ubuntu
*Boot From EFI File - Goes into file explorer has 2 selections - NO VOLUME LABEL [yadda yadda yadda (My Ubuntu boot partition] and then - NO VOLUME LABEL [yadda yadda yadda (My Windows boot partition)] If I select the Ubuntu boot partition it drills down to EFI then <.> <..> <Ubuntu> <boot> if i select the Windows Boot partition - EFI then <.> <..> <Microsoft> <Boot> <HP>

I simply cannot make it a boot option on the OS Boot Manager. From the Ubuntu side, I can view and access the drive that includes the Windows OS just fine. From the Windows side, It's like the PC knows the drive is there, it can see it, it can even discern the separate partitions and that one is an EFI Partition but it will not allow me to interact with it at all, can't access it, can't explore it, nothing.

I have tried every fix that seemed close to what I was experience but nothing has worked. Any thoughts? Suggestions? it simply doesn't make sense to me.
 


kc1di

Well-Known Member
Joined
May 14, 2021
Messages
485
Reaction score
438
Credits
3,415
I think you may be over working this :) That is why not let the machine boot to Linux and use the Linux grub boot loader boot windows for you when needed.
As couple things come to mind 1. Make sure your have secure boot turned off in bios. Linux does not like secure boot and it can interfere with many functions.
2. Why are your trying to boot linux with a window boot loader. It may work at times but bound to cause problems.
Also Windows file manager will not read any partition that is formatted to Linux file system.
Don't know if you have seen this tutorial if not it may be of help. good luck.
 
OP
C

Cbrew

New Member
Joined
Oct 21, 2021
Messages
11
Reaction score
5
Credits
142
kc1di - Thanks for responding. As to your question: Why not let the machine boot to linux and use the linux grub boot loader? - A: I don't understand how I would do this, the machine automatically boots into windows and does not see Ubuntu as an option to boot. It doesn't use Grub, i'd love it if I could use Grub instead but I can't get it to.
1.A: Secure boot is off.
2. A: Again Not trying to boot linux with Windows Boot loader, it's automatically using windows boot loader and I don't appear to have an option to select Ubuntu. I'll attach some pictures.

* You're right about Windows File Manager, my apologies, That was something I forgot when I had my old dual boot set up. I was able to access the windows Disk from Ubuntu but not the other way around, I apologize. Also yes, it's entirely possible I'm overcomplicating things, I fully expect the answer is a setting or something I didn't set up quite right.

**In the BIOS pic I attached - I'm showing the OS boot Manager option - When I click on this it does not give me an option to select anything (I Noted in other troubleshooting guides folks were able to select Ubuntu or Windows when they scroll to this and hit enter, i don't have any options when i hit enter on this)
**In the boot manager pic I attached - This is if i hit f9 while booting. I have no idea why it shows so many instances of Ubuntu on there. I explained in my first message what these options do.
**In the pic i attached labeled "on boot this is what i see" - Pretty self explanatory, Windows boot manager is what pops up I can't do anything here except select windows.

I appreciate the How to dual boot tutorial you attached. Again, i may have failed some step in installation and if so perhaps my only option is to go back through this tutorial. I can say from skimming the tutorial one step i did not take, I did not set up the partitions myself I simply chose the option to have ubuntu create the 2 partitions and install. So maybe this is where i went wrong? I don't know. Thanks again.
 

Attachments

  • BIOS.jpg
    BIOS.jpg
    63.9 KB · Views: 51
  • Boot Manager.jpg
    Boot Manager.jpg
    53.8 KB · Views: 57
  • on boot this is what i see.jpg
    on boot this is what i see.jpg
    50.6 KB · Views: 57

stan

Well-Known Member
Joined
Mar 19, 2018
Messages
974
Reaction score
1,104
Credits
9,041
I just set up a dual boot Windows/Linux on a single hard drive. At first GRUB loaded when booting and I could choose either OS, but after updating Windows it started to boot straight into Windows and GRUB no longer loaded. This is what worked for me:

1. Boot into Windows
2. Open cmd.exe as an Administrator
3. Enter the following command:
Code:
bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi
4. Reboot (and GRUB should load)

NOTE: Pay very careful attention to the command above... the difference between / and \ characters, and the use of "curly braces" (not parentheses). Copy/paste is the best way. If this fails, you may need to capitalize Ubuntu since you show that you have a folder by that name in your screenshot.... but use lower case first as it is the more common folder name.

If this works for you, save these instructions because you may have this problem again in the future, such as when Windows updates, as I did. If you switch to Linux Mint, these instructions will still work, but other distros will have a different folder name and not "ubuntu."
 

stan

Well-Known Member
Joined
Mar 19, 2018
Messages
974
Reaction score
1,104
Credits
9,041
I can select F9 on start up and that brings up (Change boot device order) and i can boot into Linux, and it boots just fine.
And sometimes that is the only way. Different computers behave differently sometimes. At least this way will work, if nothing else.
 
OP
C

Cbrew

New Member
Joined
Oct 21, 2021
Messages
11
Reaction score
5
Credits
142
I just set up a dual boot Windows/Linux on a single hard drive. At first GRUB loaded when booting and I could choose either OS, but after updating Windows it started to boot straight into Windows and GRUB no longer loaded. This is what worked for me:

1. Boot into Windows
2. Open cmd.exe as an Administrator
3. Enter the following command:
Code:
bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi
4. Reboot (and GRUB should load)

NOTE: Pay very careful attention to the command above... the difference between / and \ characters, and the use of "curly braces" (not parentheses). Copy/paste is the best way. If this fails, you may need to capitalize Ubuntu since you show that you have a folder by that name in your screenshot.... but use lower case first as it is the more common folder name.

If this works for you, save these instructions because you may have this problem again in the future, such as when Windows updates, as I did. If you switch to Linux Mint, these instructions will still work, but other distros will have a different folder name and not "ubuntu."

Stan, Thank you for your reply. This is actually one of the troubleshooting steps I found along the way. I thought this would work honestly, because it should be telling the machine to use GRUB I use this command (Just did it again to be sure) and it says operation successful, but the windows boot manager is still popping up at boot and not showing Ubuntu as an option to boot into.
 

stan

Well-Known Member
Joined
Mar 19, 2018
Messages
974
Reaction score
1,104
Credits
9,041
Did you try the command also with Ubuntu capitalized, instead of lower case?
 
OP
C

Cbrew

New Member
Joined
Oct 21, 2021
Messages
11
Reaction score
5
Credits
142
Did you try the command also with Ubuntu capitalized, instead of lower case?

Yes, I was super hopeful because that was something i hadn't tried. still no joy though :/

I'm hoping that your comment "And sometimes that is the only way. Different computers behave differently sometimes. At least this way will work, if nothing else." isn't the case, but that was my fear, something about this specific machine's bios won't allow Grub to run for whatever reason and I just don't have the option to fix it. I considered that. I just hope not because the purpose behind this set up is i'm doing a project where i'm taking this old laptop that has a busted touchpad and keyboard and i'm repurposing it to build an All in one touchscreen PC for my kids. My next step is to take apart the laptop and create a case to fix it to the back of this touchscreen monitor i bought on ebay for cheap... at any rate, I learned a bit about linux in college and It just is a fun OS and i'd love to be able to have both options... If i absolutely can't figure this out i'll just have to decide which OS to go with.
 
OP
C

Cbrew

New Member
Joined
Oct 21, 2021
Messages
11
Reaction score
5
Credits
142
Did you try the command also with Ubuntu capitalized, instead of lower case?

Stan, Along those lines, I just found this on a superuser thread... Now this is discussing an issue a guy had with dual booting Win8 and Ubuntu on an HP Laptop:

"This issue seems built into the HP UEFI/BIOS - it will only accept a /Microsoft folder for boot. Having had this issue on a HP laptop, and having tried a number of fixes, I finally just replaced the Windows boot EFI file with the Linux version:

  • Make an image of the HDD lest something go wrong.
  • Move the MS boot file, /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi, to an new folder, e.g. /boot/efi/EFI/old-Microsoft/Boot/bootmgfw.efi
  • Copy the contents of /boot/efi/EFI/ubuntu/shimx64.efi (or grubx64.efi) to /boot/efi/EFI/Microsoft/Boot/.
  • Rename shimx64.efi (or grubx64.efi) to bootmgfw.efi.
  • Change the path for the Windows UEFI bootmgfw.efi entry in grub to the location of the MS boot file, e.g. /boot/efi/EFI/old-Microsoft/Boot/bootmgfw.efi. [Thanks to @BrainRenticus for reminding me of this essential step!]
I'm considering trying this, but the obvious flaw in this approach would be that if windows pushes an update to EFI it'll wipe this out anyway and i'd be back to square 1. This is from 2018 though... Not super old but was hoping there was a better fix out there.
 

stan

Well-Known Member
Joined
Mar 19, 2018
Messages
974
Reaction score
1,104
Credits
9,041
Usually you can get GRUB to work, but it can be challenging. And it can be frustrating when Windows breaks it again and again. Windows does not like to play well with others, and I think that Windows 10 has been the worst of all. :(

One thing that comes to mind that may have caused this.... you installed GRUB on the Linux hard drive (probably /dev/sdb) and not the Windows hard drive (probably /dev/sda). This kind of explains why F9 will let you boot either one. But it's just a guess.

Having multiple Ubuntu entries in the boot list makes me think that something went wrong earlier, maybe earlier attempts to install Ubuntu. It shouldn't look like that. But I could be wrong above, and all those Ubuntu boot entries could be on the Windows drive, /dev/sda, or they could be mixed between both drives.

You might try Boot Repair... it helps some folks. Or efibootmgr may help. A last resort (the one I'm most likely to do) is to reinstall one or both operating systems from scratch. I've been doing that a lot this week, unfortunately. If you start over from scratch, you might reconsider using separate drives... the second drive could instead be used for storage, like Timeshift snapshots. Following a different sequence of installation may make everything work as you expect.
 
OP
C

Cbrew

New Member
Joined
Oct 21, 2021
Messages
11
Reaction score
5
Credits
142
Stan,
I apologize i'm new to this forum... I just tried replying 3 times and they're all sitting in moderator review.
 
OP
C

Cbrew

New Member
Joined
Oct 21, 2021
Messages
11
Reaction score
5
Credits
142
Stan, maybe you can help me here, you stated (you installed GRUB on the Linux Drive and not the windows Drive - IS that it? Because I see a 512MB partition on the Linux drive that's labeled EFI and of course i see the EFI partition on the Windows Disk. Was the Linux install supposed to put this on the windows drive?

Also, I sent another reply but i copied something that has links in it and i think that it's not posting (Awaiting Moderator) someone described a similar situation in a SuperUser Thread, and basically it said that he believed the issue was inherent to HP laptop bios - said it would only accept a /Microsoft folder for boot. His fix was the following:
  • Move the MS boot file, /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi, to an new folder, e.g. /boot/efi/EFI/old-Microsoft/Boot/bootmgfw.efi
  • Copy the contents of /boot/efi/EFI/ubuntu/shimx64.efi (or grubx64.efi) to /boot/efi/EFI/Microsoft/Boot/.
  • Rename shimx64.efi (or grubx64.efi) to bootmgfw.efi.
  • Change the path for the Windows UEFI bootmgfw.efi entry in grub to the location of the MS boot file, e.g. /boot/efi/EFI/old-Microsoft/Boot/bootmgfw.efi. [Thanks to @BrainRenticus for reminding me of this essential step!]
I could see this working but every time windows pushes an update to the EFI it would just wipe this out and need to be done again.

Thoughts?
 

stan

Well-Known Member
Joined
Mar 19, 2018
Messages
974
Reaction score
1,104
Credits
9,041
Stan,
I apologize i'm new to this forum... I just tried replying 3 times and they're all sitting in moderator review.
When you're new you cannot post URL's. A mod will release your posts soon.
 

stan

Well-Known Member
Joined
Mar 19, 2018
Messages
974
Reaction score
1,104
Credits
9,041
maybe you can help me here, you stated (you installed GRUB on the Linux Drive and not the windows Drive - IS that it? Because I see a 512MB partition on the Linux drive that's labeled EFI and of course i see the EFI partition on the Windows Disk. Was the Linux install supposed to put this on the windows drive?
This gets into the "different computers" and "different behaviors." HP makes many different models, with many different BIOS/UEFI. Same for Dell, Lenovo, Acer, Asus, and so on. And BIOS/UEFI is implemented differently in many of these cases.

The steps you outlined from SuperUser may work too... different computers, different behaviors. You can try it, and if it works, like I said before, save the instructions! You'll likely need them again.

If something gives you a quick and easy fix... life is good. If you spend a lot of time trying many things, you could also have reinstalled and started over in less time maybe. All choices for you as to which way seems best at the time.

Also... REMEMBER: making changes to your bootloaders can get you into deep trouble with nothing booting (though that is rather rare). I do hope that you have anything really important backed up to USB or DVD so that you don't lose anything. Better safe than sorry. :oops:;)
 
OP
C

Cbrew

New Member
Joined
Oct 21, 2021
Messages
11
Reaction score
5
Credits
142
This gets into the "different computers" and "different behaviors." HP makes many different models, with many different BIOS/UEFI. Same for Dell, Lenovo, Acer, Asus, and so on. And BIOS/UEFI is implemented differently in many of these cases.

The steps you outlined from SuperUser may work too... different computers, different behaviors. You can try it, and if it works, like I said before, save the instructions! You'll likely need them again.

If something gives you a quick and easy fix... life is good. If you spend a lot of time trying many things, you could also have reinstalled and started over in less time maybe. All choices for you as to which way seems best at the time.

Also... REMEMBER: making changes to your bootloaders can get you into deep trouble with nothing booting (though that is rather rare). I do hope that you have anything really important backed up to USB or DVD so that you don't lose anything. Better safe than sorry. :oops:;)
Stan,
Luckily These are just blank drives with the OS's loaded and that's it.
 

stan

Well-Known Member
Joined
Mar 19, 2018
Messages
974
Reaction score
1,104
Credits
9,041
Stan,
Luckily These are just blank drives with the OS's loaded and that's it.
And that really speeds up the time needed to reinstall, if you decide to go that way.

Some folks want to use separate drives so they can pull one later and put it in another machine. And that too can cause trouble. There is no one-size-fits-all solution to make dual booting successful. When possible, I would much rather use separate computers so each OS has total control of the hardware, not shared control.
 
Last edited:

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
6,627
Reaction score
5,391
Credits
19,641
@Cbrew welcome to linux.org :)

I approved your Post now at #9 - it came over my desk DownUnder at 4:43AM my time and I was catching zzz's

You're in good hands with Stan.

More coffee

Chris Turner
wizardfromoz
 
OP
C

Cbrew

New Member
Joined
Oct 21, 2021
Messages
11
Reaction score
5
Credits
142
@Cbrew welcome to linux.org :)

I approved your Post now at #9 - it came over my desk DownUnder at 4:43AM my time and I was catching zzz's

You're in good hands with Stan.

More coffee

Chris Turner
wizardfromoz

Appreciate that, Unfortunately, i just can't resolve this issue. Even the alternative i found at a different site, it wouldn't allow me to copy the Ubuntu Efi File to replace the one in the Windows EFI folder.. I'm pretty much at a loss. I think i'm just gonna give up and deal with having to manually boot into Ubuntu by hitting f9 and selecting it as an option. I hate giving up though I really struggle with letting go of something I'm pretty sure should work.

At some point though it's not worth the grief. Thanks anyways to all.
 

Mike13Foxtrot

Active Member
Joined
Aug 9, 2020
Messages
234
Reaction score
238
Credits
1,987
On the Dual Boot Desktop I just built I boot to the Linux SSD in Bios, first thing that pops up is Grub..

1. Boot to Linux Mint
2. Boot To Linux Mint Command Prompt
3. Boot to Windows OS
4. Boot to Bios

Only issue was an AMD CPU Upgrade (Yeah Like after 2 months old) ;) And Bios reverted back to the NVME boot. Just had to change it back to Linux SSD. Because Linux sees Windows.

On HP laptops I have found it does not like dual booting without the On hold Del option. Start with Windows and it will steal your Linux boot options. Maybe not right away but some update will eventually do so.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top