Cannot get rid of markers on Mutt

marianogedisman

New Member
Joined
Apr 21, 2021
Messages
12
Reaction score
1
Credits
115
Hello! I'm trying to get rid of the "+" sign markers on Mutt. I've set the unset markers and also tried with set markers = no on muttrc but still can't get it to work.
I've debugged Mutt and it does read muttrc from my local directory, however, there must be something else I'm missing but I cannot find why.
I've googled to no avail but could not find anyone going through the same issue.
Also, the man pages for Mutt tells me that this flag should be enough to get rid of markers, but they're still there.

Any help would be appreciated:

Distro: BSD
Mutt -v 2.2.10 (2023-03-25)


My muttrc:

Code:
# Starter muttrc file, with just a few suggestions and settings.
#
# This file purposely doesn't include hooks, keybinding, macros, colors, etc.
# Read the manual, explore, and have fun!
#

###############
# Identity
#
set realname = "Maria Noged"
set from = "<redacted>"

## If you have another address:
#alternates "^mutt@example\.com$"
#
## Or, if you use the entire domain:
#alternates "@example\.com$"
#set reverse_name
#
################
## Example: local mailboxes
##
## Some people use mbsync or getmail to retrieve their mail locally.
##
#set folder = ~/Mail           # This has the shortcut '+' or '='
#set spoolfile = "+inbox"      # This has the shortcut '!'
#set record = "+sent"
#set trash = "+trash"
#set postponed = "+drafts"
#
#mailboxes ! +mutt +family +work
#
###############
# Example: Gmail over IMAP
#
set imap_user = "<redacted>"



# To avoid storing your password in the .muttrc:
# echo -n 'mypassword' | gpg --encrypt -r 0x1234567890ABCDEF > ~/.mutt/account.gpg
#set imap_pass = "`gpg --batch -q --decrypt ~/.mutt/account.gpg`"

set folder = imaps://imap.gmail.com/
set spoolfile = "+INBOX"
unset record                # Gmail auto-stores in "+[Gmail].Sent Mail"
unset trash                 # Unset, deletion will remove labels
set postponed = "+[Gmail].Drafts"
set timeout = 60
set mail_check = 5



###############
# Pager settings
#
ignore *
unignore From Message-ID Date To Cc Bcc Subject

set pager_stop
unset markers

# Prefer plain text to html.
# However, for brain dead clients that bundle attachments inside a
# multipart/alternative, prefer that alternative.
alternative_order multipart/mixed multipart/related text/plain

# Consult mime.types for determining types of these attachments
mime_lookup application/octet-stream

# This requires a ~/.mailcap entry with the copiousoutput flag, such as:
# text/html; lynx -dump -width ${COLUMNS:-80} %s; nametemplate=%s.html; copiousoutput
auto_view text/html

###############
# Index settings
#
#set quit = ask-yes
set sort = threads

# Remember to `mkdir -p ~/.mutt/hcache` first:
set header_cache= "~/.mutt/hcache"
       
###############
# Message composition settings
#
set edit_headers

# set editor = "emacsclient -a emacs -t"
set editor = "vim"

set mime_type_query_command = "xdg-mime query filetype"

# msmtp is a solid SMTP client.
# mutt also has built-in SMTP, or you can use an MTA like exim4 or postfix.
#set sendmail = "/usr/bin/msmtp"

# lbdb is a versatile contact query tool.
# Invoke via ctrl-t in an address prompt
set query_command = "/usr/bin/lbdbq"

###############
# GnuPG
#
#unset crypt_use_gpgme
#source /usr/local/share/doc/mutt/samples/gpg.rc
#set pgp_default_key = "0x1234567890ABCDEF"
#set crypt_opportunistic_encrypt
#set postpone_encrypt

Mod edit - removed email address
 
Last edited by a moderator:


try without the spaces maybe?
set markers=no

Though, your other stuff is working i imagine.

I think 'unset markers' just means 'use markers as you would with default settings'

Edit: also, maybe see if there's a global muttrc (in /etc/ maybe) that could be overriding it?
 
Last edited:
I'm reading you can try launching Mutt with the -n option to disable any user configuration files and see if the set markers=no command works as expected.

While in mutt, like in vi/vim, hit ":" then type set markers=no
 
try without the spaces maybe?
set markers=no
Hello @Rob! Thanks for your help! Tried with no spaces, did not work.


Though, your other stuff is working i imagine.
Yessir.

I think 'unset markers' just means 'use markers as you would with default settings'

Edit: also, maybe see if there's a global muttrc (in /etc/ maybe) that could be overriding it?
Running Mutt on debug mode spits out this:
Code:
Reading configuration file '/usr/local/Cellar/mutt/2.2.10/etc/Muttrc'.
[2023-04-04 23:11:36] Reading configuration file '/Users/maria/.config/mutt/muttrc'.

First config file (global) is all commented out. Second one is mine.
 
I'm reading you can try launching Mutt with the -n option to disable any user configuration files and see if the set markers=no command works as expected.
Did this, still nothing.
While in mutt, like in vi/vim, hit ":" then type set markers=no
Also done this, nothing.

I'm starting to scratch my head really hard now... :rolleyes:
 
Hmm... I seem to recall that @JasKinasis deals with email in the terminal.

I hate to toss him under the bus, but he's also good at debugging weird stuff.
 
Hmm... I seem to recall that @JasKinasis deals with email in the terminal.

I hate to toss him under the bus, but he's also good at debugging weird stuff.
Thank you @KGIII ! I still haven't figured out how to get rid of those.
I know it's some of the options, because if I start an IMAP account from scratch, they're not there. But where does the problem lay in all my rc file? I have no idea.
 
Hmm... I seem to recall that @JasKinasis deals with email in the terminal.

I hate to toss him under the bus, but he's also good at debugging weird stuff.
True - I haven't used mutt in quite a while though. I used to have it installed on my laptop before my HDD died. Since replacing the HDD, I haven't actually got around to re-installing mutt. I often deal with email on my phone nowadays. And even then, I rarely check my emails. Last time I checked, my gmail account had over 2000 unread emails and my less used, protonmail account had somewhere in the region of 100.

I hope nobody has tried to contact me via email regarding anything serious, there might be another Nigerian prince needing help to get his dead dads money out of the country, ha ha!

Getting back on topic:
@marianogedisman
Assuming that these marks we're talking about are the + signs that denote wrapped text:
To remove those, as Rob said, it should just be a case of putting the line unset markers in your .muttrc.
My initial thought is that if it's not working, perhaps it’s a bug with mutt?! But you said that you set up mutt using a different imap account and ‘unset markers’ is being respected.

Another alternative would be to try using: set nomarkers instead. Mutt supports this Vim-like syntax.

Also, when running mutt, what is the output of entering the following command?:
Code:
set ?markers
, that should tell you the actual state of that variable.

Perhaps also try putting the set nomarkers command at the very end of your .muttrc?!
Perhaps one of the other options you’re using is automatically turning it back on?!

The only other thing I can think of is maybe smart_wrap needs to be enabled (or perhaps disabled) before you can unset markers.

So inside mutt, try running set ?smart_wrap, to see what it’s currently set to.
Then run set invsmart_wrap which should toggle it to its opposite state, then try setting set nomarkers again. And see if that works.

If that does work, then inside your .muttrc, on the line before setting nomarkers, set smart_wrap to the appropriate value.

So for example if querying the state of smart_wrap said that it was off and turning it back on worked - add the line set smart_wrap before the line where you set nomarkers.

If turning smart_wrap off worked, then add set nosmart_wrap instead.

Hopefully that will work.
As I said, perhaps try adding those lines at the end of your .muttrc.

Other than that, I’m out of ideas!

I’ve had a look through the mutt manual at:
And I can’t really see anything else that might be causing this.
 
True - I haven't used mutt in quite a while though. I used to have it installed on my laptop before my HDD died. Since replacing the HDD, I haven't actually got around to re-installing mutt. I often deal with email on my phone nowadays. And even then, I rarely check my emails. Last time I checked, my gmail account had over 2000 unread emails and my less used, protonmail account had somewhere in the region of 100.

I hope nobody has tried to contact me via email regarding anything serious, there might be another Nigerian prince needing help to get his dead dads money out of the country, ha ha!
What are you using now, may I ask? :)

LOL @ the Nigerian prince needing help xD I've actually pictured a Nigerian bloke dressed as a prince in front of a 90's style PC writing emails to you xD

Getting back on topic:
@marianogedisman
Assuming that these marks we're talking about are the + signs that denote wrapped text:
To remove those, as Rob said, it should just be a case of putting the line unset markers in your .muttrc.
My initial thought is that if it's not working, perhaps it’s a bug with mutt?! But you said that you set up mutt using a different imap account and ‘unset markers’ is being respected.

Another alternative would be to try using: set nomarkers instead. Mutt supports this Vim-like syntax.

Tried set nomarkers nothing.
Also, when running mutt, what is the output of entering the following command?:
Code:
set ?markers
, that should tell you the actual state of that variable.

markers is unset

Perhaps also try putting the set nomarkers command at the very end of your .muttrc?!
Perhaps one of the other options you’re using is automatically turning it back on?!

Tried at the end and at the beginning. nothing :-/
The only other thing I can think of is maybe smart_wrap needs to be enabled (or perhaps disabled) before you can unset markers.
So inside mutt, try running set ?smart_wrap, to see what it’s currently set to.
Then run set invsmart_wrap which should toggle it to its opposite state, then try setting set nomarkers again. And see if that works.
Tried this, didn't work either. I'm starting to get scared ha!

If that does work, then inside your .muttrc, on the line before setting nomarkers, set smart_wrap to the appropriate value.

So for example if querying the state of smart_wrap said that it was off and turning it back on worked - add the line set smart_wrap before the line where you set nomarkers.

If turning smart_wrap off worked, then add set nosmart_wrap instead.

Hopefully that will work.
As I said, perhaps try adding those lines at the end of your .muttrc.

Other than that, I’m out of ideas!

I’ve had a look through the mutt manual at:
And I can’t really see anything else that might be causing this.

Argh, all of these didn't work, damn! I will try with a different muttrc file and see if my current file is contaminated with something causing it to fail.

Thanks a lot for taking the time to help me @JasKinasis ! I'll surely keep you guys posted of what happens when I change the file.
 
A bit off-topic, but when folks talk about the Nigerian Prince scam emails, it reminds me of this:


See? They really did need someone to help 'em launder millions and millions of dollars!

(I don't think I've ever seen any follow-up to that story.)
 


Top