Can't bind to seemingly free ports

benw

New Member
Credits
36
Hello,

I'm running Ubuntu 18.04 on a Strato V-server. I'm trying to run Pydio Cells (very cool free file sharing and collab platform!). I've had some problems during the installation and I think I'm close to finishing it. I made a post on their forum and got help from some really wonderful people. The problem doesn't seem Cells related but rather Linux related.
I'm running Cells as a systemd service behind an Nginx reverse proxy. It's all working except for the deletion and moving files. When I try to move/delete I get an error that the connection to some high numbered ports is refused (the binding to other high numbered ports works) so one of the services is not working.
I've tried ```lsof -i : port_number``` for all the ports that get refused and they're not bound to anything else.
Whlie the service is not running I did ```nc -lp port_number > /dev/null``` and got no error (to test that I can bind to the port). Right now I'm binding Cells to the 10.0.0.1:8080 and using the reverse proxy to get to it. I've also tried binding to 0.0.0.0:8080, 127.0.0.1:8080 and localhost:8080 and it didn't make a difference.
I talked to the provider of the server and they told me that they're running it through Hypervisor so adding an additional IP is not possible which is why I tried to bind it to ```localhost```. There are no ports blocked by the provider.
The port is free, nginx error logs are empty, apparmor is disabled and I tried to disable ufw. The ```journalctl -u cells``` doesn't give any useful information beyond the connection refused.
Any ideas what else can I try?

Thanks,

Ben
 


dos2unix

Well-Known Member
Credits
3,584
It's a little confusing, but netstat and lsof don't always show all the bound ports.

There's a long explanation, I don't have time to go into here.

sudo lsof -i -P -n | grep LISTEN

netstat -tulpn | grep LISTEN

If these don't work, you can try rpcinfo

The other two things I would check is SElinux and the firewall.
These can also block ports.
 

benw

New Member
Credits
36
It's a little confusing, but netstat and lsof don't always show all the bound ports.

There's a long explanation, I don't have time to go into here.

sudo lsof -i -P -n | grep LISTEN

netstat -tulpn | grep LISTEN

If these don't work, you can try rpcinfo

The other two things I would check is SElinux and the firewall.
These can also block ports.
Hi,

thanks for the quick answer. I tried the lsof and netstat like you recommended it and both ports seem free, but the app is saying that the connection was refused.
I don't have SELinux installed (service is not running and there's no selinux folder in /etc, tell me if I missed something).
What do you mean "try rcpinfo"? rpcbind was disabled, I enabled the service and turned it on, the output I get when I run rpcinfo is:
program version netid address service owner
100000 4 tcp6 ::.0.111 portmapper superuser
100000 3 tcp6 ::.0.111 portmapper superuser
100000 4 udp6 ::.0.111 portmapper superuser
100000 3 udp6 ::.0.111 portmapper superuser
100000 4 tcp 0.0.0.0.0.111 portmapper superuser
100000 3 tcp 0.0.0.0.0.111 portmapper superuser
100000 2 tcp 0.0.0.0.0.111 portmapper superuser
100000 4 udp 0.0.0.0.0.111 portmapper superuser
100000 3 udp 0.0.0.0.0.111 portmapper superuser
100000 2 udp 0.0.0.0.0.111 portmapper superuser
100000 4 local /run/rpcbind.sock portmapper superuser
100000 3 local /run/rpcbind.sock portmapper superuser

is there anything else I can try?

Thanks,

Ben
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Staff online


Latest posts

Top