Can't boot any distro from usb


New Member
Jun 16, 2022
Reaction score
I am kindda new to all of this so ask for more info if needed.
When I try to install parrot from my usb I go trough graphical install and after that it just blackscreens and it doesn't accept any keyboard input, it is just frozen (kali, backbox, ubuntu, all the same story)
I tried with and without windows installed on the disk, tried with legacy and uefi only, I have secure boot disabled.( This is the motherboard i have: H310M PRO-VDH PLUS (MS-7C09) )
I had linux installed on my pc a few moths ago so i don't know what happened this time.
pls send help.

Welcome to the forums
usual problems when installing
corrupt download
bad burn of the ISO to the installation medium
dodgy pen-drive [use a new quality branded pen-drive of 8 or 16gb preferably ] clean and formatted Fats or X Fats
bad hard-drive
Last edited:
+1 what Brickwizard said. Depending on the distro, you may be able to verify the USB ISO is ok from the boot menu. Usually it's something akin to "verify boot media".

Your board appears to have an onboard Intel VGA chip. Did you install a 2nd video card? If so, what model?

I'm going to make an observation here, that you are attempting to use Kali, Parrot and Backbox. Those are pentesting distros, and are for experienced Linux users. New users should stick with mainstream distros, e.g. Ubuntu, Mint or Fedora.
Thanks for the replys.

So my pen-drive is fine i think because i could install linux on a laptop, there i had no issues.
I used rufus and balenaEtcher, in rufus i set the partition scheme with gpt (like my ssd, where i want to install it, i tried with mbr aswell) and for the fs i used fat32 and ntfs, both they dont work in my pc but work for the laptop.
Windows does install properly so i dont understand what's the issue.

SlowCoder, no i have a single gpu, my specs are: rx570, i3 9th gen, 16gb ram, a ssd and hdd.
Windows does install properly make sure windows quick-start is disabled in the BIOS..
Rufus often causes problems

If you are trying to install any of the pen-testing distributions, you need to be fully conversant with how Linux works and the use of the terminal, If you're not then don't bother as they are designed for experienced professionals, Kali in particular is so designed that a newbie will struggle, [their own forums won't even answer questions from newbies], also these distributions are no good as everyday desktop Linux as they do not carry all the codecs and drivers the mainstream distributions do and installing anything other than approved applications in the repository will often break the Linux installation. [except Parrot HOME edition which can be used as an everyday desktop, for people to learn about Linux before they move on to pen-testing
one final point on pen-testing, Professionals do not use these distributions on their main drives, they will use a VM, a persistent pen-drive or a dedicated machine
So i could install it if set nomodeset in grub screen (parrot os home edition, latest version). I ran a update and upgrade to install necessary drivers.Then when i reboot it with parrot installed it would only work with nomodeset again. From what i understood it is a issue with my gpu frimware not being installed or something like that.

I dont mind this issues i like to thinker with them and i want a pen testing distro to learn the tools. I had it in a vm but i want to give it anothet try as a daily, and if i feel like i need windows in the future i will just install it, no big deal.
Thanks again for your time.
Ok so the Linux drivers for the rx570, are in the kernel driver set,
if you can get Linux to boot, open terminal and run inxi -Fnxxz copy and paste the report back here. inxi should be included in your Parrot installation

I dont mind this issues i like to thinker with them and i want a pen testing distro to learn the tools

as I said before, unless you are proficient at using Linux, know and understand the terminal basic commands, you're not ready
many have tried to jump in with both feet and most fail, then blame Linux, not their own impatience.
Kernel: 5.16.0-12parrot1-amd64 arch: x86_64 bits: 64 compiler: gcc
v: 11.2.0 Desktop: MATE v: 1.24.1 wm: marco dm: LightDM
Distro: Parrot OS 5.0 (Electro Ara) base: Debian parrot
Type: Desktop System: Micro-Star product: MS-7C09 v: 1.0
serial: <superuser required>
Mobo: Micro-Star model: H310M PRO-VDH PLUS (MS-7C09) v: 1.0
serial: <superuser required> UEFI: American Megatrends v: 1.30
date: 09/04/2019
Info: quad core model: Intel Core i3-9100F bits: 64 type: MCP
arch: Coffee Lake rev: A cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
Speed (MHz): avg: 800 min/max: 800/4200 cores: 1: 800 2: 800 3: 800
4: 800 bogomips: 28808
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: ASUSTeK driver: N/A pcie: speed: 8 GT/s lanes: 16 bus-ID: 01:00.0
chip-ID: 1002:67df
Display: x11 server: X.Org v: 1.20.11 compositor: marco v: 1.24.1 driver:
X: loaded: vesa unloaded: fbdev,modesetting,radeon gpu: N/A display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96
Monitor-1: default res: 1920x1080 size: N/A
OpenGL: renderer: llvmpipe (LLVM 11.0.1 256 bits) v: 4.5 Mesa 20.3.5
compat-v: 3.1 direct render: Yes
Device-1: Intel 200 Series PCH HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a2f0
Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s
lanes: 16 bus-ID: 01:00.1 chip-ID: 1002:aaf0
Device-3: C-Media USB Audio Device type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-2:2 chip-ID: 2b0d:0031
Sound Server-1: ALSA v: k5.16.0-12parrot1-amd64 running: yes
Sound Server-2: PulseAudio v: 14.2 running: yes
Sound Server-3: PipeWire v: 0.3.19 running: yes
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8168 v: 8.048.03-NAPI pcie: speed: 2.5 GT/s
lanes: 1 port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168
IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Local Storage: total: 1.13 TiB used: 6.61 GiB (0.6%)
ID-1: /dev/sda vendor: Kingston model: SA400S37240G size: 223.57 GiB
speed: 6.0 Gb/s serial: <filter>
ID-2: /dev/sdb vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB
speed: 6.0 Gb/s serial: <filter>
ID-1: / size: 206.14 GiB used: 6.61 GiB (3.2%) fs: btrfs dev: /dev/sda2
ID-2: /boot/efi size: 299.4 MiB used: 568 KiB (0.2%) fs: vfat
dev: /dev/sda1
ID-3: /home size: 206.14 GiB used: 6.61 GiB (3.2%) fs: btrfs
dev: /dev/sda2
ID-1: swap-1 type: partition size: 17.14 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda3
System Temperatures: cpu: 29.8 C mobo: 27.8 C
Fan Speeds (RPM): N/A
Processes: 194 Uptime: 23m Memory: 15.58 GiB used: 2.07 GiB (13.3%)
Init: systemd v: 250 runlevel: 5 Compilers: gcc: 10.2.1 alt: 10/11
Packages: apt: 1977 Shell: Bash v: 5.1.4 running-in: mate-terminal
inxi: 3.3.16
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: ASUSTeK driver: N/A
um..something missing here, Looks like it's not loaded the kernel AMD drivers from xorg
Eventually i fixed it by removing the nomodeset, that caused the issues, because it forced the gpu drivers to not load when booting and replaceing it with amdgpu.dc=0 and amdpgu.dpm=0 for more info view this and this for more info on nomodeset.

This helped me now i have my gpu detected by the kernel:

Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
driver: amdgpu v: kernel
Display: x11 server: X.Org v: 1.20.11 driver: X: loaded: amdgpu
unloaded: fbdev,modesetting,vesa gpu: amdgpu resolution: 1920x1080~60Hz
OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.44.0
5.16.0-12parrot1-amd64 LLVM 11.0.1)

Is this fix good if the kernel updates?
Is this fix good if the kernel updates?
Excellent, so you're now up and running, and NO updates should not affect your settings

Members online

Latest posts