Can't connect to my bluetooth earbuds in Linux (Manjaro KDE Latest)

Prayag Jain

New Member
Credits
31
I use the latest version of Manjaro KDE, and I’m unable to connect my Bluetooth earbuds. Pairing works just fine but connection doesn’t. They connect for half a second and then disconnect. I tried using bluetoothctl but I get this error: org.bluez.Error.failed. I also have a Bluetooth headset (Infinity Glide 500) which works. I tried to ask this question on Reddit but couldn’t get any reply :( These earbuds work on Windows but not on Linux. Please help me! I tried all the solutions in the Arch Wiki, but couldn’t get it fixed. I will appreciate any help! Thanks in advance.
 
Last edited:


f33dm3bits

Gold Member
Gold Supporter
Credits
12,505
I've noticed that whenever I install pulseaudio-bluetooth and pulseaudio-modules-bt, they get removed after the next reboot.
Must be a Manjaro thing, bluetoothctl allows you to connect and pair your device to bluetooth, you need then need the package pulseaudio-bluetooth for bluetooth support for pulseaudio in order to for pulseaudio to see your bluetooth device as an audio device.
 

Members online


Top