Can't ssh into Fedora 36 Workstation from root

tfmeier

New Member
Joined
Nov 8, 2022
Messages
2
Reaction score
1
Credits
21
This was running fine. I have a Fedora 36 workstation that runs kvm. I connect to this workstation via root and this was working fine.

I had a power failure and now when I want to connect via ssh (i.e. ssh [email protected]<IP address> I get a 'Permission denied, please try again error'. Not sure this is coincidence...

I know the root password is correct as I can logon using root via the server console.

I can also successfully connect to the F36 workstation via ssh using another account so 'sshd' must be running.

What could be the issue here? Note: I need this root access as I'm using kvm under the root account (this is all on a local network so I'm not concerned that I'm not using best practice here
 


dos2unix

Well-Known Member
Joined
May 3, 2019
Messages
1,652
Reaction score
1,265
Credits
10,737
Fedora disables this by default now in 36 and newer.

Edit your /etc/ssh/sshd_config file.
Find the Line that starts with #PermitRootLogin
Uncomment it and change it to.
PermitRootLogin yes (delete the rest of the line)
Then you need to enable and start sshd

systemctl enable sshd
systemctl start sshd
 
Last edited:
OP
T

tfmeier

New Member
Joined
Nov 8, 2022
Messages
2
Reaction score
1
Credits
21
Fedora disables this by default now in 36 and newer.

Edit your /etc/ssh/sshd_config file.
Find the Line that starts with #PermitRootLogin
Uncomment it and change it to.
PermitRootLogin yes (delete the rest of the line)
The you need to enable and start sshd

systemctl enable sshd
systemctl start sshd
Thanks for that. It worked :)
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top