Changes To Grub Customizer LM 21.1 Cinnamon <Solved>

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
8,627
Reaction score
7,586
Credits
35,284


OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,915
Reaction score
1,466
Credits
16,263
Also see my Post in my tread on brightening grub

https://www.linux.org/threads/brighten-up-your-day-grub-menu-theming-wizard-style.35683/post-129308

If you add the line in /etc/default/grub - some distros prefer ,png over .jpg/.jpeg so I usually just use a picture in /boot/grub.

Also, you can have more than one picture in /boot/grub - it will take the first one alphabetically.

Wizard
Tried both and unfortunately it doesn't work.
I still have a all black background with white letters.
 

kc1di

Well-Known Member
Joined
May 14, 2021
Messages
1,622
Reaction score
1,438
Credits
11,698
Hi Alexzee can you give us a look at your /etc/default/grub file?
thanks
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,915
Reaction score
1,466
Credits
16,263
Hi Alexzee can you give us a look at your /etc/default/grub file?
thanks
Code:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=menu
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
GRUB_BACKGROUND=/boot/grub/Ocean.png

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1920x1080


# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
 
Last edited:

osprey

Well-Known Member
Joined
Apr 15, 2022
Messages
682
Reaction score
567
Credits
6,364
Alexzee ... just checking: did you convert the Ocean.jpeg to Ocean.png using the convert command in post #37? Does the command:
Code:
identify Ocean.png
confirm that the pic is 8-bit and RGB format?

You could also try commenting out the config: GRUB_GFXMODE=1920x1080, in your grub file to let grub decide it's own mode. Dunno how relevant that it, but in my case, it's commented out and works.
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,915
Reaction score
1,466
Credits
16,263
@kc1di,

Post #45 helped!
I edited the /etc/default/grub file and got rid of the quotation marks before the forward slash before boot and after the png and updated grub.
This is what I changed it too and rebooted.
Code:
GRUB_BACKGROUND=/boot/grub/Ocean.png

I now have the picture when the Grub Menu appears!
YAY!
 

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
8,627
Reaction score
7,586
Credits
35,284

kc1di

Well-Known Member
Joined
May 14, 2021
Messages
1,622
Reaction score
1,438
Credits
11,698
Glad it's finally working for you , enjoy! :)
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,915
Reaction score
1,466
Credits
16,263
MALIBAL Linux Laptops

Linux Laptops Custom Built for You
MALIBAL is an innovative computer manufacturer that produces high-performance, custom laptops for Linux.

For more info, visit: https://www.malibal.com

Staff online

Members online


Top