Clock cpu limited i7700hq on lenovo y520

ButterMotherboard

New Member
Joined
Jun 18, 2020
Messages
6
Reaction score
0
Credits
43
I have a lenovo Y520-15IKBN laptop, with an I7700-HQ cpu, with a base clock of 2.80 Ghz up to 3.80 Ghz in turbo boost mode, I use archlinux, but changing the distro the situation does not change. The CPU never reaches the maximum clock, at maximum 3.6 Ghz, not even in single core, (tested with various benchmarks), in the past it reached the maximum clock of 3.80 Ghz, for some time no longer. Anyone have any ideas on how to fix it, I'm losing some power for no reason. Thanks
 


Ravel12

Member
Joined
May 30, 2020
Messages
50
Reaction score
15
Credits
360
Run the following to check
cpupower frequency-info
It'll tell you what is the lowest frequency to the highest frequency and whether turbo boost is active.
 
OP
B

ButterMotherboard

New Member
Joined
Jun 18, 2020
Messages
6
Reaction score
0
Credits
43
Code:
> cpupower frequency-info
CPU 0 analysis:
   driver: intel_pstate
   CPUs operating at the same hardware frequency: 0
   CPUs that need to be coordinated by the software: 0
   maximum latency during transition: Cannot determine or is not supported.
   hardware limits: 800 MHz - 3.80 GHz
   available managers: performance powersave
   current operator: the frequency must remain between 800 MHz and 3.80 GHz.
                    The powersave manager can decide which speed to use
                   in this range.
   current CPU frequency: Unable to call hardware
   current CPU frequency: 1.10 GHz (asserted by call to kernel)
   boost state support:
     Supported: yes
     Active: yes

I have already checked with the command, but checking at the time of the stress test (on single core) it never reaches the maximum, as if it were limited, in the past it reached 3.80 Ghz without problems
 

Ravel12

Member
Joined
May 30, 2020
Messages
50
Reaction score
15
Credits
360
Try adding this to your kernel parameters

intel_pstate=disable

It could be the what's holding your scaling back
 
OP
B

ButterMotherboard

New Member
Joined
Jun 18, 2020
Messages
6
Reaction score
0
Credits
43
With intel_pstate = disable the situation does not change, I expected it, the maximum clock reached is always 3.6 Ghz. I don't understand what happened, maybe a bios problem?
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Staff online

Members online


Top