Complicated problem - All linux distros freeze, briefly run sluggish, and some cannot be installed (INFO provided) [Expert needed]

OP
Catalin

Catalin

Member
Joined
Feb 9, 2022
Messages
33
Reaction score
17
Credits
445
Probably through Octopi would be your easiest bet - https://wiki.manjaro.org/index.php?title=Octopi
Awesome!
But I am still not sure about MSI/grub modification. I had pretty much the same issues in the past when I tried to have only Linux on this laptop. However, now I also have Windows 10 on it, dual boot on the SSD, would there be a problem with it if I modify it?
We haven't yet determined what is causing the error reports, 8086 says intel to me [may be wrong] I am thinking sound card till we get more information
And yes, I would also like to know what do you think of that -Fnxxz
 


Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
2,856
Reaction score
1,851
Credits
21,316
reading down the inxi, possible problems

Graphics:
Device-1: Intel HD Graphics 510 vendor: ASUSTeK driver: i915 v: kernel ...... as @Lord Boltar says I would seriously think about changing the driver
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:9d70
Sound Server-1: ALSA v: k5.15.28-1-MANJARO running: yes ...... intel sunrise causes problems on some distributions that dont install Alsa so this look ok at the moment
Network:
Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: ASUSTeK
driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: d000 ....... the 8169 is not the best driver for this card [but should work]

Everything else looks fine to me.

Edit.. Nice to see manjaro is using the latest version of inxi
 
Last edited:

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,801
Reaction score
1,208
Credits
13,408
Awesome!
But I am still not sure about MSI/grub modification. I had pretty much the same issues in the past when I tried to have only Linux on this laptop. However, now I also have Windows 10 on it, dual boot on the SSD, would there be a problem with it if I modify it?
Modifying the grub should not affect anything as far as boot-up goes - and if some some reason it does you can always change it back - see post #39 - I pretty sure this will stop your error message from the bad implementation of MSI from the hardware

Also see here about your
Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: ASUSTeK
driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: d000 ....... the 8169 is not the best driver for this card [but should work]
https://linux-hardware.org/?id=pci:10ec-8136-103c-2ab1
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
2,856
Reaction score
1,851
Credits
21,316
@Catalin @Lord Boltar

Hi Guys
after some digging around, look what I found on the Manjaro site [this reply is made by one of the Manjaro maintainers.]

""OK, the RTL810xE is not even the same things as the RTL8168 chip.
Yes, there is a know regression with the latest r8169 driver in the 5.4.xx kernel series. A commit was introduced that causes the realtek driver to fail if there is no dedicated phy driver available. Unfortunatly the r8169 driver requires the realtek driver to be loaded first.
Here is the commit that is causing the issue:
https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/diff/drivers/net/phy/realtek.c?id=v5.4.32&id2=v5.4.31 11
For now, it is advisable to downgrade the kernel to 4.19.x..
NOTE: You could also possibly try using the realtek third party dkms driver from the AUR:
https://aur.archlinux.org/packages/r8101-dkms/ 11
However, I have not tried this, and thus can not verify it will work. As with anything from the AUR, it is use at your own risk.""
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,801
Reaction score
1,208
Credits
13,408
@Catalin @Lord Boltar

Hi Guys
after some digging around, look what I found on the Manjaro site [this reply is made by one of the Manjaro maintainers.]

""OK, the RTL810xE is not even the same things as the RTL8168 chip.
Yes, there is a know regression with the latest r8169 driver in the 5.4.xx kernel series. A commit was introduced that causes the realtek driver to fail if there is no dedicated phy driver available. Unfortunatly the r8169 driver requires the realtek driver to be loaded first.
Here is the commit that is causing the issue:
https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/diff/drivers/net/phy/realtek.c?id=v5.4.32&id2=v5.4.31 11
For now, it is advisable to downgrade the kernel to 4.19.x..
NOTE: You could also possibly try using the realtek third party dkms driver from the AUR:
https://aur.archlinux.org/packages/r8101-dkms/ 11
However, I have not tried this, and thus can not verify it will work. As with anything from the AUR, it is use at your own risk.""
Yep I seen this as well but was fixed when kernel 5.4.33-3 released apparently it was just 5.4.31 and 32 that the bug was in
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
2,856
Reaction score
1,851
Credits
21,316
Yep I seen this as well but was fixed when kernel 5.4.33-3 released apparently it was just 5.4.31
Strange then it seems to have reared its head again
 

forester

Active Member
Joined
Mar 5, 2022
Messages
404
Reaction score
219
Credits
2,900
Try,

Code:
sudo ./NVIDIA-(driver name and number).run --uninstall

it would be the best way to uninstall if Nvidia allows within driver files
 

forester

Active Member
Joined
Mar 5, 2022
Messages
404
Reaction score
219
Credits
2,900
I tested said driver and if login as root into the directory where the driver file is saved, and, TO UNINSTALL --
Code:
sh NVIDIA-Linux-x86_64-510.39.01.run --uninstall
make sure driver name is correct before executing this command -- this will uninstall the above driver.

install correct driver with same command in same manner, without the "--uninstall"

or Use the GUI option available nowadays, if you so desire.

Your choice, but command line is the way I learned it.

FYI (I like these guys) -- https://www.cyberciti.biz/faq/ubuntu-linux-install-nvidia-driver-latest-proprietary-driver/

so, to iINSTALL via CLI (oldschool way) ,
Code:
sh NVIDIA-Linux-x86_64-495.46.run
or
Code:
./NVIDIA-Linux-x86_64-495.46.run
once driver downloaded and root is in the directory of the driver file
 
Last edited:
OP
Catalin

Catalin

Member
Joined
Feb 9, 2022
Messages
33
Reaction score
17
Credits
445
Alright guys, I'm back and.. So far so good!
I've been testing it for some days and Manjaro KDE seems to be working just fine on the laptop.

What I did is this:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi pci=noaer"
And this:
or Use the GUI option available nowadays, if you so desire.
I changed the Nvidia driver using the Manjaro GUI from 510 to 470.103.01 Prime (I did not go for 495 because it was not in the list and I said it would be better to stay away from terminal for now #lol) (also I did not want to go for Bumblebee version, I've heard that's old)

This laptop is mainly used by older member of the family in a very conservative fashion.
It is only being used for and has been so far tested with Chrome, web surfing, e-mail, facebook and Onlyoffice. Also HD movies in 1080p from hard disk are running very well and Nvidia does not go past 40-42 Celsius degrees.
Also watching movies via HMDI works fine.

No more errors when shutting it down, no freezing, it stays pretty cool all the time - Nvidia temperature with Thermal Monitor shows it stays between 37-42 Celsius degrees which I think is just fine.

So I think that the MSI grub thing was the issues.
I am glad it works but can someone still explain to me what that means? #LOL :D
(I cheked the internet but I don't think I've been looking for the right thing.)

Overall, it works! Thanks :)
 
OP
Catalin

Catalin

Member
Joined
Feb 9, 2022
Messages
33
Reaction score
17
Credits
445
I found one more way of resolving this issue and I thought I would write it down here for others to see in case of need. As I also had problems with live installations getting stuck (no matter the architecture or distro). The ones I was able to install would somehow loose all the free space in real time, the /var/log folder was consuming it it all very fast.
Something more had to be done before even starting the Live mode.

So I found these to work. Steps for resolving the PCI issue/distro freezing:
  1. In Grub menu before entering live press E and add after quiet splasht splash (or similar) the following: pcie_aspm=off + pci=nomsi + pci=noaer
  2. Start Live (by pressing F10 or whatever it says on the screen) and install the OS
  3. The fresh installed OS should also have those kernel parameters in /etc/default/grub
And now everything should work just fine.


Update2: I still experienced issues even after this. The error I was getting when booting up or shutting down was pcieport 0000:00:1c.5: because of the Intel's Sunrise Point-LP PCI Express Root Port.
The solution is to add pci=nommconf in the grub, then sudo update-grub.
Check this forum thread here for the comment marked as solution.

I did not need it (so far) but it might also imply doing some stuff with TLP and battery parameters, especially if you have this piece of hardware or a Asus laptop - for this check it here.
 
Last edited:
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Staff online


Top