configure: error: external blkid library not found

[email protected]

New Member
Credits
33
Hi,

I am new to Linux. I am trying to build the source code for EVB-KSZ9477 using all the steps mentioned in the document "EVB_KSZ9477_Source_Build_Instructions.pdf"
I have installed Ubuntu 14.04.06 LTS using VM on my laptop. After few hours of build, I am getting an error shown in the attached screenshot.

Has anyone faced this issue?

Thanks
Meenanath
 

Attachments



jglen490

Well-Known Member
Credits
4,106
Another EOL Linux distro causing problems. Ubuntu 14.04 is EOL, please install a current distro. Doing so will eliminate some possible causes for your build issues.
 

[email protected]

New Member
Credits
33
Thanks for your reply. I tried to build the project using latest distribution of Linux 20.04.01. That gives me different errors. I am trying to solve those issues as well.

Meantime, I was thinking if I can get at least this project built with 14.04 as Microchip have mentioned in the document.
 

jglen490

Well-Known Member
Credits
4,106
You are free to use 14.04, but you won't be able to get any updates security or otherwise, and being on the internet with an old, unsecure distro is rather dicey.
 

[email protected]

New Member
Credits
33
Hi Guys,

Just to let you know that, I fixed this problem by enabling libblkid option in e2fsprogs.mk file which was disabled.

--enable-libblkid

Thanks,
Meenanath
 

maqui

New Member
Credits
8
As commented in e2fsprogs.mk, it is not recommended to use libblkid as e2fsprogs builtin.
In my case, the target that was failing is host-e2fsprogs, which itself requires host-util-linux.

Whereas enabling BR2_PACKAGE_HOST_UTIL_LINUX should have done the trick, it appears that the right solution is simply to enable libblkid for host if it is required per builtroot variable:
Screenshot from 2021-04-13 16-06-30.png
 
Last edited:
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online

No members online now.

Latest posts

Top