Configuring Debian 11 WIFI Card



dos2unix

Well-Known Member
Credits
4,548
dns has nothing to do with packets. This is easy to prove.
Do you know the IP address of your wifi router?
Ping 192.168.1.1 (whatever the IP is)

We can fix the dns.
 

dos2unix

Well-Known Member
Credits
4,548
This looks like like your off the internet.
Your LAN (local are inside your house) is fine.
Your WAN (external to your ISP) is down.
 

mikelosat

New Member
Credits
181
to me everything works, the only thing that does not work is DEBIAN in 5ghz mode.
All the devices in my house are connected without any signal loss.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
25,461
It's amazing, I still can't get my rtl8822ce wifi network card to work in 5G mode. The 2.4G mode works great with my ar750 ext router. when I try to connect to the 5g network it's as if the DNS doesn't resolve the names.

I don't know what to try anymore, can anyone suggest something?
What happens when you ping your gateway when you are connected to 5Ghz? So this?
Code:
ping -c 3 192.168.8.1
 

f33dm3bits

Gold Member
Gold Supporter
Credits
25,461
Looks like it can't reach your gateway, can you share the output of ip route when you are connected to 5Ghz? Are other devices able to access the internet when connect to 5Ghz?
 

mikelosat

New Member
Credits
181
Looks like it can't reach your gateway, can you share the output of ip route when you are connected to 5Ghz? Are other devices able to access the internet when connect to 5Ghz?
Yes, as already mentioned, other devices connect in 5ghz mode without problems to the same Ar750s ext router.
The only one that has problems is debian that can only connect in 2.4ghz mode
 

f33dm3bits

Gold Member
Gold Supporter
Credits
25,461
Yes, as already mentioned, other devices connect in 5ghz mode without problems to the same Ar750s ext router.
The only one that has problems is debian that can only connect in 2.4ghz mode
What's the output of the following when connected to 5Ghz?
Code:
ip route
 

f33dm3bits

Gold Member
Gold Supporter
Credits
25,461
I would try playing around with your 5Ghz settings on your router specifically "Wireless Channel" and "Channel Width" since you are able to connect but not reach your router.
 

mikelosat

New Member
Credits
181
I would try playing around with your 5Ghz settings on your router specifically "Wireless Channel" and "Channel Width" since you are able to connect but not reach your router.
I had already tried, currently it is set with the default values but there are unfortunately no results.

I believe it is a problem of the router firewall even if the 2.4ghz mode works with the same firewall
 

mikelosat

New Member
Credits
181
... and after days of study and work FINALLY came the solution.

As I imagined the problem was the ROUTER AR750s ext. In fact, in the settings of the 5ghz connection it was enough to change the "operating frequency" from AC to N to finally see the transmission of the packets.
Finally my Debian 11 will be able to browse in 5ghz mode.

Thanks to everyone for the availability that allowed me to understand and learn many commands that I did not know, you learn from the problems.

Thank you friends you are the nicest community I have ever found on DEBIAN and linux.
es.png
 

f33dm3bits

Gold Member
Gold Supporter
Credits
25,461
... and after days of study and work FINALLY came the solution.

As I imagined the problem was the ROUTER AR750s ext. In fact, in the settings of the 5ghz connection it was enough to change the "operating frequency" from AC to N to finally see the transmission of the packets.
Finally my Debian 11 will be able to browse in 5ghz mode.
That's basically what I meant when I mentioned to play with those router settings I mentioned except I did mention network mode. ;)
I would try playing around with your 5Ghz settings on your router specifically "Wireless Channel" and "Channel Width" since you are able to connect but not reach your router.
Glad you were able to solve it! Welcome to linux.org! :)
 
Last edited:

f33dm3bits

Gold Member
Gold Supporter
Credits
25,461
AFAIK you don't need to do anything special to activate it AC on your network card, there are options you can configure. I just switched on my wireless network card and disabled my ethernet connection and I am able to connect to my AC wireless network without needing to configure anything extra on my wireless network card. If you want to use AC I would enable AC on your wireless router and play around with the different "Wireless Channels", just try all channels until starting from the top and then moving down until you find one that works.
 
Last edited:
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top