• We had to restore from a backup today after a failed software update. Backup was from 0000 EDT and restored it at 0800 EDT so we lost about 8hrs. Today is 07/20/2024. More info here.

Corrupted USB Drive with I/O error


Feb 9, 2022
Reaction score

Hello community!​

I've been testing some distros lately as I need to find other possible options for an older member of my family. So, I have this Hama 3.0 USB Drive 64 GB that I have been using but today it stopped working. I have this one since February 2020 and I barely used it, and when I did it happened mostly in the last 3-4 months.

It didn't break down at once. I had Ventoy on it with multiple other ISOs but it just didn't want to work with EndevourOS - this is was the first sign of problem. I thought it was the OS or ISO's fault so I re-downloaded it but meanwhile I gave it one more try to MX Linux without any issues. Then I tried Endevour again and it broke down, then nothing worked anymore.

1. I have been trying to repair it with USB Format Tool, right-click-formatting from file manager and with Diskpart - all of these on Windows (here I received I/O error).
2. I am mainly using Manjaro and I gave it a try with this tutorial here but it just doesn't work. However, as you can see in the pictures, the USB Drive can be seen in KDE Partition Manager and also by using some commands such as lsblk

I don't think the stick has a physical issue.. but what do you guys think, how can I repair it?


  • Screenshot_20220424_224929.png
    180.5 KB · Views: 497
  • Screenshot_20220424_224911.png
    187.7 KB · Views: 467
  • Screenshot_20220425_002630.png
    168.4 KB · Views: 479

Chances are it is dead.
"Bad magic number in superblock" +USB stick repair
in search engine returns many results on how to repair.

I'd bet using dd to check for bad blocks wouldn't even complete, but who knows until trying, huh?
dd if=/dev/sdX of=/dev/null bs=1M
where /dev/sdX
is how the stick is recognized by running

End result would show equal numbers for 'record in' and 'records out' or there are bad blocks.

I had a cheap 32GB USB stick I put Ventoy with several ISOs of distros that only lasted about six months. So many reads and writes and it was done, I suppose.
Only once did I purchase a cheap USB pen-drive, it gave up after only a few weeks, so never again, I have a selection of them now all different capacities some as old as 15+ yrs that still work, all have 2 things in common, they are all known brands and none of them were what I would call cheap, A computer and its components are no different to buying any other tool, you get what you pay for, always get the best you can afford. Pen-drives and flash drives are not worth keeping once they start messing about.
Pen-drives and flash drives are not worth keeping once they start messing about
I agree with you, I will also buy a new one but maybe I can still use this one a couple more times for some live sessions.

However, I think there might be some good news about this?
I'd bet using dd to check for bad blocks wouldn't even complete, but who knows until trying, huh?
I have this:
sudo dd if=/dev/sdd of=/dev/null bs=1M                                                                              1 ✘
[sudo] password for catalin:
dd: error reading '/dev/sdd': Input/output error
35396+1 records in
35396+1 records out
37116051456 bytes (37 GB, 35 GiB) copied, 653,913 s, 56,8 MB/s

This means.. it's still working right?
I also tried sudo mkusb but it tells me: error: no usb device found
It is "undecided"

Bin it
The test was just for reading bad blocks. It does not necessarily mean it'll function well saving data. {@Condobloke is just speaking like a lawyer (solicitor, for the Brits)}. Your USB stick, by consensus, is likely on its way out.

I've been having more than the usual amount of problems with memory devices lately. "Bad magic number" has popped up more than once. All the years prior to this, I had not encountered this problem.

Plus, I am starting to suspect Ventoy and how it is accessing the ISOs is stressing USB sticks more than they may be currently designed for. The only good thing that could come from such would be the eventual discovery of better brands of USB sticks. Anyway, experience has taught me to avoid certain brands.
Alright, thanks for the information!
to avoid certain brands
I also had a Bluetooth stick from Hama and I was disappointed by it, I returned it. I will not choose this one again.
What brands do you recommend?
The ones I use most are, a PNY, a Toshiba [Kingston inside] and adata [also Kingston inside]
if I had to choose just one, then the pny would be my first pick
I've had bad luck with sandisk, adata, Team, the cheapies. Good luck with patriot, corsair, kingston, micron (don't know what they are called now) and Mushkin. Surprisingly, I had to buy a stick at Walmart and got one called onn, that has lasted, so far, going on a year.
Last edited:
I usually buy Kingston, but I tried a few of the ones from Team and (unlike above) had good results with them. So, I bought some SSDs from them and have also had good luck. I'm thinking about trying their M.2 NVMe SSDs.

But... What that likely means is they may have poor QC and I've just been lucky - or they've been unlucky.
I wonder if quality control is a top concern with many manufacurers.
I will go for a Kingston as it's easy to find and affordable at the same time. All my hard disks and SSDs are Kingston and I never had an issue with them. Thanks for the info!
Our pleasure
I am starting to suspect Ventoy and how it is accessing the ISOs is stressing USB sticks more than they may be currently designed for.
I think you are right with this. Today I used Ventoy 1.72 on Linux, on my EMTEC 16GB USB drive to add Manjaro KDE iso to use the KDE partition Manager to extend my root size.
When I tried to boot live, the iso seemed corrupted and I received the bad magic number error in boot, white on black screen. Then I used Ventoy 1.73 from Windows and everything was okay.
I am not sure if it's only happening on Linux or if it's just simply more hazardous on it. I thought I should share this with you.
@Catalin -- thanks for sharing supporting observations on Ventoy! I'll look for more evidence of this possibility as time goes by and in differing forums on articles. There may be more down the road on this topic.

Best wishes!

Members online