Couldn't enable monitor mode.

Jazmen

New Member
Credits
23
Hi, i wanted to change the wireless interface from managed to monitor mode. Thanks in advance (i am beginner ).
 


f33dm3bits

Gold Member
Gold Supporter
Credits
5,672
Isn't it just easier to use wireshark?
 

Jazmen

New Member
Credits
23
I am using Kali-Linux-2020.2a in a virtual machine (Oracle VM ) . and there is no WiFi interface. basically I am trying to use fern WiFi cracker. and turning on the monitor mode is a must in order to scan for access point.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
5,672
I am using Kali-Linux-2020.2a in a virtual machine (Oracle VM ) . and there is no WiFi interface. basically I am trying to use fern WiFi cracker. and turning on the monitor mode is a must in order to scan for access point.
The host machine and the virtual machine can't be using the wireless card at the same time. You will need to buy a second wireless adapter, for example a wireless usb adapter and assign that to the virtual machine you are running Kali on.
 

Jazmen

New Member
Credits
23
The host machine and the virtual machine can't be using the wireless card at the same time. You will need to buy a second wireless adapter, for example a wireless usb adapter and assign that to the virtual machine you are running Kali on.
Thanks, I really was desperate for a solution.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
5,672
This post links to some useful informationl, but in short make sure your secondary wireless usb adapter isn't a virtualized network card and then use the instructions from a post on the virtualbox forums to make your usb wireless adapter available to your virtual machine.
 

wtsxdev

New Member
Credits
8
I had the same problem and it was all because of the adapter even after i got a new one i didn't work cause it dose not support monitor mode , i had to learn it the hard way that some adapter are supported and some are not , however i got Alfa AWUS1900 listed here https://kalitut.com/usb-wi-fi-adapters-supporting-monitor/ and it work very well strong signal and everything i needed is supported
 

JasKinasis

Well-Known Member
Credits
3,079
The OP hasn't actually told us which wifi adaptor/chipset they're using.

Also - another possibility - For some reason, in the latest version of Kali - the builds of the Realtek rtl8812au and rtl8188eu drivers have monitor mode and packet injection disabled.

So if the OP is using an adaptor using a Realtek chipset - they may need to take a look at this post I made earlier today which fixes that issue:

[EDIT] Ooops! Just re-read the thread and realised that the OP didn't have a separate adaptor for their VM to use. But I'll leave this here anyway, because it could help somebody else! [/EDIT]
 


Staff online

Members online


Top