Debian 10 Gnome and Firefox 88 SOLVED

KGIII

Super Moderator
Staff member
Gold Supporter
Credits
26,135
I decided I didn't want to fight with this anymore and followed KGIII's instructions in post #7.
For the record, I'm pretty sure that you could have just closed the browser, deleted the .mozilla folder, and restarted Firefox. I tested it a dozen or so times on different VMs and it worked out well at resetting everything.

I mention it again because it's a pretty neat trick. I am not terribly surprised that it works. You can do that with all sorts of stuff. I wasn't sure if it'd work with Firefox, but it did. It's a trick worth remembering.
 


Alexzee

Well-Known Member
Credits
8,873
For the record, I'm pretty sure that you could have just closed the browser, deleted the .mozilla folder, and restarted Firefox. I tested it a dozen or so times on different VMs and it worked out well at resetting everything.

I mention it again because it's a pretty neat trick. I am not terribly surprised that it works. You can do that with all sorts of stuff. I wasn't sure if it'd work with Firefox, but it did. It's a trick worth remembering.
Worth remembering indeed!

Thanks for the help- :)
 

Fanboi

Active Member
Credits
2,042
I know this is marked [Solved], but for future visitors:

One: If you need to manage preferences:

1. Go to ~/.mozilla/firefox/

2. Know your profile. It's normally the default one listed in profiles.ini
"Name=" or "Default="

3. Open the corresponding dir with the profile name. Your pwd should be something like this: ~/.mozilla/firefox/56zw8oji.default/

4. Open prefs.js. By default, these keys won't exist. Only if you change the defaults.
- Background (what you broke):
user_pref("browser.display.background_color", "#");
- Foreground:
user_pref("browser.display.foreground_color", "#");
- You can set each key in lowercase hex prepended with a hash, #.

5. The following should be easy on your eyes without completely messing things up:
Code:
user_pref("browser.display.background_color", "#1e1e1e");
user_pref("browser.display.foreground_color", "#e9e9e9");
// Note: These values are just a guess, I cannot "see" the hex in my mind, I am not Neo.
// Run "zenity --color-selection" from your console or use GIMP, InkScape, etc. to get hex
Notes:
You can set FF to adhere to your GTK theme:
preferences-->search:color-->colors-->"Use System Colors".
Admittedly, this sometimes breaks horribly because, like a lot of software, Mozilla does not conform to OS spec or render spec.


Two: To Reset Settings to Default:

You can probably just close Firefox, delete the .mozilla folder, and restart Firefox. I just tested that too.
This is correct. But ensure firefox is closed. (Logout of X or $ killall -9 firefox firefox-esr)
Notes: You may lose your bookmarks, etc.

Cheers,
Fanboi
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top