Debian 11 Help


New Member
Apr 10, 2022
Reaction score
I’ve downloaded the latest version of Debian and decided to leave my computer off for a few months. Prior to my problem I was using an Ethernet cable to connect to the internet. I’ve since moved properties and have no access to an Ethernet port nor Ethernet cable. To my surprise, I have found that I cannot connect to WiFi. I’ve tried everything but every time I either don’t see a prompt for wireless connections or don’t see any SSID names on the list. I only see what is my past Ethernet profile from my old property. I don’t know what to do, please help.

Debian has two versions the one with all the third party drivers/firmware is called non-free ISO and is located here -
The normal version of Debian does not contain third party firmware

If you know what kind of WiFi you have you can download that firmware from here -
this site is a DEB package if you can download it to another machine a put it on a thumb drive and install it to the machine with no internet - it will be listed as firmware-
The below is direct links to download some of the most common WiFi firmware as DEB packages
Intel WiFi is here -
Realtek WiFi is here -
Atheros/Qualcomm is here -

This is one of the main reasons I only get the non-free ISO, but Debian says it's "unofficial" - it has all the extra firmware
G'day @Corptal and welcome to :)

My friend just beat me to writing the same sort of thing so I won't reinvent the wheel.

I was struggling with my wifi and Debian for ages before I learned here of the non-free option and it has worked well ever since.

If you are not sure on Desktop choices take a read here and you will get an idea

Good luck

Chris Turner

Members online