Disable paging on openldap

breen25

New Member
Credits
0
Hi,
I am trying to disable paged responses on a Solaris Open Ldap 2.4.45 instance.

It is using the so-called OLC(cn=config) or slapd.d method (seems to be a few different names for it floating around). I successfully have disabled paging on version 2.4.42 using the predecessor slapd.conf configuration method by adding sizelimit size.prtotal=disabled to the slapd.conf file. This works as I get

search: 2
result: 11 Administrative limit exceeded
text: pagedResults control not allowed

back in my response.

According to http://www.openldap.org/doc/admin24/slapdconf2.html the same can be applied by adding olcSizeLimit: size.prtotal=disabled to the slapd.d configuration but this hasn't worked so far. I've tried adding the entry to the server settings cn=config.ldif and database olcDatabase={0}config.ldif files but to no avail.

Running: ldapsearch -xv -h <ldaphost> -E pr=2000 -b "dc=mydom,dc=com" "(objectClass=*)

still shows the paging control is enabled in the response as evident in:

search: 2
result: 0 Success
control: 1.2.840.113556.1.4.319 false MAUCAQAEAA==
pagedresults: cookie=

Any ideas?
 


Members online


Top