DNS already started, won't stop - failed

hcaeb2000

New Member
Credits
22
Hello all, I am on a CentOs 5 machine, having issues with starting named backup, we started having some DNS issues after an upgrade and I traced it back to the DNS on this server...

When I do a status it shows that named is stopped

when I try to start it, it says that it is already running. I attempted to fix with these steps, which worked for us once before but isn't working now.

cd /etc/init.d
mv named named.backup
wget -O named http://www.directadmin.com/named
chmod 755 named
/sbin/chkconfig named reset

Also if I kill the named service which somehow seems to be running somewhere and restart, it appears to restart the service again under some mystery named

and gives the error: named dead but subsys locked when I do service named status

been banging my head on this one for a few hours. Any ideas?
 


wizardfromoz

Administrator
Staff member
Gold Supporter
Credits
17,806
G'day @hcaeb2000 and welcome to linux.org :)

I know next to nothing about centOS (but use Fedora) but are you aware that End of Life for 5 was 4 years ago? This from 1 March 2017.

Just a message to remind everyone that CentOS-5 has an End of Life date of March 31, 2017.


This means that there will be no new security updates released by Red Hat for RHEL-5 after that date.
Cheers

Chris Turner
wizardfromoz
 

f33dm3bits

Gold Member
Gold Supporter
Credits
24,609
Yes, I am aware, I am working on that right now.

Thanks,
That's 4 years too late. Seeing you downloaded the script from directadmin.com I am assuming you are running directadmin on the machine and have a subscription to directadmin, so since the script is from the direcatdmin website and you have a subscription there just create a support ticket.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Latest posts

Top