Dual Boot (Ubuntu and Win 10) Mounting Drive Problems

333pwn

New Member
Credits
142
Hi, having some problems with switching to Linux. I have my Win 10 local disk on /dev/sdd and Ubuntu Linux on /dev/sda. I would like to access my windows local disk files within Linux but when I try to mount /dev/sdd to /mnt with:
"sudo mount /dev/sdd /mnt"
I get:
"mount: /mnt: wrong fs type, bad option, bad superblock on /dev/sdd, missing codepage or helper program, or other error."
It's the same if I try mounting each partition of sdd separately. As a result of this, I can't get into Windows even if I boot with my windows drive in the bios(i presume this is because grub isn't installed on /dev/sdd and I can't install it without mounting it). Any help? Gparted shows my sdd with an error:
"Unable to detect file system! Possible reasons are:
- The file system is damaged
- The file system is unknown to GParted
- There is no file system available (unformatted)
- The device entry /dev/sdd3 is missing"


Thanks
 


KGIII

Super Moderator
Staff member
Gold Supporter
Credits
15,231
Hmm... Do you have ntfs-3g installed? Lemme find you a link...

Rather than type it all out anew, this link *may* get you sorted.


But, it may be something larger. You say you can't get into Windows even if you try to get in with the BIOS. With that, I'm not a Windows user and can't help. So, let's see if the above will get you started and we can go from there.
 

stan

Well-Known Member
Credits
4,577
Two things:

1. /mnt is often already part of your Linux system, and it may not be empty. You can use it, but I would make a new directory to mount Windows to... inside /mnt or not, for example:
Code:
sudo mkdir /windows

# or

sudo mkdir /mnt/windows

2. Windows 10 does not fully shutdown when you tell it to... it goes into hibernation instead. This allows it to boot faster, but Linux refuses to mount it in that state so that it will not damage it. The solution here is to boot into Windows, open a CMD prompt as Administrator, and give this command:
Code:
powercfg.exe hibernate off

Exit from the CMD window and shutdown. Go back to Ubuntu and mount like you were doing:
Code:
sudo mount /dev/sdd3 /windows

# or

sudo mount /dev/sdd3 /mnt/windows

If all is well, you can now cd /windows or cd /mnt/windows and see your Windows files. If it is working properly, you can add an entry to your fstab file so that it will mount automatically when you boot into Ubuntu.
 
Last edited:

333pwn

New Member
Credits
142
Two things:

1. /mnt is often already part of your Linux system, and it may not be empty. You can use it, but I would make a new directory to mount Windows to... inside /mnt or not, for example:
Code:
sudo mkdir /windows

# or

sudo mkdir /mnt/windows

2. Windows 10 does not fully shutdown when you tell it to... it goes into hibernation instead. This allows it to boot faster, but Linux refuses to mount it in that state so that it will not damage it. The solution here is to boot into Windows, open a CMD prompt as Administrator, and give this command:
Code:
powercfg.exe hibernate off

Exit from the CMD window and shutdown. Go back to Ubuntu and mount like you were doing:
Code:
sudo mount /dev/sdd /windows

# or

sudo mount /dev/sdd /mnt/windows

If all is well, you can now cd /windows or cd /mnt/windows and see your Windows files. If it is working properly, you can add an entry to your fstab file so that it will mount automatically when you boot into Ubuntu.
Thanks so much, problem is that I cannot boot into windows now, since Linux automatically boots even if I choose the drive with windows. Any way to make it not hibernate within Linux?
 

333pwn

New Member
Credits
142
Hmm... Do you have ntfs-3g installed? Lemme find you a link...

Rather than type it all out anew, this link *may* get you sorted.


But, it may be something larger. You say you can't get into Windows even if you try to get in with the BIOS. With that, I'm not a Windows user and can't help. So, let's see if the above will get you started and we can go from there.
Problem is that I think its not a NTFS partition. gparted says LDM.
 

stan

Well-Known Member
Credits
4,577
problem is that I cannot boot into windows now, since Linux automatically boots even if I choose the drive with windows. Any way to make it not hibernate within Linux?
I'm not clear on this... has something changed? These problems are not related... hibernation is not stopping Windows from booting.

Boot into Linux, and run sudo update-grub and reboot. You should get a grub screen where you can select Windows, and it should boot Windows. If it doesn't, try booting Windows from your BIOS Boot Menu (usually accessed with ESC or some F-key when the system is starting).
 

333pwn

New Member
Credits
142
Grub doesn't show up (im guessing cuz I have to install grub on my windows drive), when I run sudo update-grub, it shows me:
"Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/init-select.cfg'
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-5.8.0-7642-generic
Found initrd image: /boot/initrd.img-5.8.0-7642-generic
done"

Not sure what initrd is but winows is not on there. I can't get into windows through bios either. Been reading something about removing hybernation through linux but I cant find a way to do it.
 

stan

Well-Known Member
Credits
4,577
I would suggest NOT removing hibernation from Windows using Linux. You may corrupt data there. Hibernation is not your problem booting Windows.


Grub doesn't show up (im guessing cuz I have to install grub on my windows drive)
No, you don't need grub on your Windows drive.


I can't get into windows through bios either.
Not BIOS... not changing BIOS boot order, if that is what you mean (though that sometimes works). The BIOS Boot Menu is called during the initial boot sequence, before Linux starts... it should show you a Windows bootloader to boot from. Tell us more about your system. Desktop or laptop? What brand and model is your computer? What kind of hard drive is this?
 
Last edited:

333pwn

New Member
Credits
142
I would suggest NOT removing hibernation from Windows using Linux. You may corrupt data there. Hibernation is not your problem booting Windows.



No, you don't need grub on your Windows drive.



Not BIOS... not changing BIOS boot order, if that is what you mean (though that sometimes works). The BIOS Boot Menu is called during the initial boot sequence, before Linux starts... it should show you a Windows bootloader to boot from. Tell us more about your system. Desktop or laptop? What brand and model is your computer? What kind of hard drive is this?
Not sure what to do then, ive been trying but even If i boot straight off my windows drive it still goes to linux. Im running pop os and win 10 on a PC i built. Motherboard is MSI if that helps.
 

stan

Well-Known Member
Credits
4,577
Not sure what to do then, ive been trying but even If i boot straight off my windows drive it still goes to linux. Im running pop os and win 10 on a PC i built. Motherboard is MSI if that helps.
There may be many steps to figure out what is going on. And many questions... from me and other helpers here. Try to be patient with us and give us full answers to our questions, as best as you can. If I start to go down the wrong path, hopefully another helper will jump in with better ideas or better questions.

Let's start with this. Open up Gparted and make it full screen. Use the selection box in the upper right corner to show each of your drives: /dev/sda, /dev/sdb, /dev/sdc. and /dev/sdd. Make a screen capture of each drive in Gparted and post each one here.
 

333pwn

New Member
Credits
142
There may be many steps to figure out what is going on. And many questions... from me and other helpers here. Try to be patient with us and give us full answers to our questions, as best as you can. If I start to go down the wrong path, hopefully another helper will jump in with better ideas or better questions.

Let's start with this. Open up Gparted and make it full screen. Use the selection box in the upper right corner to show each of your drives: /dev/sda, /dev/sdb, /dev/sdc. and /dev/sdd. Make a screen capture of each drive in Gparted and post each one here.
right, sorry. here are the screenshots:
Im trying to either get into windows or access my files on /dev/sdd. Whichever one is easier
 

Attachments

stan

Well-Known Member
Credits
4,577
Wow, this is going to be a challenge. I know I can't solve this myself, so I'll call for helpers to come and look at your screenshots and offer more advice. @wizardfromoz @KGIII @f33dm3bits @Tolkem @gvisoc @jglen490 @dos2unix (Who else, especially with Windows experience?)

Some observations:

You have two EFI System Partitions (ESP's) on sdc1 and sdb2.

You say Windows is on sdd... and I didn't recognize the LDM reference you made above, but I do now. I have never used LDM, and I wonder what motivated you to use it? It is quite likely that the mount commands will not work with this filesystem, or will need more investigation before trying again.

I don't think either of your ESP's is on a drive with an operating system! That's strange. With Windows on sdd3, it looks like the Linux system is on sda2. You have another ext4 partition on sdb1, but that has a label "ADATASSD" so I guess that is just storage. The sdc drive has several NTFS partitions, but I will guess those are storage also and contain no operating system. Correct me if I'm wrong.

And a question (or two, or more):

Did your system EVER dual boot properly? If it did, what "event" happened that made it stop working correctly? An update (Windows or Pop_OS)? Anything that you can add to help analyze what is going on?

Repeating a question from above: What motivated you to use LDM? Is it something you are familiar with? Since I've been using computers for a very long time, I'm amazed that I was totally unaware of it. And I'm curious how many of the helpers here will have knowledge about it.

Another request for details:

Please copy and paste the output of lsblk (LSBLK but all lower case) and also sudo fdisk -l (that's -L but lower case). Also please put the output from each inside of "code tags" to help with readability. You can select the "code tag" function in the message editor window here at the top, the "three dots" icon next to the Smiley face. Thanks!
 

333pwn

New Member
Credits
142
Wow, this is going to be a challenge. I know I can't solve this myself, so I'll call for helpers to come and look at your screenshots and offer more advice. @wizardfromoz @KGIII @f33dm3bits @Tolkem @gvisoc @jglen490 @dos2unix (Who else, especially with Windows experience?)

Some observations:

You have two EFI System Partitions (ESP's) on sdc1 and sdb2.

You say Windows is on sdd... and I didn't recognize the LDM reference you made above, but I do now. I have never used LDM, and I wonder what motivated you to use it? It is quite likely that the mount commands will not work with this filesystem, or will need more investigation before trying again.

I don't think either of your ESP's is on a drive with an operating system! That's strange. With Windows on sdd3, it looks like the Linux system is on sda2. You have another ext4 partition on sdb1, but that has a label "ADATASSD" so I guess that is just storage. The sdc drive has several NTFS partitions, but I will guess those are storage also and contain no operating system. Correct me if I'm wrong.

And a question (or two, or more):

Did your system EVER dual boot properly? If it did, what "event" happened that made it stop working correctly? An update (Windows or Pop_OS)? Anything that you can add to help analyze what is going on?

Repeating a question from above: What motivated you to use LDM? Is it something you are familiar with? Since I've been using computers for a very long time, I'm amazed that I was totally unaware of it. And I'm curious how many of the helpers here will have knowledge about it.

Another request for details:

Please copy and paste the output of lsblk (LSBLK but all lower case) and also sudo fdisk -l (that's -L but lower case). Also please put the output from each inside of "code tags" to help with readability. You can select the "code tag" function in the message editor window here at the top, the "three dots" icon next to the Smiley face. Thanks!
Alright so,
Im not sure why its LDM, ive been into computers for a while too but always windows, recently changed to linux and i only now found out its LDM, it wasint configured like this by me. Drive sdd is a m.2 ssd. Another thing, I had a lot of trouble installing windows after building this pc, even though I've installed it many times before it just wouldn't work, I got it working but I'm guessing something might be broken there too.

I did not ever boot successfully into windows after I installed pop os, so Im not sure what caused it first. I did boot into ubuntu once but chose the option to "test out" without installing, that was a couple months ago and I got back into winows.

lsblk:
Code:
NAME                      MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
loop0                       7:0    0  60.8M  1 loop /snap/coin/38
loop1                       7:1    0  55.5M  1 loop /snap/core18/1988
loop2                       7:2    0  99.2M  1 loop /snap/core/10859
loop3                       7:3    0 162.9M  1 loop /snap/gnome-3-28-1804/145
loop4                       7:4    0  64.8M  1 loop /snap/gtk-common-themes/1514
sda                         8:0    0 223.6G  0 disk
├─sda1                      8:1    0    50M  0 part
└─sda2                      8:2    0 223.5G  0 part /
sdb                         8:16   0 223.6G  0 disk
├─sdb1                      8:17   0   223G  0 part
└─sdb2                      8:18   0   100M  0 part
sdc                         8:32   0 931.5G  0 disk
├─sdc1                      8:33   0   500M  0 part
├─sdc2                      8:34   0   128M  0 part
├─sdc3                      8:35   0 917.7G  0 part /media/kw/HDD1TB
├─sdc4                      8:36   0   865M  0 part
└─sdc5                      8:37   0  12.4G  0 part
sdd                         8:48   0 238.5G  0 disk
├─sdd1                      8:49   0     1M  0 part
├─sdd2                      8:50   0   127M  0 part
├─sdd3                      8:51   0 238.3G  0 part
└─ldm_vol_DESKTOP-VVANIJQ-Dg0_Volume2
                          253:0    0  15.4G  0 dm   /media/kw/New Volume
Note: "New Volume" is a drive that appeared after I followed the instruction of this video:
however, this made a new drive (New Volume) that was only 17GB and did not have my files on it.

sudo fdisk -l:

Code:
Disk /dev/loop0: 60.77 MiB, 63725568 bytes, 124464 sectors

Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop1: 55.46 MiB, 58159104 bytes, 113592 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop2: 99.21 MiB, 104026112 bytes, 203176 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop3: 162.87 MiB, 170778624 bytes, 333552 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop4: 64.77 MiB, 67915776 bytes, 132648 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/sda: 223.57 GiB, 240057409536 bytes, 468862128 sectors
Disk model: CT240BX500SSD1 
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x26581160

Device     Boot  Start       End   Sectors   Size Id Type
/dev/sda1  *      2048    104447    102400    50M  7 HPFS/NTFS/exFAT
/dev/sda2       104448 468857558 468753111 223.5G 83 Linux


Disk /dev/sdb: 223.57 GiB, 240057409536 bytes, 468862128 sectors
Disk model: ADATA SU635     
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: A6D7AD51-7722-4799-A036-0916DC65756A

Device       Start       End   Sectors  Size Type
/dev/sdb1  1290240 468860927 467570688  223G Linux filesystem
/dev/sdb2  1085440   1290239    204800  100M EFI System

Partition table entries are not in disk order.


Disk /dev/sdd: 238.47 GiB, 256060514304 bytes, 500118192 sectors
Disk model: TEAM TM8PS7256G
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 5DE3D6B3-9995-4331-A854-24344AD19A29

Device      Start       End   Sectors   Size Type
/dev/sdd1      34      2081      2048     1M Microsoft LDM metadata
/dev/sdd2    2082    262177    260096   127M Microsoft reserved
/dev/sdd3  262178 500118158 499855981 238.3G Microsoft LDM data


Disk /dev/sdc: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: WDC WD10JPVX-75J
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: E0A4A7A6-DF7F-4DD2-8275-CEB29A1AE204

Device          Start        End    Sectors   Size Type
/dev/sdc1        2048    1026047    1024000   500M EFI System
/dev/sdc2     1026048    1288191     262144   128M Microsoft reserved
/dev/sdc3     1288192 1925829500 1924541309 917.7G Microsoft basic data
/dev/sdc4  1925830656 1927602175    1771520   865M Windows recovery environment
/dev/sdc5  1927602176 1953523711   25921536  12.4G Windows recovery environment


Disk /dev/mapper/ldm_vol_DESKTOP-VVANIJQ-Dg0_Volume2: 15.41 GiB, 16545480704 bytes, 32315392 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x73736572

Device                                                Boot      Start        End    Sectors   Size Id Type
/dev/mapper/ldm_vol_DESKTOP-VVANIJQ-Dg0_Volume2-part1      1920221984 3736432267 1816210284   866G 72 unkn
/dev/mapper/ldm_vol_DESKTOP-VVANIJQ-Dg0_Volume2-part2      1936028192 3889681299 1953653108 931.6G 6c unkn
/dev/mapper/ldm_vol_DESKTOP-VVANIJQ-Dg0_Volume2-part3               0          0          0     0B  0 Empt
/dev/mapper/ldm_vol_DESKTOP-VVANIJQ-Dg0_Volume2-part4        27722122   27722568        447 223.5K  0 Empt

Partition table entries are not in disk order.
 

stan

Well-Known Member
Credits
4,577
OK, thanks for the video. I'm always glad to learn new things... which happens all the time. But I'm still amazed I've never encountered LDM before. Cool.

I seem to have run into many troubles with people using NVMe drives. I don't know why that is... if they are that problematic, or just my bad luck. But you had Windows working after some effort, so maybe we can get it back.

I was surprised that your Linux drive, /dev/sda was bootable and uses a dos partiton table (instead of gpt). So it may be that Linux does not use either of those ESP's to boot. I'm kind of hopeful for that at the moment.

Would you be willing to try this experiment? If you can recognize which is the Linux drive inside the case, unplug the data and power cables to it. Then turn it on and see if Windows comes alive.

I'm not quite sure where to go after this test, but I would be very happy if Windows boots. And if it does boot, you could disable the hibernation while you can. Windows will need either sdb or sdc to boot from the ESP, but we don't know which one, so leave them both connected, and just disconnect Linux if you know which it is.
 

stan

Well-Known Member
Credits
4,577
And a correction by me... M.2 and NVMe are not interchangeable terms, as I made them sound. M.2 is a form factor, as opposed to SATA... your drive may or may not be NVMe. You might tell us if it is NVMe, if you know.

And thanks also for the lsblk and fdisk -l outputs. I would guess that all of the helpers here would be asking for those. :)
 

Tolkem

Well-Known Member
Credits
5,362
Hi, having some problems with switching to Linux. I have my Win 10 local disk on /dev/sdd and Ubuntu Linux on /dev/sda. I would like to access my windows local disk files within Linux but when I try to mount /dev/sdd to /mnt with:
"sudo mount /dev/sdd /mnt"
That's not Windows' partition. The right partition is the one with the label Basic data partition /dev/sdc3 that's the one you should be trying to mount.
Code:
sudo mount /dev/sdc3
Furthermore, sdd is the disk, the partitions are sdd1, sdd2 ... so trying to mount sdd won't work.

I did not ever boot successfully into windows after I installed pop os, so Im not sure what caused it first. I did boot into ubuntu once but chose the option to "test out" without installing, that was a couple months ago and I got back into winows.
You have Windows in 1 disk and Linux in a different one?
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
14,303
...so I'll call for helpers to come and look at your screenshots and offer more advice. @wizardfromoz @KGIII @f33dm3bits @Tolkem @gvisoc @jglen490 @dos2unix (Who else, especially with Windows experience?)
You rang?

I have to look at this a little more closely over my weekend, but an observation or two for now.

:)G'day @333pwn and welcome to linux.org - also thank you for the screenshots.

The GParted shots indicate sufficiently to me to agree with stan at #12 and Green Hornet at #16.

The predominance of Windows at (mostly) /dev/sdc and /dev/sdd makes me wonder whether the OP has had Windows on there, then taken it off and put on Linux, and then added Windows again.

Is that possible?

I am (agreeably) ever so outdated with Windows, this is my 8th year of using Linux exclusively.

Brian @Condobloke used to be pretty adept at Windows, what think you, Brian?

Cheers

Chris Turner
wizardfromoz
 

f33dm3bits

Gold Member
Gold Supporter
Credits
16,168
What I would have said was already mentioned by @KGIII and @Tolkem. You need the ntfs-3g driver to mount ntfs under GNU/Linux and you can't mount a disk that is partitioned since there are no filesystems on a disk but on the partitions of the disk.

About the dual booting, when I started with Linux uefi didn't exist and it's been a long time since I dual booted so I won't be much of a help there I think. But from my experience with efi is that both Windows and Linux should be able to access and write their efi stuff to it because it uses a vfat/fat32 filesystem. I'm getting the idea OP has trouble booting into Windows and is able to boot into Ubuntu that makes me think, efi got screwed up for the Windows install. So first thing I would do is what to check the efi partition to see if the efi files and directory for Windows still exist and what the contents are while being booted into Ubuntu.

Btw in those screenshots I see two efi partitions, /dev/sdc1 and /dev/sdb2. Maybe look somewhere in that direction?
 
Last edited:

stan

Well-Known Member
Credits
4,577
That's not Windows' partition. The right partition is the one with the label Basic data partition /dev/sdc3 that's the one you should be trying to mount.
D'oh... that mistake repeated in my instructions above. Corrected. Thanks!

The video the OP was following also gives correct instructions for adding the mount command to /etc/rc.local... drive + partition needed. Fixing /etc/rc.local might be enough to give access to Windows. :)
 
Last edited:

stan

Well-Known Member
Credits
4,577
Seems to be a consensus to check for ntfs-3g. I would guess Ubuntu includes that by default, but open up a terminal and confirm by:
Code:
which ntfs-3g
I'm using Ubuntu-based Zorin, and I find it installed in /bin.
 
Last edited:
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online

No members online now.

Latest posts

Top