Dual Boot Windows/Ubuntu suddenly can't mount /dev/sda1 . . .

bille7

New Member
Joined
Jun 30, 2023
Messages
5
Reaction score
2
Credits
47
Hi!

Am new to the forums and, as a retired Linux admin, this is embarrassing. It's amazing how fast details fade when you're no longer involved on a daily basis.
Anyhow- My personal pc boots Windows 11 or Ubuntu 22.04 . I use Ubuntu almost exclusively but just in case I need an app that's not available. . . hasn't happened so far,
(about 18 months using dual-boot) though.
Have recently been doing Ubuntu & Windows updates and installing video editing software off and on for the last month so not sure of the exact cause, but
now when I click on the "Files" folder at the left side of the display, then choose "Other Locations" and click "DATA", it asks for authentication OR sez
it can't mount /dev/sda1 to /media/bill/DATA1 <for various possible reasons>.
The mount points exist. /dev/sda1 is a separate ntfs drive. It's labeled as D: when running windows and all of the data seems to be intact, accessible
and write-able. I don't know what the Windows privs on the drive should be. I exit windows by doing a complete shutdown then hit the power button to go back
to Ubuntu. Can manually make a new mount point then mount /dev/sda1 over it, and can access the files ok but the drive gets mounted READ ONLY, even if the mount point
is created rwxrwxrwx, can't save or update anything thru the gui. I'm sure I've gone brain dead but any ideas would be much appreciated! OR ....if anyone can lend a hand
with the guitar solo to "The Final Countdown"....

A relatively dry day in here in the northeast for a change.

thanks in advance for any ideas!
b
 


Have recently been doing Ubuntu & Windows updates
and there you probably have it, Windows updates are renowned for breaking Linux grub..
Go back to the BIOS, and disable both Windows quick start[ fast boot] and secure boot, [Windows updates will have re-enabled one or both of them], power off the machine completely and switch on hopefully you will have your grub boot screen back
 
Welcome to the forums.

I never understood why people want to "dual-boot", while it's obvious M$ is so intent on getting people locked into their stuff. Somehow in the future the OP will have to pick one or the other, cannot have both.

They will go even further making sure that somebody who buys a computer with Windows installed on it, will find it near impossible to take it off in favor of any "free" operating system. Otherwise it becomes e-waste, and it's also obvious with what they (and their corporate "friends") have done starting with Windows8. Make computers become worthless even for Linux.

Actually I do dual-boot but I have an 11-year-old HP laptop which doesn't allow me to have just a GRUB menu. GRUB is really complicated and easy to mess up, that's why I don't want to depend on it. The computer doesn't boot into Windows straight away but it does if allowed for about 10 seconds. Otherwise I could press [F9]. I have to do this if I want to go into Linux. You call it clumsy but I prefer it this way instead of "dual-boot" which is a headache only to set up and to preserve from alteration.

If in case you have to boot to Ubuntu and cannot access GRUB, but could access a menu that BIOS/UEFI gives you then all you have to do is go looking for the EFI file for Ubuntu. It should be under "EFI/boot" somewhere in the EFI System Partition inside "Ubuntu" directory. If you're lucky a system such as one for HP could give you the entries to choose straight away, at least two of them LOL. But they all do the same thing.

I am not advertising for HP nor selling anything by them, but that's from my experience and what I have. Good luck.
 
and there you probably have it, Windows updates are renowned for breaking Linux grub..
Go back to the BIOS, and disable both Windows quick start[ fast boot] and secure boot, [Windows updates will have re-enabled one or both of them], power off the machine completely and switch on hopefully you will have your grub boot screen back
Thank you!!!! Will check it asap-
b
 
I exit windows by doing a complete shutdown then hit the power button to go back
to Ubuntu.
You don't say that you have disabled Windows hibernation. Since Windows 8 came out, Windows does not truly shut down when you tell it to... it goes into hibernation instead. Because of this, Linux may refuse to mount your Windows partitions, or in your case, that may be why it is asking for your root password (trusting if you are root that you have sense enough not to wreak havoc on your Windows system).

If the above tips don't help, try rebooting your system from Windows instead of shutting down, and then going into Ubuntu. Rebooting Windows does not put it in hibernation. Then having rebooted instead, see if you can do the file operations that you want to accomplish. If this works, you can disable hibernation permanently to prevent further problems.

Good luck!
 
Just disabled hibernation and fast startup. Back in Ubuntu- SOS. Thanks to everyone who wrote in!!
Will eventually get thru it-

Hope the weekend is GREAT!

cheers,
b
 
@bille7 if your happy how it's running, please go back to your first post edit and mark as solved [drop down box by title]
 
sorry about that! "SOS" - "Same Old .... " after disabling Windows Fast Boot & Hibernate. Can circumvent the problem
for the time being and will eventually get past it. In the meantime. it's ok to go ahead and close out this account!

b
 
still having problems? Which distribution are you using?
 


Top