Entire Machine freezing over virtualbox

f33dm3bits

Gold Member
Gold Supporter
Credits
12,612
I have updated the kernel this morning (the freezing was yesterday).
I assume it was all because of that.

Gonna try a different version of VB now.
So the freezing started since you updated the kernel and it was working fine before that or the freezing hasn't happened since you updated the kernel and rebooted this morning?
 


astralpr0jector

New Member
Credits
231
#2

The freezing STOPPED happening after I updated the kernel.
Now whether that has something to do with it initially, or perhaps the CPU usage was low today is still a question. The fact is, today I updated the kernel, and there also wasn't any full system freezing.
 

astralpr0jector

New Member
Credits
231
UPDATE:

I have just manually installed Nvidia driver, the exact one for my graphics card downloaded directly from there website and installed when booting etc (all that complicated setup lol), the result:
- GeForce HDMI port works, but the MOTHERBOARD hdmi port no longer works
- Virtualbox is still slow just like before.


I also checked BIOS:
- virtualization is enabled
- hyperthreading is enabled

I also tried reinstalled Windows 10 on a STATIC vdi rather than a dynamically allocated one. Still same result, runs laggy.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
12,612
Create a second vm, configure it with the same virtual video card(VBoxSVGA 256mb 3D) as your Windows vm. Then install Linux Mint on it and see if you have the same lag or that it reacts normally?
 

astralpr0jector

New Member
Credits
231
Installed Linux Mint.
Tbh, it runs pretty LAGGY too. I opened firefox and I can see the delay's in the loading icons and other animations...

I was not, however, able to set the virtual video card to VBOXSVGA.
When I try to do it there is a warning that it is not the correct one to put. If I ignore that warning and boot the virtualbox, it just sets it back by itself to VMSVGA.

Screenshot attached.



UPDATE:
This is a newly built PC (my first time building one). I had a theory yesterday that maybe this has something to do with maybe the fans not being installed correctly. Was looking around in the computer today, all fans are working and CPU temperature is stable at 32 celcius.
Do you know if hardware build can somehow have an effect on this?
 

Attachments

f33dm3bits

Gold Member
Gold Supporter
Credits
12,612
That sounds like a normal CPU temperature, if it were some hardware problem I would expect your physical/host machine to have problems. VMSVGA seems to be the one you need for Linux guests, did you try increasing the video memory to 128MB?
I just installed Virtualbox(6.1.18) and a vm with Mint 20.1 using:
- Video Memory: 128MB
- VMSVGA
- 3D Accelaration
And I'm not experiencing any lag or graphics glitches in the vm.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
12,612
I actually install Windows10 in virtualbox vm and then I installed the guest additions, it's after I installed the guest additions that I got the same graphics glitches that you have and the same lag that you have. Try removing guest additions: Open Control panel -> Programs -> Programs and Features; Then select virtualbox guest additions and click on uninstall. Reboot your machine and see the lag and graphics glitches are gone?
 

f33dm3bits

Gold Member
Gold Supporter
Credits
12,612
I found the answer, it seems like it's a problem with the newest virtualbox and the newest nvidia drivers:

Try downgrading your nvidia drivers from 460 to 450 through the driver manager in Mint on your host system, then reboot and see if the glitches and lag are gone in your guests(Windows and Mint) with guest additions still installed. Btw what graphics card does your friend have in his system that doesn't have these lag and glitch problems?
 
Last edited:

astralpr0jector

New Member
Credits
231
Uninstalled Guest additions: Not same type of lag, but still laggy.

Downgraded to Nvidia 450: Same thing. No difference at all. Played around with all virtualbox display settings.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
12,612
The last idea I have is to disable 3D acceleration and use the 450 drivers and otherwise I would suggest posting on the Virtualbox forums since they will probably be able to help you. Your other options would be to try to setup xrpd(don't know if that suits your needs) or to try QEMU/KVM on Linux Mint:
If you do try that you will need to download this iso(virtio-win-guest-tools) and mount it on your Windows vm and then install the drivers from there.
 
Last edited:

Staff online

Members online


Top