Ethernet not working, since updating and rebooting


New Member
Sep 6, 2020
Reaction score
Suddenly my ethernet stopped working, i didn't touch anything, just updated, upgraded and rebooted, the cable is ok i tested it on my pc and the ethernet works, also ethtool says the link is up and detected, i have no idea what's the problem?, any help, also set static ip 2 weeks ago worked fine until now, also the lights on the ethernet port are lighting, the orange is constantly lit and the green occasionally flashes, wifi works no problem,tried a lot of things, modifying /etc/network/interfaces, nothing worked, spent days finding any solution to this, nothing helped, i have no idea what's wrong, i'm desperate, would really appreciate some help because i need this server online asap, using debian buster, can't even ping my router or any other ip, also tried without auto lo, iface lo inet loopback, didn't work, maybe it's some driver problem, also kernel updated


  • Annotation 2020-12-17 174845.jpg
    Annotation 2020-12-17 174845.jpg
    23.2 KB · Views: 409
  • Annotation 2020-12-17 174821.jpg
    Annotation 2020-12-17 174821.jpg
    79.8 KB · Views: 395
  • Annotation 2020-12-17 174757.jpg
    Annotation 2020-12-17 174757.jpg
    70.6 KB · Views: 421
  • Annotation 2020-12-17 174653.jpg
    Annotation 2020-12-17 174653.jpg
    10.5 KB · Views: 392

I think the problem is in the latest kernel, i switched to an older kernel 5.8.16-sunxi64, and now ethernet works without a problem and everything else.

Latest posts