• Rob's side project: I recently started Gun-Forums.com and we currently have a $100 raffle - if you're into guns, join up and enter the raffle to win $100.00. Gun Forums

Ethernet problem

billw

New Member
I'm stumped! I'm bringing back a computer after being powered down for a year. As expected I've had problems. On the windows side I've decided to blow it away and start over due to problems there. On the Linux side I installed Fedora 31 over the old system (complete new formatting/install). My ethernet now refuses to start up and connect to the router that's running the DHCP server. The networking was working fine and reliable when booted into Windows before I deleted it. I've deleted the network profile and reconfigured a new one with no luck both using the graphical tool and nmcli on the command line. I downloaded a live copy of Ubuntu with the same result when I booted that system. Any help or suggestions (or WAGS!) would be appreciated.
Thanks,
Bill

EDIT: This is the wired connection, by the way :)
 
Last edited:


Drizzit89

Member
Are the Linux OSs detecting the device and applying the correct driver or is it possible that they are trying to use a generic driver for the ethernet card that is not compatible? Try running the "dmesg" command in either or both OS and look for errors associated with eth0 or other NIC/ethernet devices and drivers.
 

billw

New Member
Here's some more info. The ethernet controller is an Intel I218-v onboard controller (per lspci). The driver is e1000e (per lsmod). The configured device is eno1 (per ifconfig). In my simplistic view all seems well???
 

atanere

Well-Known Member
Hi Bill, and welcome.

Linux can have driver problems with anything that is latest-greatest hardware, but that is not the case with your older computer. And Linux is a master of ethernet connections and rarely requires anything more than simply plugging in the cable and (sometimes) rebooting to make it all work. At this point, I would do all of your further testing with your live Ubuntu USB, or some other live distro, to be sure that the changes you made in Fedora are not contributing to the problem. Any live distro should connect easily to your router.

So, in the WAG department... remember that all components CAN fail. It is possible that your ethernet card simply gave up and died, but I seriously doubt it.

The simplest and most likely cause is your ethernet cable. Check the connections at both ends, or even better.... replace it with a new one.

If your router supports wireless, and if you are interested in switching, this dongle is one that I often recommend. It's cheap, but it's not the fastest, and it's kind of big and clunky. But it has been rock solid on every Linux box I've connected it to, and the larger antenna helps give better range than smaller devices.

Cheers
 
Last edited:

billw

New Member
Hi Atanere,

I have cleaned out the machine and started over so my windows partition no longer exists but while that partition was active the network was stable with all the present hardware under windows. I was having other problems with windows that caused me to just give up on it. My biggest problem here is that Linux is totally reliable in regard to the ethernet connection and therefore I have zero experience in troubleshooting a problem like this over the last 20 years or so. :D Thanks for the suggestion of using the LiveDVD for troubleshooting once I start making changes. Good point. At the present time Fedora is a fresh install without alteration. I'm about to the point of rechecking things like the cat5 as I have no other ideas of what to try. Everything I check says it should be working (I am not an experienced admin though so I could easily be missing a finer detail or two!).
Thanks for the input,
Bill
 

atanere

Well-Known Member
The configured device is eno1 (per ifconfig).
The eno1 device identity also indicates it is an onboard adapter... check your BIOS/UEFI settings to make sure it is enabled there. Do you not see an IP address with ifconfig, as well as RX and TX packets with values other than zero?

If you see RX/TX packets, try to ping 8.8.8.8 and/or ping google.com.

If RX/TX packets are zero, try to start the interface with sudo ifconfig eno1 up and provide your password. Then test ping again.

Keep thinking about that Cat5 cable too though... especially if you don't have an IP address and if you don't show any RX/TX packets.
 

billw

New Member
ifconfig shows RX packets 23 bytes 2881 no errors, overruns etc. TX packets 61 bytes 9291 and zeros.
The pings show network not reachable before and after the ifconfig eno1 up. I'm going to check the BIOS again (I didn't see any related enable last check) and replace the cable again :).
Thanks!
 

billw

New Member
I messed up earlier. There is an "Intel LAN controller" enable/disable in the BIOS. It was enabled and LAN boot options are disabled. Cat5 replaced and connection LED on the switch shows "conneced". Same result, connection failed after reboot!
 

atanere

Well-Known Member
Well, you're on the right track, I think... a methodical process of elimination. Having a link light is a good sign. I take it there was no IP address in ifconfig either? Actually, copy/paste the ifconfig output here... maybe something else will stand out.

Also, try ping 127.0.0.1 and see if that works.
 

billw

New Member
Yes the link light has been working. Remember that the same hardware was working fine when system was booted into Windows. lo is fine and pings successfully.

ifconfig output:

enol1:flags=4163< up,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet6 xxxx::xxxx etc. prefixlen 64 scopeid 0x20<link>
ether xx:xx: etc. txqueuelen 1000 (Ethernet)
RX packets 30 bytes 4435 (4.3 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 76 bytes 11584 (11.3 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 20 memory 0xdfe00000-dfe20000

Transcribing into a tablet makes you appreciate cut and paste :)
 

Nik-Ken-Bah

Well-Known Member
G'day @billw and welcome to the community.
An interesting problem similar to the one I am experiencing. So I will watch and learn.
 

atanere

Well-Known Member
Actually I've been around for years. I've just been inactive due to a move and was too lazy to try and find my old account info
The forum had a major reset in 2017 (April, I think), and your old login info won't work if you signed up before then. You could have reclaimed your old username with a new account though.


An interesting problem similar to the one I am experiencing. So I will watch and learn.
Yes, it is similar... but I have struck out with yours, it seems, and my bag of tricks is running very low now for Bill too. :(o_O


Bill's descriptions and testing have all shown just as he said... it looks like it should all be working, but it isn't. The adapter is "up" and you can ping the localhost okay, so it seems it is functioning... but it is not getting an IP address from the router (which is DHCP). The cable is good, has been exchanged, and shows a link light (at the router end too, right?).

So, all signs (to me) are pointing to the router now... yet it worked with Windows recently. There are few, if any, settings in a router that I know of that would be OS-specific. So if Windows works, then Linux should work too. This should be very easy with DHCP. But one or the other, the adapter or the router, is fooling us.

Back to the WAG department...

1. If you haven't already, by all means reboot the router.

2. If you haven't already, switch your ethernet cable to a different port on the router. Be sure the link light is on at the router too.

3. If you haven't already, try both Fedora and your LiveDVD. Even download and try another LiveDVD or two, or three.

4. If you haven't already, log into your router and carefully examine all of your settings to see if you can spot anything there that might explain this. For example, I use to set my router to only allow a very small number of incoming connections on my LAN, just enough to cover my devices. If yours were similarly limited, that could explain why it won't issue an IP. Not a likely scenario, I know, but we're back at WAG's now anyway.

5. While you're in your router configuration... look at the IP range it's using for DHCP, where it starts and how many it allows. I'm not sure if it will work, but you may can assign a static IP address to your adapter to match your LAN config, and perhaps force the router to recognize it. Again, not sure about this.... I've never tried it. Worst case might be to manually configure everything on your LAN and not use DHCP... which could be a whole lot of trouble with people using so many devices these days.

Maybe some of the smarter people will jump in here with better ideas too! :cool::D

Cheers
 

poorguy

Well-Known Member
Perhaps this will help.
 

billw

New Member
Thanks atanere and poorguy. Anything can help at this point. I'm getting the strange feeling that at some point it will just start working and you will see me sitting there with a stupid look on my face scratching my head or I will locate something really stupid that I did to hose the whole thing :D.

As a bit of an update, I did switch it to a static IP and it now says connected but it's just kidding. Still no ping to the router. I'm not sure if that is progress or it just assumes that it is connected due to not seeing any failed handshake with the DHCP control from the router?
 

atanere

Well-Known Member
Thanks atanere and poorguy. Anything can help at this point. I'm getting the strange feeling that at some point it will just start working and you will see me sitting there with a stupid look on my face scratching my head or I will locate something really stupid that I did to hose the whole thing :D.

As a bit of an update, I did switch it to a static IP and it now says connected but it's just kidding. Still no ping to the router. I'm not sure if that is progress or it just assumes that it is connected due to not seeing any failed handshake with the DHCP control from the router?
A lot of solutions look really simple.... AFTER you discover them. It's that in-between time that can be pretty frustrating. o_O

A couple more WAG possibilities, but way more effort:
1. Take the computer to a friend's house and see if it will connect to a different router.
2. Reset your router to factory settings and start over. (Sorry, WAY MORE EFFORT, and probably not the best choice either.) A better option like this might be to find a friend who has a spare router that you can borrow and try a temporary setup without destroying everything that is currently working for you. If your router is a modem/router combo... well, never mind. :oops:

But, while you've got a static IP configured now.... did you set the default gateway? And netmask? And DNS server? The default gateway would be most important, but maybe the other settings too. I'm not familiar with Fedora/RedHat systems, but route add or ip route add are the most common methods with Debian/Ubuntu. These instructions seem to cover everything in Fedora.
 

billw

New Member
Fedora 31 has a graphic config tool that is rather simple and (I assume!) works. I did set the netmask and default gateway. I left the DNS server in auto which may be something to play with.

The router (RT-AC66U) is the one I've been using before the move so at this point I haven't suspected it but I may back it up (I think I can do that?) and set the factory default settings. It'll should only be a lot of work If I find that this exercise cures the problem, otherwise I'll just restore the backup. Another option I can think of is to load up an older version of Fedora and see what happens. I seem to remember a connection problem when I first booted the computer before I upgraded it. Unfortunately that was when I looked at it as a minor problem and didn't really take note as to what was happening.

The only hardware that is new from when this system was on line at the old house is the ISP cable modem sitting between the outside feed and the router. That shouldn't be able to prevent me from getting to the router from this side.
 


Members online


Latest posts

Top