Ettercap only shows virtual hosts


New Member
Dec 15, 2020
Reaction score
I just installed Kali linux on VM. I learned some things and start working with ettercap and wireshark. When I first time scaned for hosts I found online that I need to reinstall ettercap, so I did according to some article on stack overflow or github and I am sure it is not the problem. When i start search i click scan for hosts and get 3 results(all of them are Virtual hosts I think), I connected every combination and tried sniffing in wireshark it loaded some things but did not load i do not know searches I did on every possible device connected to network, it loaded some ARP protocole informations but nothing useful, and it loaded that every like 3-4 minutes. I am sure I did nothing wrong in setting up ettercap and wireshark. Can it be something like firewall or DNS? Can someone help me to solve this?


Gold Member
Gold Supporter
Dec 11, 2019
Reaction score
Do you mean you tried sniffing a wireshark capture with ettercap?I don't know anything about the tools in Kali, all I know is that for different tools in Kali your wireless card should support monitoring mode, try finding out if your wireless card supports monitoring mode if it doesn't I would start there but I would also recommend you ask your question on the Kali forums since the Kali tools are usually not installed by default on other GNU/Linux distributions and there are only a few people here that have some Kali knowledge who I haven't seen in aw while so you are more likely to get an answer on the Kali forums.
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online