Failed to start x server



Hey guys, so i recently bought a hp 11-e004 laptop and its a bit slow with windows 8 so i tried installing linux. Pretty much a noob when it comes to linux.
I had ubuntu 34bit on a usb and tried it out, i got it to boot but it went to gparted and i didnt know what to do from there, i wanted to install linux mint 64 so i shut down, dloaded mint and booted it using unetbootin. It booted up but gave me the error failed to start x server. This may have occured because i tried ubuntu and they got mixed up or somethin. Anyway i jus want to use mint so my laptop will be faster and easier to run. I dont know or want to mess around with any coding. If anyone can help me with fixing this problem and gettin mint up and running it will be greatly appreciated.
Also i chose mint because it seems very user friendly and easier for linux noobs aswell as being good for general purpose use, would ubuntu or another distribution be better?
Thanks, supunz

The X server not starting thing is probably because of a video driver/configuration issue. When bringing up new systems here at work, what we do is try the latest Ubuntu live boot disc. If it fires up with that, we can then go to work seeing what drivers and configurations we need with our distro of choice, reasonably confident that there's a driver available to support our hardware.
I can't seem to find the specs of the laptop. What are they?
I had ubuntu 34bit on a usb and tried it out, i got it to boot but it went to gparted and i didnt know what to do from there, i wanted to install linux mint 64 so i shut down, dloaded mint and booted it using unetbootin. (...) This may have occured because i tried ubuntu and they got mixed up or somethin.
In case you used the same flash drive for Ubuntu and, subsequently, Mint, did you format the usb drive before writing Mint into it with unetbooting? If you didn't, you may have "mixed" them. Always use a clean drive with unetbootin.
Yesyesloud, yea i formatted always before using unetbootin to fat32.
I dloaded ubuntu 64 and booted it, the option window came up and i chose try ubuntu before install. The ubuntu logo came up with the five dots which showed the progress and after that it jus went to a blank screen. Black with nothing on it, the computer was still running fine. So i held the power button down and retryd it but the same thing happend again.
Your laptop has a Kabini APU (AMD Dual-Core A4-1250 APU) in it. Currently Ubuntu 13.10 (Mint 16) does NOT support it. At least without extensive changes.

14.04 should have support when it is releases.
When using Mint 16 (or Ubuntu 13.10):
1. After the "failed to start x server" run the following
sudo Xorg -configure
sudo cp /home/mint/ /etc/X11/xorg.conf
*if Ubuntu 13.10
sudo cp /home/ubuntu/ /etc/X11/xorg.conf
2. You should now get the desktop
3. Install Mint like normal. Include all updates
4. Now you must install the AMD 14.1 Beta driver.

* To be honest I spent a lot of time on an E1 AMD Kabini APU. I could never get it to work properly.
Last edited:
Thanks for that ryanvade, ill give it a go and see what happens. Do you know when 14.04 will be released? Also does anyone know of any other alternative os that i can run for everyday use because windows 8 is barely usable. I cant even watch videos on youtube without lag. Would windows 7 work better?
14.04 = YEAR.MONTH of release, so April 2014. Normally it is late in the month.

I am afraid to say all the Kabini chips are, frankly, slow. The cpu portion is running at 1 Ghz with only a level 2 cache. On the other hand integrating the Graphics into the same chip does speed it up a little. AMD is leading with the APU market but I can't wait to try Intel's version. ;)

Now for other OSs. The AMD APUs are designed for Windows 8. Not in terms of hardware, but in terms of drivers. However, even with the latest drivers AMD has not really worked out all the kinks of the new chips. Linux has the best chance of getting support after Windows. Then FreeBSD, then Solaris, then OpenDarwin, then Hackintosh, etc. The new APUs will be fully supported in a year or two I think.

Windows 7 will not have better support for these chips then 8.

**I think Linux kernel 3.13 will be the first fully to support Kabini.
Thanks for the reply ryanvade, i seem to have a lot of bad luck when it comes to small laptops. If you recall i was tryin to get linux running on my hp x2 11 and gave up, sold it for nearly 200$ less and bought this only to run into a different but equally troublesome problem. Thanks again guys, i will have to live with windows 8 haha
Yeah, that seems to be the case with these APUs. All I can say is either try some really advanced hackery on the drivers and system. Or wait for the developers to do it. :)
APUs architectures are not that new (as in meant for Win8, even in terms of drivers)... I own 2 machines with APUs and they work really better on Windows 7 - actually, they rock on ARCH :D.
Mine are A-series though, so there's probably some difference.

Intel has actually released chips APU-like (CPU with built in GPU). They're good, but AMD keeps ahead in that department (best performance for cpu+gpu in 1 chip, no discrete graphics card).

Anyway, why not try some development distro with an (almost) state-of-the-art kernel?

Besides, as ryanvade mentioned, installing Catalyst 14.1 may also help (a lot, in some cases).
Last edited:
Also, you could install any distribution and compile the latest development Kernel (3.14-rc3 as of 2014-02-16 -

A "simpler" way to do it is by installing ARCH or variant distros and loading linux-mainline package from AUR repositories - package info.

In this case, you'd have to use open source drivers for now. Although sometimes troublesome, they work great depending on your system and what you wanna do with it.
Last edited:
Liquorix kernels 3.13 and above for either Arch (a la Yesyesloud) or a stripped-down Debian distro like antiX would be a good suggestion. With the latter, one can use the post-install script smxi to assist the process -- it's very easy and convenient -- as shown here.
Last edited:

Members online