New Member
Apr 6, 2022
Reaction score
Hi, total newbie to Linux so please don't shout if I have posted this in the wrong place.

My son has an old iMac which he somehow managed to wipe the Mac software off and install a duel boot system of Ubuntu and CloudReady.

All worked good for a while until one day Grub wouldn’t allow a boot into Ubuntu, a few months later and now he can’t boot into Cloudready either – all you get is a loop of it boots, some Grub error briefly appears and then it boots again.

I tried to create a Grub recovery USB however the USB does not appear to be recognised at boot up (press Alt at boot and get a choice of the hard disk only)

I managed to find the original USB stick he used to install Cloudready, from this I can USB boot into a guest account and get access to the terminal window.

I have also noticed that the USB with the Grub recovery on can be seen within Cloudready file explorer which seems strange that it cannot be seen at boot.

Anyway, with a Terminal window I have managed to figure out how to get shell access to run sudo commands (not too sure what they are but any script I find online is prefixed with sudo).

Trouble is any other command such as ‘apt’, ‘apt-get’ etc are met with a ‘command not found’ error so where I find online resource telling me how to fix Grub using command line I can’t get any further.

So, basically I am looking at help on how to re-install ‘apt’ (and anything else anyone thinks I may be missing), how best to fix grub, and some basics on how to move around folders in Linux using command line (from the little I know windows has commands such as dir etc).

Hopefully from there I can work out how to make it all work again for my son.

Many thanks for taking time to read / any help you can offer in advance.

Once again apologies if in the wrong forum thread, I chose command line as it’s about the only access I can get at present.

In my experience I've solved problems like this by booting into a Live USB and running ubuntu's boot repair.

It's kind of a "hammer" approach though as I'm not very familiar with GRUB so I'm not sure what exactly boot-repair does to it behind the scenes.
I tried to create a Grub recovery USB however the USB does not appear to be recognised at boot up (press Alt at boot and get a choice of the hard disk only)

Welcome to the forums
this article is the beginners guide to installing Linux, provided you have made a bootable pen-drive it should help you.

To enter quick boot menu on a Mac, Start up the computer and hold the "Option" key to bring up a screen that will list available boot devices, This interface should show all drives including USB, & FireWire, .

How Do I Install Linux (A General Guide) • Linux Tips
Hello @Tiggerbasher and welcome to the forum.

Unfortunately Cloudready is not a true Linux distro. So not sure if linux commands would work in it's terminal. But it's worth a try
you can issue this command and see if it works
sudo update-grub
But what you actually need is the original Ubuntu usb stick that ubuntu was installed from or down load it again and boot from that. Then issue the command given. Good luck.