GAH! "No such file or directory"

HAL_2000

Member
Credits
1,055
Hello Experienced Linux users,

Long-time Windows user, exploring Linux here, now running Ubuntu-based LXLE 18.04.3 32-bit on a Sony Viao Intel Core i5 testbed.

LXLE runs nicely OOTB (Out Of The Box), but now trying to follow the download and Command Line instructions found on this page:

How To Make Linux Look Like Windows XP

Author Derrik Diener, was kind enough to make his tutorial PLAYSKOOL simple by providing Command Line Instructions (CLI) for each step. (Or so I thought. The attached video is singularly opaque).

Unfortunately, after seeming to successfully download the theming app (including themes and icons), entering the CLI, terminal is refusing the instructions -- in a form of Cybernetic 'Simon Says' -- and responding with a repeated: No such file or directory.


My Understanding of the Relevant Directories


1) the initial directory for the theming app [Longhorn-Collaboration] would be downloaded by default to

/home/PC_Name/Downloads/Longhorn-Collaboration



2) The intermediate destination for the files would be:

/usr/share/themes


3) Diener's CLI cheat includes one of the following:

sudo mv ~/Longhorn-Collaboration/Windows\ \Longhorn\ \Slate /usr/share/themes/



4) the following are found in the various sub-directories:

/Downloads/Longhorn-Collaboration/Windows Longhorn Aero
/Downloads/Longhorn-Collaboration/Windows Longhorn Jade
/Downloads/Longhorn-Collaboration/Windows Longhorn Slate



5) Longhorn-Collaboration can be found in "/usr/share/Longhorn-Collaboration"

But clicking on it redirects you to:

/home/PC_Name/Longhorn-Collaboration/Windows Longhorn Aero

"Jade" and "Slate" are found separately in the same manner.



6) Following the CLI cheat codes, viz..

sudo mv ~/home/<username>/downloads/Longhorn-Collaboration/Windows Longhorn Plex /usr/share/themes

yields:

mv: cannot stat '/home/<username>/downloads/Longhorn-Collaboration/Windows': No such file or directory


7) Eventually, I understand that I have to move the theme-and-icon sets to the respective sub-directories:

/home/PC_Name/.icons

/home/PC_Name/.themes


DISCUSSION

My understanding of computer commands is that they can be real idiot-savants like Rainman -- they can perform excellently, but you have to be absolutely precise in giving them a command.

Could it be that my default "/Downloads" sub-directory is spelled with an upper case, therefore confusing Linux, telling it where to look for the file or app in question? Or is it some other issue with the instructions? Once again, the instructions are located at:


...and I am using the instructions given for Debian, since LXLE is Debian-based.*
[self-correction: No. It's Ubuntu-based.]


In short, how to I get these theme-and-icon files safely into their /.themes and /.icons destinations?

Thanks in advance.


*
 
Last edited:


jglen490

Active Member
Credits
1,319
The line
sudo mv ~/home/PC_Name/downloads/Longhorn-Collaboration/Windows Longhorn Plex
has embedded spaces between the words Windows and Longhorn and again between the words Longhorn and Plex. This results in the error, with the error message stopping after the the word Windows.

Change your entry such that it looks like this:
Code:
sudo mv ~/home/PC_Name/downloads/Longhorn-Collaboration/Windows\ Longhorn\ Plex /usr/share/themes
the backslashes tell the shell that the space characters in the line are a part of the string, and not the end of the string. The space after the word Plex is fine.

The "~/home/PC_Name" looks weird, also. The ~ is normally translated by the shell as "/home/<username>", so unless you actually have a directory literally named "/home/<username>/home/PC_Name", you have more problems. The <username> part is of course the user that you are signed on with in the command line shell session.
 
Last edited:

dos2unix

Well-Known Member
Credits
1,029
Double and single quotes also work.

cd "/home/user/my directory with lots of spaces in the name"

scp 'my file with spaces in the name.txt' [email protected]:/home
 
Last edited:

HAL_2000

Member
Credits
1,055
Hello
@jglen490 and @dos2unix,

THANKS.

I did manage to get the themes installed, so good to go.

Now, I am trying to follow the instructions as to ICONS.

Using the CLI instructions given on the webpage,
but what terminal is giving me back is:

mv: cannot stat 'icon-theme-folder': No such file or directory

NOTE: I must make a correction. I am on a [em]different[[/em] machine, which has LXLE loaded 18.04.3 -32-bit and it is *Ubuntu* not Debian based. (Silly me. Duh)

And among other things, I need to ensure that I can unzip files, thus:

sudo apt install wget unzip
Accomplished.

I download the icons file and unzip them, and so far, so good.

But upon reaching this command:

sudo cp WinXP-Icons-master /usr/share/icons/

Terminal responds with:

cp: cannot stat 'WinXP-Icons-master': No such file or directory


The Cheat page gives you an option to use an alternative command:

sudo mv WinXP-Icons-master /usr/share/icons/

again, the response is No such file or directory.

I use the file manager to look and see if any of the icons have been unzipped and installed to the hidden /.icons sub-directory, but it is empty.

I use File Manager / Search to see if I can find Master.zip or WinXP-Icons-master in the /icons subdirectory, and no joy.

Master.zip IS located in /Downloads, as is Windows-7-master.zip

QUESTION:


So what do I need to do to Unzip these icons and get them into the /.icons sub-directory?

Almost there.

=====================
EDIT
=====================

In previous attempts to install icon packages the procedure involved downloading a compressed package of icons to the /Downloads directory. Using the file manager, selected the compressed / or zipped file, and extract all to the /.icons directory.

Thereafter, in the Look and Feel application, you could select Windows-themed icons for the desktop.

For some reason, when using File Mananger (PCManFM) going to /Downloads, click on the compressed icons file, then select all, then extract to, you seek out the hidden /.icons sub-directory, and, lo, the /.icons sub-directory is now hidden.

Even after typing in the exact directory location, selecting all the files to be extracted, and instructing Ubuntu-based LXLE to extract all the compressed files to the /.icon directory, what results is an error message indicating that File Manager has Insufficient Permission to extract and install those files.

I am consulting this page in the meantime:

How to Manage File and Folder Permissions in Linux

But it doesn't discuss how I can elevate my File Manager to the level where it can extract and install files.

Thanks in advance.
 
Last edited:

dos2unix

Well-Known Member
Credits
1,029
A few things here.

First your file manager only has the same permission you do. If you login as a "normal" user.
You only have "normal" permissions in file manager. Usually you have to go into the
terminal/console/CLI in order to do much as root.

Second, usually unzip will "unzip" the archive in the directory where the zip file is located.
You said the zip file was in Downloads.

You will need to move this directory. From what I gather...

cd Downloads
sudo mv Win-XP-Icons-master /usr/share/icons

is what you want to do.
 

HAL_2000

Member
Credits
1,055
Thanks Guys,

I think that one of the issues was that File Manager somehow installed without root permissions.

SOLVED:

lxlelxle June 24 1 Like Unlike
PMPosts: 2,533
you can open the directory as root by right clicking on it and selecting 'open as root'... or you could launch pcmanfm from the terminal as root using gksu pcmanfm.

After that, the downloaded files easily extracted and moved into the /.icons sub-directory and the new icon selections appeared in the SETTINGS -> Look And Feel -> Icons App.

New icons are now installed.

Thanks to all.
 

Tolkem

Well-Known Member
Credits
962
So what do I need to do to Unzip these icons and get them into the /.icons sub-directory?
For future reference, if by /.icons you mean the one located in your home dir, next time you can just decompress/extract the icons file and then move/copy the resulting extracted folder to that dir using the file manager; just hit Ctrl + h to show hidden files and directories and you'll see the .icons folder, just copy/move the icon pack/theme either by dragging it into it, right-clicking and selecting move/copy, using shortcut key Ctrl + x to cut or Ctrl + c to copy, double-click on the .icons dir or select it and hit enter and paste the icons folder using whatever corresponding method you prefer. No need for such complicated processes; just extract the icons and copy/move them to the .icons dir and they'll be automaticaly available.
 

HAL_2000

Member
Credits
1,055
For future reference, if by /.icons you mean the one located in your home dir, next time you can just decompress/extract the icons file and then move/copy the resulting extracted folder to that dir using the file manager;..... No need for such complicated processes; just extract the icons and copy/move them to the .icons dir and they'll be automaticaly available.
Fantastic. Thank you.

I had actually been doing something like that on other testbeds, and I wonder if, during the OS install that I did not set myself up with root privileges? Because this time around, when I attempted to click on, select, extract the zip package, there is a box at the bottom of that menu which has a space for password (I suppose the GUI equivalent of "sudo"), which was greyed out, and defied any entry of a password.

And, in an act of electronic obstinence, when it came time to answer the questions of where to extract to, hidden files remained hidden. When trying to kludge around this by typing in /username/.icons LXLE would spawn an error message with a big red X saying I had insufficient privileges for that operation.

At bottom, it seemed when I logged in, it wasn't as owner, or admin, or root, but as some other, with restricted access, and the normal process you described was blocked.

Once LXLE, in the LXLE user forums, (probably the guy who coded the distro), gave me the key to elevate user privileges in Terminal, that seemed to permit the installation of the package to go forward.

To avoid a repeat of this mess, how do I log in as Owner/Admin/Root?

Once again, many thanks.
 

Tolkem

Well-Known Member
Credits
962
during the OS install that I did not set myself up with root privileges?
As far as I know LXLE offers a graphical installer which makes the install process easier and it should create a regular user. When you log in to LXLE, you should type in your user - who has regular's user persmission - and the password for said user - which is the "sudo" password too - once you're logged in, you could check your user by opening a terminal and typing
Code:
id
which Prints user and group information for the specified USER, or (when USER omitted) for the current user you should get a list with some numbers and other items, like :
Code:
uid=1000(user_name) gid=1001(user_name) groups=1001(user_name),24(cdrom),25(floppy)
UID stands for user identfier and GID group identifier. In the example above those numbers are what regular - non root - users should get, root's UID is always 0. So, you might try and see if you get something different when running the "id" command in a terminal in LXLE. You might want to read here https://www.debian.org/doc/debian-policy/ch-opersys.html#uid-and-gid-classes and here https://wiki.archlinux.org/index.php/Users_and_groups for a better understanding on this topic.
 

jglen490

Active Member
Credits
1,319
But upon reaching this command:

sudo cp WinXP-Icons-master /usr/share/icons/

Terminal responds with:

cp: cannot stat 'WinXP-Icons-master': No such file or directory

The Cheat page gives you an option to use an alternative command:
...
You may have already found the answer, but JIC the most certain solution is to reference the full path of the "from" side of the command. So entering
Code:
sudo mv /full/path/of/the/source/for/this/WinXP-Icons-master /usr/share/icons/
would ensure only the correct source directory is moved or copied. I've copied the wrong file over the desired target before, just because Linux will look in the PATH variable first for a file. I've also deleted most of my installation by accident simply because I did not refer to the absolute path of my backup drive when deleting stuff. Live and learn.

It's a few more keystrokes, but it's absolute certainty. There are other tricks, but I will never make that second mistake again :eek:
 


Members online


Top