General Question

alkion

Member
ACPI:
 


alkion

Member
It could help, but a little risky.
 

blackneos940

Active Member
Manjaro was based on the Arch Linux distribution, but uses its own software repository. The assumption of distribution creators is user-friendliness, while maintaining basic compatibility with the Arch Linux distribution. In particular, like Arch, Manjaro uses the Pacman package manager and the unofficial, additional AUR software repository (short for Arch User Repository).

Manjaro contains three official software repositories: Stable - whose packages have been checked and found stable by the developers of the distribution; Testing - packages currently being tested, potentially unstable; Unstable - packages not tested and potentially dangerous for the proper functioning of the system.

Debian is the best ;)
I'm about to install Debian today. :) It's got Chrome, it's got VICE, and it can pretty much install anything Ubuntu can. ;)
 

alkion

Member
Debian is more than just the operating system itself: it contains over 59,000 packages, which are compiled programs packed in a way that allows easy installation. o_O o_O :)
 

poorguy

Well-Known Member

Jeffrey Lapinski

Active Member
Yes! That is it. I have to check the model numbers to be sure but it is a 17 in 16 gb originally had a 256 gd ssd that I replaced with a 1 TB ssd
 

poorguy

Well-Known Member
I don't know that I'd jump out and update the bios.


From reading the other threads about this problem you are able to install and run Linux Mint 19.2
using an older 4.15 kernel.

Is this correct.
If this is correct than I would download Linux Mint 19.1 and use it.

Linux Mint 19.2 uses a HWE stack kernel and these can be problematic with some hardware.
 

Jeffrey Lapinski

Active Member
I know, I hope I don't have to go that route. I found a few articles/discussions that listed BIOS update as a solution.

I am able to install LM and I have Cinnamon and MATE each installed and working on separate partitions. Despite disabling secure boot I either boot directly to the GRUB for my LM distros or I will begin to boot from the live USB and it will freeze at the boot menu. The BIOS doesn't give me an option for legacy boot. If the live USB does boot I usually get a loop screen of ACPI errors as well.

Both Mint installs are working perfectly.
 

Jeffrey Lapinski

Active Member
From reading the other threads about this problem you are able to install and run Linux Mint 19.2
using an older 4.15 kernel.
You are correct, but here is an odd thing as well. I want to have a KDE distro so I decided to just download 18 Sylvia KDE edition. I figured it was also using an older kernel so it shouldn't be a problem. No luck, same error!
 

poorguy

Well-Known Member
Linux Mint 18,3 Sylvia is using a HWE Stack kernel and as mentioned in an earlier post those can be problematic with certain hardware although not always.

It is possible that a bios upgrade may solve the problem but I don't know and if you choose to do that make certain you understand how to do it correctly or you can brick a working computer.

If Linux Mint 19.2 is working I'd use it and be happy since you have had the problems you have had with other Linux Distros.

Linux usually works well with Intel although yours is a newer laptop so it is possible that driver support may not be there in non Ubuntu based Linux Distros although I may be wrong about that.

The new UEFI / EFI secure boot bios can also be a PITA sometimes and not want to cooperate.

That's a head scratcher for certain.

I'm not trying to be negative.

From the other threads about this you appeared to have tried several different things without success although Linux Mint 19.2 works with an older kernel so that may be your best end result.
 

Jeffrey Lapinski

Active Member
I am not real into the idea of updating the BIOS, I've never done it and as you said I could easily ruin a working laptop! There have been a few suggested work arounds that I haven't been able to try as of yet!

You aren't being negative, I am coming to the same conclusion! I'm only worried that as Mint upgrades I may be unable to upgrade this system.

As for now, I am going to keep using what I have since both LM installs are working well but I am going to keep working on a solution to this!
 

poorguy

Well-Known Member
I'm only worried that as Mint upgrades I may be unable to upgrade this system.
Just because a new Linux Mint point release comes out doesn't mean you have to move over to it.
Linux Mint 19.2 is supported until 2023 of April.
I used Ubuntu 14.04 until it's last days of life 2019 of April.

I use old computers and sometimes I have to go outside of the mainstream flagship Linux distros.

An example.
This desktop is from 2006 Windows XP days and built to last.

Code:
[email protected]:~
$ inxi -Fxz
System:    Host: antix1 Kernel: 5.2.8-antix.1-amd64-smp x86_64 bits: 64 compiler: gcc v: 6.3.0 Desktop: IceWM 1.4.2 
           Distro: antiX-17.4.1_x64-base Helen Keller 28 March 2019 base: Debian GNU/Linux 9 (stretch) 
Machine:   Type: Desktop System: HP Pavilion 061 product: RF170AV-ABA d4650y v: 0qm1114CT101BASSW00 serial: <filter> 
           Mobo: ASUSTek model: Basswood v: 1.05 serial: <filter> BIOS: Phoenix v: 3.08 date: 09/18/2006
CPU:       Topology: Dual Core model: Intel Core2 6400 bits: 64 type: MCP arch: Core Merom rev: 6 L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 ssse3 vmx bogomips: 8533 
           Speed: 1834 MHz min/max: 1600/2133 MHz Core speeds (MHz): 1: 1600 2: 1600 
Graphics:  Device-1: NVIDIA G72 [GeForce 7300 LE] vendor: ASUSTeK driver: nouveau v: kernel bus ID: 01:00.0 
           Display: server: X.Org 1.19.2 driver: nouveau unloaded: fbdev,modesetting,vesa resolution: 1152x720~60Hz 
           OpenGL: renderer: Gallium 0.4 on NV46 v: 2.1 Mesa 13.0.6 direct render: Yes 
Audio:     Device-1: Intel 82801H HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k5.2.8-antix.1-amd64-smp 
Network:   Device-1: Intel 82562V 10/100 Network vendor: Hewlett-Packard driver: e1000e v: 3.2.6-k port: ff00 bus ID: 00:19.0 
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 111.79 GiB used: 3.83 GiB (3.4%) 
           ID-1: /dev/sda vendor: Western Digital model: WD1200JD-00HBB0 size: 111.79 GiB 
RAID:      Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 bus ID: 00:1f.2 
Partition: ID-1: / size: 107.53 GiB used: 3.83 GiB (3.6%) fs: ext4 dev: /dev/sda1 
           ID-2: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 56.0 C mobo: N/A gpu: nouveau temp: 50 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 123 Uptime: 28m Memory: 3.85 GiB used: 686.4 MiB (17.4%) Init: SysVinit runlevel: 5 Compilers: 
           gcc: 6.3.0 Shell: bash v: 4.4.12 inxi: 3.0.33 
[email protected]:~
$
 

poorguy

Well-Known Member
You ain't got nothing to lose by trying it and sometimes it works and lets you do the install.

-------------------------------------------------------------------------------------------------------------------------

It's frustrating but don't let it bum you out.

When you are going outside the norm of what your computer was built to run you sometimes run into obstacles and those can be a real big PITA.
 

Jeffrey Lapinski

Active Member
This is a new one for me! I had a problem with the NVIDIA card in another laptop that drove me nuts but I could do the install. I'll probably give these work arounds a shot to see if that solves the issue, if not I'll stick to Mint until a solution!
 

Members online

No members online now.

Latest posts

Top