gpg command not found on windows10

Cybio

New Member
Credits
0
[email protected] /ISO
$ dir
linuxmint-18.3-cinnamon-64bit.iso sha256sum.txt sha256sum.txt.gpg

[email protected] /ISO
$ sha256sum -b linuxmint-18.3-cinnamon-64bit.iso
ecebdf9ac4697b6c2d7feffd1bc5430641bca67c7df122fa2914824dc8844b3a *linuxmint-18.3-cinnamon-64bit.iso

[email protected] /ISO
$ sha256sum --ignore-missing -c sha256sum.txt
linuxmint-18.3-cinnamon-64bit.iso: Réussi

[email protected] /ISO
$ gpg --keyserver keyserver.ubuntu.com --recv-key "27DE B156 44C6 B3CF 3BD7 D291 300F 846B A25B AE09"
-bash: gpg : commande introuvable

[email protected] /ISO
$ gpg --keyserver keyserver.ubuntu.com --recv-key A25BAE09
-bash: gpg : commande introuvable

[email protected] /ISO
$ gpg --verify sha256sum.txt.gpg sha256sum.txt
-bash: gpg : commande introuvable

[email protected] /ISO
$ gpg --list-key --with-fingerprint A25BAE09
-bash: gpg : commande introuvable
 


Cybio

New Member
Credits
0
"commande introuvable" means "cannot find command" : sorry guys i'm a froggy ! Problem #1 : ISO image checksum is completely different from what it should be, but the "
sha256sum --ignore-missing -c sha256sum.txt" command result seems ok (réussi means passed). You can see that i'm not even close to install Linux, though i've been working on it for a couple of hours. Thanks a lot for helping me out in advance !
 

atanere

Well-Known Member
Credits
0
[email protected] /ISO
$ dir
linuxmint-18.3-cinnamon-64bit.iso sha256sum.txt sha256sum.txt.gpg

[email protected] /ISO
$ sha256sum -b linuxmint-18.3-cinnamon-64bit.iso
ecebdf9ac4697b6c2d7feffd1bc5430641bca67c7df122fa2914824dc8844b3a *linuxmint-18.3-cinnamon-64bit.iso

[email protected] /ISO
$ sha256sum --ignore-missing -c sha256sum.txt
linuxmint-18.3-cinnamon-64bit.iso: Réussi

[email protected] /ISO
$ gpg --keyserver keyserver.ubuntu.com --recv-key "27DE B156 44C6 B3CF 3BD7 D291 300F 846B A25B AE09"
-bash: gpg : commande introuvable

[email protected] /ISO
$ gpg --keyserver keyserver.ubuntu.com --recv-key A25BAE09
-bash: gpg : commande introuvable

[email protected] /ISO
$ gpg --verify sha256sum.txt.gpg sha256sum.txt
-bash: gpg : commande introuvable

[email protected] /ISO
$ gpg --list-key --with-fingerprint A25BAE09
-bash: gpg : commande introuvable
Hi @Cybio, and welcome! It looks like you are having difficulty "verifying" the Mint distro checksum as they describe on this page. I would have trouble following their instructions too! (The gpg command, and all of their instructions are meant to be done from Linux... so that is the main part of the problem.) But it really is a good idea to verify that you received a complete and uncorrupted .iso file before you burn it to DVD or USB (although our resident Wizard has even found a way to verify after you burn the image... but maybe you won't need to do that).

So, if you still have the .iso file you downloaded... I'm guessing that you downloaded it in Windows, right? You can get the SHA256 checksum value from the Mint page linked above, or the direct link to the text file is here. That text file has the checksum value for all of the Mint 18.3 editions, so you are only interested in the Cinnamon edition.

The easy way to verify the checksum is to use a free utility for Windows... here's a good one. With this utility, you can Browse with the button on the top right to your .iso file and it will generate all three types of checksums (or you can uncheck the two you don't need, just keeping SHA256). After it calculates the value, you can copy/paste the Cinnamon checksum value from the text file you got earlier into the box at the bottom, and click the Verify button. (Don't copy the filename, just the long checksum string of characters.) It will probably tell you that it matches! :D

@arochester's link above is a nice site for instructions on installing Mint (or others) in a dual-boot configuration. I hope that it all goes smoothly after this, but let us know if you have trouble and we'll try to help you along.

Cheers
 

Cybio

New Member
Credits
0
Hi guys !

First problem solved : i copied the wrong checksum code (32bits instead of 64...) into the text file ... Now that my ISO file is checked, going to next step.
 

Cybio

New Member
Credits
0
Hi again,

Using Arochester's link, everything went smoothly from then on : i'm so happy to tell you that Mint 18.3 is UP and RUNNING on my little computer !

Already amazed : so easy to use and so intuitive when you're searching for something, it's a real pleasure compared to Microsoft's poor products ! (planning to stop using win10 very soon...)

Thanks a lot again for helping me out : it feels really good to know that some people are always ready to share advice and knowledge.

Big cheers to you guys !
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
2,956
Hi @Cybio and welcome :p

That is wonderful news.

First thing you should do after a new install is to enable the firewall.

You can open Terminal by pressing Ctrl-Alt-t or by finding it in your Menu choices. At Terminal

Code:
sudo ufw enable
When you enter the code, you will be prompted for your admin password. Enter it (there will be no movement - security) and press Enter.

You will be rewarded with a message that the Uncomplicated Fire Wall (UFW) is enabled in real time, and a small script generated that will run at each boot/reboot to do the same.

Enjoy your Cinnamon with a cup of tea or coffee and pat yourself on the back for a job well done. :D

Wizard

BTW and a cheery thumbs up to @arochester and @atanere , your helpers in this matter.

Edited added BTW
 


Staff online

Members online


Top