grub keeps loading when my machine isnt connected to my monitor

mukto6121

Member
Credits
320
i'm usin latest version of kali when my monitor isnt connected to my machine it shows a blackscreen and says grub loading for ever then again when i connect my monitor back and restart the machine then it works fine. i tried some googling and someone posted this as a bug but didnt got any solution.
 


mukto6121

Member
Credits
320
the bit i couldn't understand was If you removed a monitor what was left to show a black screen ?
after i boot my machine while a monitor connected it boots then i can remove the monitor it works fine as it supposed to but then again when i reboot my machine without a monitor connect it gets stuck then then i connect my monitor i see its stuck in grub loading screen
 

KGIII

Super Moderator
Staff member
Gold Supporter
Credits
21,621
You'll have to look up how to make it a headless boot. It involves editing /etc/X11/xorg.conf the last I knew.

I probably shouldn't be helping, as it's likely just wasting time. Kali isn't a server distro and shouldn't be wedged into that role. It literally makes no sense to do this. If you think this makes sense, you're in for a long and painful road of discovery. Kali is barely usable as a desktop system, with who knows how many caveats attached.

Just so we're clear, there's a stickied post in the Kali sub-forum. It's worth reading that before going further. If you're new to Linux, Kali is probably a really bad choice in the first place - even for a desktop system. It doesn't turn you into a pen tester and all the applications it uses can be trivially installed on any number of other distros.
 

mukto6121

Member
Credits
320
the bit i couldn't understand was If you removed a monitor what was left to show a black screen ?
So basically when I start the machine without connecting the monitor after few seconds I ping it from another machine and I get no ping response then I connect my monitor and I see a screen where it says "grub loading" after that while connecting my monitor I restart my machine by power button it works as it supposed to
 

mukto6121

Member
Credits
320
You'll have to look up how to make it a headless boot. It involves editing /etc/X11/xorg.conf the last I knew.

I probably shouldn't be helping, as it's likely just wasting time. Kali isn't a server distro and shouldn't be wedged into that role. It literally makes no sense to do this. If you think this makes sense, you're in for a long and painful road of discovery. Kali is barely usable as a desktop system, with who knows how many caveats attached.

Just so we're clear, there's a stickied post in the Kali sub-forum. It's worth reading that before going further. If you're new to Linux, Kali is probably a really bad choice in the first place - even for a desktop system. It doesn't turn you into a pen tester and all the applications it uses can be trivially installed on any number of other distros.
I'm aware about all that I'm using this as a experiment. I'm using kali for a year or so. I tried switching to ubuntu but didn't liked that personally. I had this small machine which I could use it as a home server
 

f33dm3bits

Gold Member
Gold Supporter
Credits
21,056
I'm aware about all that I'm using this as a experiment. I'm using kali for a year or so. I tried switching to ubuntu but didn't liked that personally. I had this small machine which I could use it as a home server
If you don't like Ubuntu I would switch your server from Kali to Debian because Kali is based on Debian and meant for servers.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
21,056
As the community suggested that i should try another distro and see if that works i install parrot and im getting the same problem
I didn't recommend a different distribution because of your problem but because Kali isn't meant to be a server OS and neither is ParrotOS because Kali is meant for pen-testing and ParrotOS as well. What does your grub configuration look like?
 
Last edited:

mukto6121

Member
Credits
320
I didn't recommend a different distribution because of your problem but because Kali isn't meant to be a server OS and neither is ParrotOS because Kali is meant for pen-testing and ParrotOS as well. What does your grub configuration look like?
grub-install (GRUB) 2.04-18parrot1
are you talking about this file (cat /boot/grub/grub.cfg) ??
 

mukto6121

Member
Credits
320
/etc/default/grub
>>cat /etc/default/grub

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
 

Lord Boltar

Well-Known Member
Credits
4,278
Servers don't necessarily include peripherals like a monitor, keyboard, and mouse this is known as Headless - also server edition software focuses on specific packages include Bind9 and Apache2. Whereas desktop applications are focused for use on the host machine, Server packages concentrate on allowing connectivity with clients as well as security. Also the Kernel is different in Ubuntu for example; the Kernel for the Server Edition has been optimized for server use and not a desktop environment - I would recommend using a server edition then install a desktop environment afterwards if you want - the desktop environment will be optimized for the serve edition and not a standard desktop environment.
 

mukto6121

Member
Credits
320
Servers don't necessarily include peripherals like a monitor, keyboard, and mouse this is known as Headless - also server edition software focuses on specific packages include Bind9 and Apache2. Whereas desktop applications are focused for use on the host machine, Server packages concentrate on allowing connectivity with clients as well as security. Also the Kernel is different in Ubuntu for example; the Kernel for the Server Edition has been optimized for server use and not a desktop environment - I would recommend using a server edition then install a desktop environment afterwards if you want - the desktop environment will be optimized for the serve edition and not a standard desktop environment.
lets say im using this as a raspberry pi i use vnc to control this machine its not like that you are thinking
 

mukto6121

Member
Credits
320
So basically you are trying to setup a Video/Audio Distribution center/node? not a server
So I have a windows laptop and this linux machine I am not a fan of a vm and my laptop isnt that highend So i had this idea i'll set this linux machine as a Headless machine and do vnc to it when i need the linux. I just use linux for ctfs thats why i am trying to stick with pentest distro
 

f33dm3bits

Gold Member
Gold Supporter
Credits
21,056
>>cat /etc/default/grub
That looks pretty normal so seems is it's a grub thing(or something else) but same as you I can't find anything about it, the other thing you could try is to install another bootloader. Either Refind or Systemd-boot, but I think those require your system to be efi boot. Do you know if your system is bios boot or efi boot?

It may also be worth a try change the following setting to 0.
Code:
GRUB_TIMEOUT=5
GRUB_TIMEOUT=0
Then update grub: grub-mkconfig -o /boot/grub/grub.cfg and then reboot without monitor and see what happens.
 
Last edited:
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Latest posts

Top