Grub Login Not Working, USBs Not Recognized & Error 102 on SDA via GParted


New Member
Sep 11, 2020
Reaction score
Been a rough year so my recall on what started or contributed to this is sketchy.

I had Mint Cinnamon installed, updated to Uma and then uninstalled, I think. I believe I downloaded a Linux and installed only to realize it wasn't Mint.

All was well as I recall. Then I installed some security though I don't recall the software I uninstalled. Soon after my USB slots stopped being recognized.

My Grub is not working for my dual boot of Windows 10 and Mint. I backed up some of my Documents to the Windows sda but not all. I'm booting from a Mint ISO via CD/DVD. I'm unable to backup all the Documents which is very concerning and its too large for a CD and no USBs avail.

I uninstalled Telegram too. Grub boot menus are not working which I've tried to repair using web search results which didn't help. I don't recall my old password but my current one does not work when I last was able to use the Grub boot menu.

I don't recall what I did but I get this error:

Partition: ID-1: / size: 1.89 GiB used: 357.5 MiB (18.5%) fs: overlay source: ERR-102

mint@mint:~$ inxi -Fxxxrz
  Host: mint Kernel: 4.15.0-54-generic x86_64 bits: 64 compiler: gcc
  v: 7.4.0 Desktop: Cinnamon 4.2.3 wm: muffin 4.2.2 dm: LightDM 1.26.0
  Distro: Linux Mint 19.2 Tina base: Ubuntu 18.04 bionic
  Type: Laptop System: HP product: HP Laptop 15-bs1xx
  v: Type1ProductConfigId serial: <filter> Chassis: type: 10
  serial: <filter>
  Mobo: HP model: 832A v: 23.70 serial: <filter> UEFI: Insyde v: F.52
  date: 03/04/2019
  ID-1: BAT1 charge: 28.7 Wh condition: 28.7/31.1 Wh (92%) volts: 12.3/10.9
  model: Hewlett-Packard PABAS0241231 type: Li-ion serial: <filter>
  status: Full
  Topology: Dual Core model: Intel Pentium 4417U bits: 64 type: MT MCP
  arch: Kaby Lake rev: A L2 cache: 2048 KiB
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18432
  Speed: 800 MHz min/max: 400/2300 MHz Core speeds (MHz): 1: 800 2: 800
  3: 800 4: 800
  Device-1: Intel vendor: Hewlett-Packard driver: i915 v: kernel
  bus ID: 00:02.0 chip ID: 8086:5906
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa
  resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 610 (Kaby Lake GT1)
  v: 4.5 Mesa 19.0.2 compat-v: 3.0 direct render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71
  Sound Server: ALSA v: k4.15.0-54-generic
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Hewlett-Packard driver: r8169 v: 2.3LK-NAPI port: 3000
  bus ID: 01:00.0 chip ID: 10ec:8168
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
  v: kernel port: 3000 bus ID: 02:00.0 chip ID: 8086:24fb
  IF: wlo1 state: down mac: <filter>
  Local Storage: total: 465.76 GiB used: 325.81 GiB (70.0%)
  ID-1: /dev/sda vendor: Western Digital model: WD5000LPCX-60VHAT1
  size: 465.76 GiB speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter>
  rev: 1A03 temp: 31 C scheme: GPT
  ID-1: / size: 1.89 GiB used: 383.1 MiB (19.8%) fs: overlay source: ERR-102
  System Temperatures: cpu: 32.5 C mobo: 29.8 C
  Fan Speeds (RPM): N/A
  No active apt repos in: /etc/apt/sources.list
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
  1: deb tina main upstream import backport #id:linuxmint_main
  2: deb bionic main restricted universe multiverse
  3: deb bionic-updates main restricted universe multiverse
  4: deb bionic-backports main restricted universe multiverse
  5: deb bionic-security main restricted universe multiverse
  6: deb bionic partner
  Processes: 228 Uptime: 1h 11m Memory: 3.77 GiB used: 1.31 GiB (34.8%)
  Init: systemd v: 237 runlevel: 5 Compilers: gcc: 7.4.0 alt: 7 Shell: bash
  v: 4.4.19 running in: gnome-terminal inxi: 3.0.32

/dev/sda1 is Not Mounted
/dev/sda2 has an error - see image
/dev/sda4 I don't recall what that is
unallocated I gave up trying to get that into another partition a very long time ago
Windows & Mint are in sda3 and sda5 but they are on the same Mount Point folder /media/mint/... which does not look familiar (perhaps Microsoft made changes though I very rarely use MS but I had Ethernet plugged in one day...or)

GParted ScreenShot.png


Well-Known Member
Jan 14, 2021
Reaction score
Grub boot menus are not working which I've tried to repair using web search results which didn't help.
What website you were reading to restore Grub? Did you read and try the methods in this article yet?
Reinstall grub2 from LiveCD - LinuxMint Community

Edit: Other than that, you can use Boot Repair. Details here.
sudo apt install software-properties-common; \
sudo add-apt-repository "deb $(lsb_release -sc) universe"; \
sudo add-apt-repository -y ppa:yannubuntu/boot-repair; \
sudo apt-get update; \
sudo apt-get install -y boot-repair && boot-repair
Last edited:


Well-Known Member
Apr 30, 2017
Reaction score
I don't recall what I did
Neither do I......

methinks it may be a really good idea to get hold of a good size external hard drive, save your documents etc etc etc to that ahrd drive.......then, unplug that external hard drive and start again from scratch.

Write down the steps you need to take and then follow them. It is a good approach, I have done so many times.
Invariably it leads to a good outcome.

I can only assume that you have had the dual boot with windows for some time now ?
Do you truly still need windows at all ?

Hopefully food for thought.


New Member
Sep 11, 2020
Reaction score


Trying your recommended link. At Step 3 and I get this error
mint@mint:~$ sudo grub-install --root-directory=/mnt/ /dev/sda
Installing for i386-pc platform.
grub-install: warning: this GPT partition label contains no BIOS Boot Partition; embedding won't be possible.
grub-install: warning: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged..
grub-install: error: will not proceed with blocklists.
I searched for grub and found a bunch of files. Though my folder isn't providing dates of creation I took a look and there are various dates. I did find a recover program for grub. Perhaps I should try that? Notice the folder too...perhaps I should find the oldest folder and work to restore that grub versus the method explained in that site you referred me to.

I setup grub right after I got Mint loaded soon after I purchased the laptop and it worked right off the bat. Maybe I should restore my oldest, at least not one from 2022.


I need to keep Windows sometimes for use of rare software and for communications with rare others. So its not an option to get rid of it. thx.
Last edited:

Staff online

Members online