Hardware help - Apologies if wrong location


New Member
Mar 5, 2023
Reaction score

I have been using Linux for a while but I am not super proficient in troubleshooting and I'm in need of some help. I apologise if this is in the wrong location - I suspect the issue is hardware related but I've tried everything I can think of and I still can't resolve it. I have tried to include all relevant details

Overall System Issue:
After BIOS changes or after Windows restarts, the system goes to a black screen but does not complete the restart - it just hangs on a black screen.

Linux Specific Issue:
Both the existing Linux Install on a HDD and a Kubuntu 22.10 bootable media will not boot

System Details:
Motherboard: MSI B360 Pro Carbon
CPU: Intel i5 8500
Memory: 16GB
GPU: Nvidia GTX1060 6GB
Other: TP-Link Wireless N PCI Express Adaptor (Wifi card)
Windows: Installed to 480GB SSD
Linux: Installed to ext4 partition of 2TB HDD. Ubuntu 22.10, running manual installed KDE plasma desktop.
Other Drives: 1 TB HDD, 512 GB HDD

Issue Description:
On startup the Ubuntu distribution hangs. It displays the following warning:

x86/cpu: SGX is disabled by BIOS

Startup freezes at this point.

Windows operating system will start up if selected in GRUB.

Things I've tried - SGX:
I initially thought it may be a HDD failure. I have wanted to move the installation from the HDD to the SSD, so I created a bootable media using Kubuntu 22.10 iso image, mounted with Rufus and shrank the SSD windows partition. (yeah, sorry. I'm not good at this)

During the course of the SSD partition management, chkdsk /r had to be run from Windows as there was some kind of level of corruption of some SSD Sectors. It got to stage 4 of 5 before freezing. A hard reset was performed and afterwards the previously impossible partition resize operation was successful.

I then restarted and booted into the BIOS, prioritised the bootable Kubuntu 22.10 USB.

On startup the hang occurred at the same place in the start up and the same error was passed:

x86/cpu: SGX is disabled by BIOS.

I went into the BIOS and turned SGX from "Software Controlled" to On, and went back to starting up with the HDD installed Ubuntu 22.10 drive. Kernel Still hung on startup with the message:

x86/cpu: SGX is locked by BIOS.

I went back into BIOS and turned SGX to "Off". Kernel Still hung on startup with message:

x86/cpu: SGX is disabled by BIOS.

I reset SGX in BIOS to "Software Controlled"

Things I've Tried - Linux Kernel and Boot Params:
I attempted to boot to Linux kernel version 5.15.something. No effect.
I attempted to boot into recovery mode on kernel version 5.19.something. Before freezing, it's final message was:

Usb 1-1: A Highspeed usb device is connected using xhci_hcd controller (apologies if this is incorrect, I'm working from memory and some photographs)

This appeared to occur immediately Sata controllers were (initialised?) enumerated.

I restarted system with all USB devices removed. No effect

I attempted to boot into recovery mode on kernel version 5.15.something. Before freezing it did not get passed the SATA controller initialisation step.

At this point, I started passing startup arguments. Things I've tried include

"nosplash", "sgx=off", "acpi=strict"*, "acpi=off"*, "nomodeset"

I then tried all of this with both kernel version 5.15.something and the Lubuntu bootable media. No effect except that the screen just sat there with no error message (at least when not trying to boot into recovery mode). These various things appear to have suppressed the SGX and ACPI* warnings but not resolved the issue.

*At one point along with the sgx is off error, I was also getting ACPI Aborting Method errors.

Things I've tried - Hardware:
I downloaded and installed the latest version of the BIOS for my motherboard. After a tense moment during the flash when the system appeared to crash and then fail to startup, the bios update appears to have worked.

No effect, except that now the ACPI error alluded to above is permanently gone (even without passing the boot parameters that previously suppressed it) and I now get Problem Blacklisting Hash (-13) displayed 6 times on the screen. From research, I believe this is unlikely to be the cause of the issue.

I then tried unplugging the GPU from the system (because, you know, NVIDIA hates the penguin). No effect.

I tried FurMarking the GPU within windows to see if it was partially dying. It appears to have performed normally.

I then tried unplugging the Wifi Card. No effect.

I then tried unplugging the shadiest of the cannibalised drives attached to the system. No effect.

What did I do to provoke it?
The last time the system was working correctly, I had to hard reset the machine. This was because a storm was approaching and I needed to get several things done to prepare my house and hard shutdown of this machine has never been a problem in the past.

Why do I think it is a hardware issue?
The fact that reverting to kernel 5.15 and using a bootable media did not resolve the issue makes me think that something has broken with the hardware.

At this point, windows appears to be working, however, I strongly prefer using Linux as my primary operating system and I would like to get it working if possible.

Any help or advice you could give me would be much appreciated.

Members online

Latest posts