Hardware Trouble In multiple distros (grahcical,Ethernet)


New Member
Dec 16, 2018
Reaction score
Greetings, I have been having problem with my hardware for quite a while now and have been trying to figure it out on my own just by reading forms and such and I have found a few forms that helped but honestly most of them were complete idiots so I decided to make my own and explain in depth the problem. (excuse me if I make any grammar mistakes as I am Ukrainian.)

Warning: I apologize for this but I am going to go overboard with detail so If you are not someone that can sit through and read very long form then move on please.

I Will first start off with my current specifications:

1 8 gb ddr3 ram stick
amd radeon r9 380 asus strix model
amd fx 6300 6 core processor unlocked
gigabyte 970a-ud3p
500 watt evga Power supply

The Distrubutions I tried installing that all had the same problems were: Debian, Arch, Linux Mint, fedora, openSUES.

I am using Insigna 1217 Rev.A flat screen Television as my main display and it is connected via High-Definition Multimedia Interface cable. works fine on windows.

Ok now that that is settled here is the story:

I first installed linux mint on this machine and instantly when the machine booted up ( I use rufus to create the iso image also good to be noted) The mouse and keyboard both did not work. TO fix this problem I found that I needed to do the following in the Bios:

set EHCI_HANDOFF to Enabled
set Iommu = Enabled

Then in Grub (applies to every distro I used on this machine) :

GRUB_CMDLINE_LINUX="amd_iommu=on iommu=pt"

After I applied these initial fixes the booting speed picked up very much and then the keyboard and mouse worked properly.

After this I then ran into the more serious problems that I see lots of other people have been having with this combo of graphics card and mobo:
There was screen teaaring inside discord, firefox, and opera but the desktop enviornments (I tried both XFCE and KDE Plasma) did not have any screen tearing problems. Only if I played game, or used extrernal application (something that did not come with the initial installation not the file manager applications or things like those) Then there were screen tearing problems. so you ask what did i do to try to fix these problems:
- Tried both free and non-free drivers (the non free were not really much use i found the free to work slightly better as most people know) using command
sudo mhwd -a pci nonfree 0300 -f (in arch)

- tried switching to compbiz and compton compositors (XFCE)
- Edited sudo leafpad /etc/X11/xorg.conf.d/20-amdgpu.conf
to use:
Section "Device"
Identifier "AMD"
Driver "amdgpu"
Option "TearFree" "true"

- added the parameters radeon.cik_support=0 amdgpu.cik_support=1 amdgpu.dpm=1 amdgpu.dc=1 to the GRUB_CMDLINE_LINUX line in /etc/default/grub then ran update-grub and rebooted.

-disabled hardware accelaration in firefox (for browser specific problems)

- edited the sudo leafpad /etc/X11/xorg.conf.d/20-amdgpu.conf
yet again to:

Section "Device"
Identifier "Radeon"
Driver "radeon"
Option "AccelMethod" "glamor"
Option "DRI" "3"
Option "TearFree" "on"
Option "ColorTiling" "on"
Option "ColorTiling2D" "on"

and all of those options STILL did nothing and the screen still still stuttered and had tearing in browsers and discord. so this i am quite confused on as videos play fine and there is no tearing in them. Interestingly though, in firefox only, they will not play in full HD (in arch specifically)

The other problem I was having was (again in every distro i used) livestreams would stutter and also streaming average not live videos from youtube also would stutter (mostly just the sound not the actual video) so to try to fix THIS problem i tried the following:

changed the drivers from free to nonfree and then back again

and this did nothing, still the glitchy video playback in both opera and firefox.

I did go on amazon and look up my motherboard model and read a bunch of their comments and there were so many people saying that it was a terrible mobo for linux support but then there were some that were linux users who were quite happy. I am stumped by these problems and have not been able to fix them myself. sorry for the overly detailed form but it must be done in this situation.

I know this was nothing to do with my internet as I have no problems with any of my cables or router or anything of the sort and the streaming works fine on windows. I have been told that having only 1 ram stick instead of 2 might be bottlenecking system. Also I have been told by people that the IOMMU did not need to be enabled but on my particular board and i have read many people say this sbout this board that the mouse and sometimes even keyboard will not work unless IOMMU is enabled. also my video card is properly secured in the mobo. I asked this same question on a fourm and i was told That the only fix might be to build a specific kernel meant for my board. I feel like this would probably be very tedious and take a long time so i would like to try to find an easier solution before i know that would be the last resort. thanks.

Ive also been asked before to list the following commands outputs so i will here for extra information:

$ lspci -k | grep -5 VGA:

Kernel modules: k10temp
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 4
Kernel driver in use: fam15h_power
Kernel modules: fam15h_power
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 5
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tonga PRO [Radeon R9 285/380] (rev f1)
Subsystem: ASUSTeK Computer Inc. Tonga PRO [Radeon R9 285/380]
Kernel driver in use: amdgpu
Kernel modules: amdgpu
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Tonga HDMI Audio [Radeon R9 285/380]
Subsystem: ASUSTeK Computer Inc. Tonga HDMI Audio [Radeon R9 285/380]

$ glxinfo -B

name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
Vendor: X.Org (0x1002)
Device: AMD Radeon (TM) R9 380 Series (TONGA, DRM 3.26.0, 4.18.20-1-MANJARO, LLVM 7.0.0) (0x6939)
Version: 18.2.6
Accelerated: yes
Video memory: 4096MB
Unified memory: no
Preferred profile: core (0x1)
Max core profile version: 4.5
Max compat profile version: 4.4
Max GLES1 profile version: 1.1
Max GLES[23] profile version: 3.2
Memory info (GL_ATI_meminfo):
VBO free memory - total: 4045 MB, largest block: 4045 MB
VBO free aux. memory - total: 4091 MB, largest block: 4091 MB
Texture free memory - total: 4045 MB, largest block: 4045 MB
Texture free aux. memory - total: 4091 MB, largest block: 4091 MB
Renderbuffer free memory - total: 4045 MB, largest block: 4045 MB
Renderbuffer free aux. memory - total: 4091 MB, largest block: 4091 MB
Memory info (GL_NVX_gpu_memory_info):
Dedicated video memory: 4096 MB
Total available memory: 8192 MB
Currently available dedicated video memory: 4045 MB
OpenGL vendor string: X.Org
OpenGL renderer string: AMD Radeon (TM) R9 380 Series (TONGA, DRM 3.26.0, 4.18.20-1-MANJARO, LLVM 7.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.2.6
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.4 (Compatibility Profile) Mesa 18.2.6
OpenGL shading language version string: 4.40
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 18.2.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20

Members online

Latest posts