Solved Having multiple versions of Qt installed at same time

Solved issue


May 23, 2023
Reaction score
I screw around with coding in Python and like to use PyQt6 as my GUI framework. There was a recent-ish release of PyQt6 to version 6.5.0. I used to be on 6.4.2, and there were no problems. Once I upgraded, I can't launch applications I create. If needed, I can provide the exact error I get when launching Qt apps I code, but my environment is not set up yet. I just recently installed Fedora 38 KDE Plasma, and am getting it all set up (current step in that process is my coding environment).

My question is, in troubleshooting (read: grabbing for straws) apps not launching, I wonder if it's because Fedora uses Qt5, not 6? So, can I have two versions of Qt installed at one time? I wonder if the correct libraries are not installed in my OS. I'm seeing results on the net, but I'd rather just ask here. Thanks for any help.

Well, I got my coding environment set up, launched an app that uses Qt, and all is good. I don't know... prior to my latest test of Linux distro's, I was on "mainline" Fedora 37 with GNOME and such (I've given GNOME a fair day in court, and don't like it that much) and my apps wouldn't launch. With Fedora 38, they do. What can I say.
Not really solved by anything but testing the OS. But, I noticed that Fedora 38 has Qt6 installed already. I wonder if Fedora 37 did as well? Fedora 38 has Qt4, 5 and 6 installed.
Useless side note: I like KDE (my first go with it) much better than GNOME.

Members online

Latest posts