Having Trouble Installing LibreWolf App Image on 19.3 Cinnamon [solved]

SpongebobFan1994

Active Member
Credits
1,451
As some of you know by now (I found this out through DistroTube), Mozilla was involved some scandals fairly-recently. One was involving internet censorship in response to the alt-right throwing their big tantrum at the white house, and the other one was involving cancel culture where they, and some other far-left twats, are trying to remove Stallman (again) and the board of the FSF from their positions, even though he resigned because of his comments regarding Epstein. Because I can no longer support Mozilla because of this, I decided to check out LibreWolf because of what DistroTube was saying about it in his video. The problem is I can't get it to install in Terminal. The instructions say to download the app image (I downloaded LibreWolf-87.0-1.x86_64.AppImage because the instructions say most modern computers run x86_64), and then says to copy and paste "chmod +x LibreWolf-*.AppImage" into Terminal, and after doing that, I get an error message saying "No such file or directory". I've even tried downloading it again, but changing the file to AptURL when I went to save it (which listed it as an app image file), and it still didn't work. I don't understand what I did wrong. The app image should work on 19.3, right?
 


Vrai

Well-Known Member
Credits
3,703
Open the terminal in the folder in which the appimage is located (or use "cd" to change to the correct directory) and try the instructions again.

Also, I think you will need to run the command with administrator or SuperUser privileges. Or, you may be able to right click on the appimage file, select Properties and change the permissions from there.

Also, be sure you are using the correct name for the file. The file name used in the chmod command has to be exactly correct. (Linux is fussy that way.)

Edit: I am running Linux Mint 19.3 Cinnamon and have been intending to check out LibreWolf so I just downloaded the AppImage and tried it.

Just right click on the file, select Properties > Permissions and check (x) the Execute permission box for Owner. Then click on the AppImage file and it should start up and open LibreWolf.
 
Last edited:

craigevil

Member
Credits
416
I have never been able to get an appimage to work. Believe me I have tried many times.
That said LibreWolf has a Flatpak and it works. I am not a big fan of flatpak but this one works.
1) Download the flatpak : wget https://gitlab.com/librewolf-commun...b4fc1ef1ccc8e/LibreWolf-87.0-1.x86_64.flatpak
2) Install flatpak, follow the setup directions on flathub:https://flatpak.org/setup/Debian/, then install librewolf
3) flatpak install paste the path to the flatpak you download from above
4) Create a menu entry by using the run command flatpak run io.gitlab.librewolf-community
In a couple of minutes you have a working Librewolf install that will autoupdate.

2021-03-27_20-09.png
 
Last edited:

SpongebobFan1994

Active Member
Credits
1,451
Open the terminal in the folder in which the appimage is located (or use "cd" to change to the correct directory) and try the instructions again.

Also, I think you will need to run the command with administrator or SuperUser privileges. Or, you may be able to right click on the appimage file, select Properties and change the permissions from there.

Also, be sure you are using the correct name for the file. The file name used in the chmod command has to be exactly correct. (Linux is fussy that way.)

Edit: I am running Linux Mint 19.3 Cinnamon and have been intending to check out LibreWolf so I just downloaded the AppImage and tried it.

Just right click on the file, select Properties > Permissions and check (x) the Execute permission box for Owner. Then click on the AppImage file and it should start up and open LibreWolf.
I typed in "cd" and retried the instructions and it still didn't work. Thanks anyway.
 

Condobloke

Well-Known Member
Credits
9,116
Edit: I am running Linux Mint 19.3 Cinnamon and have been intending to check out LibreWolf so I just downloaded the AppImage and tried it.

Just right click on the file, select Properties > Permissions and check (x) the Execute permission box for Owner. Then click on the AppImage file and it should start up and open LibreWolf.
Follow @Vrai' s instructions. They work.
 

craigevil

Member
Credits
416
Perhaps the Appimage isn't the right one for your OS.
I was surprised the one from LibreWolf actually worked for me.
 

Vrai

Well-Known Member
Credits
3,703
I typed in "cd" and retried the instructions and it still didn't work. Thanks anyway.
You have to use "cd" (without the quotation marks) followed by the path to the directory (folder) where the file is actually located.
Code:
$ cd Downloads/
Then proceed with the aforementioned instructions.
Or you can navigate to the location of the downloaded file by using your file browser and clicking on the appropriate icon. Then right click and select Open in Terminal.
 

SpongebobFan1994

Active Member
Credits
1,451
You have to use "cd" (without the quotation marks) followed by the path to the directory (folder) where the file is actually located.
Code:
$ cd Downloads/
Then proceed with the aforementioned instructions.
Or you can navigate to the location of the downloaded file by using your file browser and clicking on the appropriate icon. Then right click and select Open in Terminal.
After clicking on LibreWolf like you said, it seems like I got it up and running now. Thanks!
 

Tolkem

Well-Known Member
Credits
4,205
The instructions say to download the app image (I downloaded LibreWolf-87.0-1.x86_64.AppImage because the instructions say most modern computers run x86_64), and then says to copy and paste "chmod +x LibreWolf-*.AppImage" into Terminal, and after doing that, I get an error message saying "No such file or directory". I've even tried downloading it again, but changing the file to AptURL when I went to save it (which listed it as an app image file), and it still didn't work. I don't understand what I did wrong. The app image should work on 19.3, right?
First, you don't "install" an appimage; appimages are self-contained, portable executable files. Form https://appimage.org/
Download an application, make it executable, and run! No need to install. No system libraries or system preferences are altered. The key idea of the AppImage format is one app = one file. Every AppImage contains an app and all the files the app needs to run. In other words, each AppImage has no dependencies other than what is included in the targeted base operating system(s).
So, yes, in theory appimages should run regardless of the distro(except Alpine Linux due to different libraries, it uses musl while the rest use glibc, see here for more on this). I run and use a number of appimages myself, 20+, and they all work just fine. I just downloaded LibreWolf and am writing this using it. Just follow these steps:
1. cd to the dir you downloaded the appimage
2. Make it executable; you can do this in 2 ways:
via terminal
Code:
chmod +x LibreWolf-87.0-1.x86_64.AppImage
via file manager
Open the file manager, locate LibreWolf-87.0-1.x86_64.AppImage, select it, hit Ctrl + Enter the properties windows should pop up, tick the box where it reads make this file executable or some similar wording.
3. Run/launch LibreWolf-87.0-1.x86_64.AppImage, again, you have two options here;
via terminal
Code:
./LibreWolf-87.0-1.x86_64.AppImage
hit enter and it should start. Alternatively, open the file manager, double-clikc LibreWolf-87.0-1.x86_64.AppImage or right-click and select launch or something similar and it should start.
You can make it available in your DE's menu too. In a text editor copy/paste the following
Code:
[Desktop Entry]
Comment=
Exec=/path/to/LibreWolf-87.0-1.x86_64.AppImage
GenericName=Web Browser
Icon=/path/to/LibreWolf-icon.png
Name=LibreWolf
NoDisplay=false
Terminal=0
TerminalOptions=
Type=Application
save that as LibreWolf.desktop in $HOME.local/share/applications. You can also use Cinnamon tool to do that too https://community.linuxmint.com/tutorial/view/1504



I have never been able to get an appimage to work. Believe me I have tried many times.
You're probably doing something wrong.

Also, I think you will need to run the command with administrator or SuperUser privileges.
No, that's not necessary, just imagine that! They can be run as your regular user's permission, no need for sudo and/or root. That would be a security issue and no one, including me, would use appimages.
 

Tolkem

Well-Known Member
Credits
4,205
After clicking on LibreWolf like you said, it seems like I got it up and running now. Thanks!
Seems you made it before I finished posting lol. By the way, to get the proper Icon to use in Cinnamon's menu, do this:
1. cd to LW.appimage location
Code:
cd /path/to/LW.appimage
now copy/paste or type this
Code:
./LibreWolf-87.0-1.x86_64.AppImage --appimage-extract
this will extract the contents of LW.appimage to a folder, the icon should be in browser > chrome > icons > default select either default 48 or 64.
 

Tolkem

Well-Known Member
Credits
4,205
Just took a look at LW settings and it's exactly the same as in FF, the only difference is some options are grayed out, so you can't enable them even if you wanted to, then again, you don't have to in FF either, I don't. I might keep playing a bit with it to see what is like. :)
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Latest posts

Top