Hibernation issue with LXLE 18.04.3 32-bit on Dell 700m

HAL_2000

Member
Credits
1,188
Hello Experienced Linux Users,

For those unfamiliar with my current mission, I am reviving older hardware (mostly 32bit machines) with lightweight distros of Linux for donations to kids overseas (and I am told there is a local tech).

This issue involves a Dell Inspiron 700m (1.6GHz Centrino, 1.25GB RAM), with Linux LXLE 18.04.3, 32-bit loaded. It tends to have the screen blank out during bootup and sometimes during operation. Otherwise, once booted and working it seems to operate normally and can surf the Net comfortably (using the OOTB SeaMonkey browser).

Now I don't think this is as much a Linux issue as much as it is a Dell hardware issue, since I have read online of others having the same problem, and them seeking solutions for it:

How to disable sleep and configure lid power settings for Ubuntu or Red Hat Enterprise Linux 7

Linux: Suspend and Hibernation Status Report

From the Linux side, I don't know anything about Kali, but you should have power management options available which control what "close lid" will do on a laptop. I would set that to "blank screen only" and I'd probably completely disable suspend and hibernation, or anything related to those power saving options.

Anyone here installed Linux on Dell Inspiron 700m?

The gist of my understanding of this issue is that it has something to do with ACPI, hibernation and suspend settings, and a very small button lid sensor.

While I am using the machine (like right now) when the screen blanks, you just hit the button (it's more of a very small, stiff whisker near the right lid hinge) and the screen comes back on. A user indicated to me that she could not use the machine because of this issue.

I would like to resolve it so it will not have that problem. It's operational in all other respects.

Where it's made a little more difficult for me, being a long-time Windows user, finding the hibernation and suspend settings in Linux (LXLE) is not so obvious. Also, if anyone has mastered this glitch, I would appreciate learning what you learned.

Thanks in advance.

Hal

 


yx_wh

New Member
Credits
6
I installed Debian GNU/Linux 10 on my Inspiron 700m and found the same problem.
I edited /etc/systemd/logind.conf , changed it to HandleLidSwitch=ignore and this time it's OK.
 

HAL_2000

Member
Credits
1,188
Cool! I will be busy this work-week, but when the smoke clears I'd like to try that.

Next question though: how do I edit this? Remember, Windows users generally did not mess with their Registry. For my own part, I did so rarely, cautiously, and backed it up before I did so.

Thanks in advance.
 

HAL_2000

Member
Credits
1,188
Thanks guys.

yx_wh wrote:

"I installed Debian GNU/Linux 10 on my Inspiron 700m and found the same problem.
I edited /etc/systemd/logind.conf , changed it to HandleLidSwitch=ignore and this time it's OK."

Actually, ^^^that^^^ looks very interesting, because not only is it about *stopping* unwanted hibernation / suspend, it is specifically directed at the Dell 700m, a machine which seemed to have that specific problem, regardless of OS.

Now I need to learn how to "edit" and put yx_wh's instructions into operation.
 

darry1966

Well-Known Member
Credits
1,848
This is interesting because some Puppies (Some older ones) gave me the black screen when I had that model, so as you say could be across the board.
 


Members online

No members online now.

Top