How fix corrupted sections on file system?



Dear Forum Users,
I recently start learning OS Linux and I have few question about corrupted sections on file system. I would be grateful if you could help me. My case next:
1. I deployed VM Linux Ubuntu (version 14, x32 bit) through vagrant on VirtualBox. OS work correct.

2. I found corrupted sections file system and cannot fix. Please see below command about disk and result checking file system.
vagrant@vagrant-ubuntu-trusty-32:~$ sudo fdisk -l

Disk /dev/sda: 104.9 GB, 104857600000 bytes
4 heads, 32 sectors/track, 1600000 cylinders, total 204800000 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000212ab

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 204799999 102398976 83 Linux

vagrant@vagrant-ubuntu-trusty-32:~$ sudo fsck -nf /dev/sda1
fsck from util-linux 2.20.1
e2fsck 1.42.9 (4-Feb-2014)
Warning! /dev/sda1 is mounted.
Warning: skipping journal recovery because doing a read-only filesystem check.
Pass 1: Checking inodes, blocks, and sizes
Deleted inode 61808 has zero dtime. Fix? no

Inodes that were part of a corrupted orphan linked list found. Fix? no

Inode 61828 was part of the orphaned inode list. IGNORED.
Inode 61837 was part of the orphaned inode list. IGNORED.
Inode 61841 was part of the orphaned inode list. IGNORED.
Inode 61934 was part of the orphaned inode list. IGNORED.
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Free blocks count wrong (24694906, counted=24694849).
Fix? no

Inode bitmap differences: -61808 -61828 -61837 -61841 -61934
Fix? no

Free inodes count wrong (6318944, counted=6318938).
Fix? no

cloudimg-rootfs: ********** WARNING: Filesystem still has errors **********

cloudimg-rootfs: 87200/6406144 files (0.1% non-contiguous), 904838/25599744 blocks

3. I tried increase level initialization from 2 until 1. Used command sudo init 1.
vagrant@vagrant-ubuntu-trusty-32:~$ who -r
run-level 1 2016-11-17 13:05 last=2

But after execute command through 10-15 sec my session automatically closed. When i try reconnect I see situation not changed.

vagrant@vagrant-ubuntu-trusty-32:~$ who -r
run-level 2 2016-11-17 13:21

4. I tried unmounting disk for checking and fixing corrupted sections. But device busy.

vagrant@vagrant-ubuntu-trusty-32:~$ sudo umount /dev/sda1
umount: /: device is busy.
(In some cases useful info about processes that use
the device is found by lsof(8) or fuser(1))

5. Then I found solution that need used disk with OS(ubuntu-14.04.5-server-i386.iso) for starting "Rescue a broken system", then unmount disk and fix corrupted sections.

I successfully unmounted disk. But when i try using command sudo\fsck -nf /dev/sda1. I see that commands "sudo" and "fsck" not found.

Could you help me how fix corrupted sections on file system from "Rescue Mode"?

Thank you for your attention to this matter.

Youe sincerely,

Members online