[how to] disable highlighted pasted text in the terminal

rado84

Well-Known Member
Joined
Feb 25, 2019
Messages
603
Reaction score
483
Credits
3,137
Not long ago all terminals somehow got a new option for a pasted text to appear as if it was marked by the user to be copied. But that was very annoying for me, especially due to the fact that there was no GUI option included to disable that. But a way was found to disable it and since I'm guessing I'm not the only one annoyed by that marking, I decided to share a way to get rid of it.

For the current terminal window (a temporary solution):
Code:
bind 'set enable-bracketed-paste off'

A permanent solution:
Code:
echo "set enable-bracketed-paste off" >> ~/.inputrc
 


jbrock

New Member
Joined
Aug 17, 2021
Messages
1
Reaction score
0
Credits
6
I just upgraded to Debian Bullseye, and I was very glad to find this post. Thank you!
I put bind 'set enable-bracketed-paste off' in my ~/.bashrc and that did the trick as well.
 

Ti Nu

New Member
Joined
Oct 31, 2021
Messages
1
Reaction score
0
Credits
8
I switched from bash to mksh to get rid of that misfeature. But that did not solve the problem with python where it is not only annoying, paste is completely broken except for single line pastes.

To globally get rid of that misfeature I added set enable-bracketed-paste off to /etc/inputrc.

Thank you rado84, you are my hero :)
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Staff online


Latest posts

Top