How to mount my USB external storage drive.

grr8d8

New Member
Joined
Jan 14, 2022
Messages
19
Reaction score
23
Credits
395
Hello While I am not brand new to Linux. I feel that way so am posting here. After upgrading Ubuntu, my external drive won't mount. On my new computer, I just installed MX Linux. It won't mount there either. If I need to transfer files, I will need to use the Ubuntu machine due to data size. If I can get it to mount, MX would be preferred. The currently OS is Ubuntu 22.04 Just yesterday I reinstalled 21.01 and upgraded to 22.04 early as that was the OS installed when the computer was last able to mount the drive. If I have to do it in Ubuntu, transfer the files and then reformat the drive, so be it. At this point, whatever will work.

How to mount my external hard drive?
What I have tried:
I tried running disk manager
Results: Incomplete multi-sector transfer: magic: 0x58444e49 size: 4096 usa_ofs: 40 usa_count: 1 data: 44044 usn: 44043: Input/output error
Corrupt index block signature: vcn 0 inode 5
Failed to open $Secure: No such file or directory
Failed to mount '/dev/sdb1': No such file or directory

I tried run mount, removable drives and media. Opened Thunar file manager - tried to mount from there. It is always an unknown error.

I ran this:
sudo ntfsfix /dev/sdb1
[sudo] password for Alex:
Mounting volume... Incomplete multi-sector transfer: magic: 0x58444e49 size: 4096 usa_ofs: 40 usa_count: 1 data: 44044 usn: 44043: Input/output error
Corrupt index block signature: vcn 0 inode 5
Failed to open $Secure: No such file or directory
FAILED
Attempting to correct errors...
Processing $MFT and $MFTMirr...
Reading $MFT... OK
Reading $MFTMirr... OK
Comparing $MFTMirr to $MFT... OK
Processing of $MFT and $MFTMirr completed successfully.
Setting required flags on partition... OK
Going to empty the journal ($LogFile)... OK
Incomplete multi-sector transfer: magic: 0x58444e49 size: 4096 usa_ofs: 40 usa_count: 1 data: 44044 usn: 44043: Input/output error
Corrupt index block signature: vcn 0 inode 5
Failed to open $Secure: No such file or directory
Remount failed: No such file or directory


Then I tried this: sudo mkdir /mnt/NTFS
then this: sudo mount -t ntfs-3g -o ro,force /dev/sdaX /mnt/NTFS

[with sdaX replaced with My Passport also tried with "My Passport"

I spent 3 days trying to use testdisk. I wish I could go back to the first day. I got to a point where on my Ubuntu machine, it was going to "repair" the partition. I wasn't so sure what that might do so did not hit yes. I tried again on the MX machine and did not get to that point and on either machine cannot get there now. I can get to where it tells me to copy and choose a destination but 0 copies. I can't actually "copy) the files to the MX machine as it has a 256 GB hard drive and I need to transfer 931 GB - only about 8 of which I need...unless there is a way to "pluck" files out of folders.


The last suggestion I got was to try Hiren's Boot CD PER x54 (v1.0.2) I had already looked into it...but haven't tried. I am not sure about it as it comes with its own burner but it might install on linux. It also might burn with Etcher. I will be unfamiliar with whatever software is there. It was also suggested that I try a Windows machine. I have no idea why that would be. This drive is brand new October just before my new computer arrived in November. It has NEVER been in a Windows machine. I can't quite figure out "how" linux can turn my drive into a "windows readable only" drive. I guess anything is possible. I am just used to automount.

Lastly is this: I don't know if it is an issue but with all 5 installations I have done over the past few weeks these kinds of things show up during the installation. I didn't think anything of it the first time until it showed up 3 different times during the installation. Somehow, the computer got around it (so figured it had sorted it out) but this is now happening on both computers with 3 different versions of Ubuntu and 1 version of Mx Linux. I just hope it is NOT a hardware problem. I purchased both of these computers with Ubuntu preinstalled. I put the computer specs from the site I purchased in [ ] at the bottom.

I: The initranfs will attempt to boot resume from /dev/sda/2
I: (UUID=d3aed5aa=5cde=43e4-b232-94dd47cc6f10)
I: Set the RESUME variable to override this.

{I don't know how to set a Resume variable nor do I know what one is.}

Check GRUB_DISABLE_OS_PROBER documentatin entry.
Warning: os-prober will not be executed to detect other bootable partitions. Systems on them will not be addded to the Grub boot directory.

[Brand Name:qotom
Processor Model:Intel Celeron j1900
Memory Capacity:8GBCertification:CEHard Drive
Capacity:256GBType:Mini DesktopOrigin:CN(Origin)Model Number:Q190SProcessor Main Frequency:Quad core 2.0 GhzProcessor Brand:IntelGraphics Card Type:Integrated CardType:MINI PCMemory:/ 8GB DDR3L SO-DIMM,mSATA SSD,Dual Band WiFi/ BT4.0 (opt...]
 
Last edited:


wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
7,120
Reaction score
5,996
Credits
23,583
I will try to give more time to this a little later in my day, but have commitments for next few hours.

As background, the OP (Original Poster, that's you, Alex ;)

has a Thread going at MX-Linux which has died off or stalled. On my laptop, it trickles into a 3rd page. It's a lot to ask, but I would ask Helpers to read there first, for background of what has been asked and answered, and achieved or not.

https://forum.mxlinux.org/viewtopic.php?t=68480

From there, the OP has apparently issued something like

Code:
inxi -Fxz

and I place the output from that in the following Spoiler (click to open, click to close)

System: Host: <filter> Kernel: 5.10.0-10-amd64 x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/boot/vmlinuz-5.10.0-10-amd64
root=UUID=<filter> ro quiet splash
Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 dm: LightDM 1.26.0
Distro: MX-21_x64 Wildflower October 20 2021 base: Debian GNU/Linux 11 (bullseye)
Machine: Type: Desktop Mobo: AMI model: Aptio CRB serial: <filter> UEFI: American Megatrends
v: 5.6.5 date: 02/25/2019
CPU: Topology: Quad Core model: Intel Celeron J1900 bits: 64 type: MCP arch: Silvermont
family: 6 model-id: 37 (55) stepping: 9 microcode: 90C L2 cache: 1024 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 16000
Speed: 1333 MHz min/max: 1333/2416 MHz Core speeds (MHz): 1: 1333 2: 1333 3: 1333
4: 1333
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass status: Not affected
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW,
STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics: Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display driver: i915
v: kernel bus ID: 00:02.0 chip ID: 8086:0f31
Display: x11 server: X.Org 1.20.11 driver: modesetting unloaded: fbdev,vesa
resolution: 1360x768~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics (BYT) v: 4.2 Mesa 20.3.5 compat-v: 3.0
direct render: Yes
Audio: Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio
driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:0f04
Device-2: WCM_USB WEB CAM type: USB driver: snd-usb-audio,uvcvideo bus ID: 1-2:2
chip ID: 1c3f:2002
Sound Server: ALSA v: k5.10.0-10-amd64
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
v: kernel port: e000 bus ID: 01:00.0 chip ID: 10ec:8168
IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
v: kernel port: d000 bus ID: 03:00.0 chip ID: 10ec:8168
IF: eth1 state: down mac: <filter>
Drives: Local Storage: total: 1.14 TiB used: 8.08 GiB (0.7%)
ID-1: /dev/sda vendor: Hoodisk model: SSD size: 238.47 GiB block size:
physical: 512 B logical: 512 B speed: 3.0 Gb/s serial: <filter> rev: J1.3 scheme: GPT
ID-2: /dev/sdb type: USB vendor: Western Digital model: WD My Passport 2626
size: 931.48 GiB block size: physical: 512 B logical: 512 B serial: <filter>
rev: 1028 scheme: GPT
Partition: ID-1: / raw size: 101.29 GiB size: 99.15 GiB (97.88%) used: 7.63 GiB (7.7%) fs: ext4
dev: /dev/sda2
ID-2: /home raw size: 128.92 GiB size: 125.84 GiB (97.61%) used: 460.4 MiB (0.4%)
fs: ext4 dev: /dev/sda4
ID-3: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap swappiness: 15 (default 60)
cache pressure: 100 (default) dev: /dev/sda3
Sensors: System Temperatures: cpu: 40.0 C mobo: N/A
Fan Speeds (RPM): N/A
Repos: No active apt repos in: /etc/apt/sources.list
Active apt repos in: /etc/apt/sources.list.d/brave-browser-release.list
1: deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ bullseye main
Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list
1: deb http://deb.debian.org/debian bullseye-updates main contrib non-free
Active apt repos in: /etc/apt/sources.list.d/debian.list
1: deb http://deb.debian.org/debian bullseye main contrib non-free
2: deb http://security.debian.org/debian-security bullseye-security main contrib non-free
Active apt repos in: /etc/apt/sources.list.d/mx.list
1: deb http://la.mxrepo.com/mx/repo/ bullseye main non-free
Active apt repos in: /etc/apt/sources.list.d/skype-stable.list
1: deb [arch=amd64] https://repo.skype.com/deb stable main
Info: Processes: 213 Uptime: 4h 26m Memory: 7.60 GiB used: 932.5 MiB (12.0%) Init: SysVinit
v: 2.96 runlevel: 5 default: 5 Compilers: gcc: 10.2.1 alt: 10 Shell: quick-system-in
running in: quick-system-in inxi: 3.0.36

I would also like to get the OP's output from (lines with a # are comments, not commands)

Code:
cat /etc/default/grub

# and

cat /etc/fstab

as background.

Check GRUB_DISABLE_OS_PROBER documentation entry.

... has me interested, too, which can be modified to see if it helps.

Back when I can

Wiz
 
OP
G

grr8d8

New Member
Joined
Jan 14, 2022
Messages
19
Reaction score
23
Credits
395
Thanks

What I have tried this morning:

sudo mount -t ntfs-3g -o ro,force /dev/sdb1 /mnt/NTFS

[sudo] password for Alex:

Incomplete multi-sector transfer: magic: 0x58444e49 size: 4096 usa_ofs: 40 usa_count: 1 data: 44044 usn: 44043: Input/output error
Corrupt index block signature: vcn 0 inode 5
Failed to open $Secure: No such file or directory
Failed to mount '/dev/sdb1': No such file or directory

I ran what you suggested

sudo cat /etc/default/grub

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'
GRUB_DEFAULT="0"
GRUB_TIMEOUT=6

GRUB_DISTRIBUTOR="$(unset PRETTY_NAME; (. /etc/lsb-release; echo ${PRETTY_NAME:?}) 2>/dev/null || echo Debian)"

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

GRUB_CMDLINE_LINUX=""
# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
# Uncomment to disable graphical terminal (grub-pc only)

#GRUB_TERMINAL=console

# The resolution used on graphical terminal

# note that you can use only modes which your graphic card supports via VBE

# you can see them in real GRUB with the command `vbeinfo'

GRUB_GFXMODE=1024x768
# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries

GRUB_DISABLE_RECOVERY="true"
# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

GRUB_DISABLE_OS_PROBER=false

#export GRUB_MENU_PICTURE="/usr/share/backgrounds/MXLinux/grub/linen-gradientblu-grub.png"
#export GRUB_MENU_PICTURE="/usr/share/backgrounds/MX18ALPHAWALL.png"

GRUB_THEME="/boot/grub/themes/mx_linux/theme.txt"

[email protected]:~

$ sudo # and
usage: sudo -h | -K | -k | -V

usage: sudo -v [-AknS] [-g group] [-h host] [-p prompt] [-u user]

usage: sudo -l [-AknS] [-g group] [-h host] [-p prompt] [-U user] [-u user] [command]

usage: sudo [-AbEHknPS] [-r role] [-t type] [-C num] [-D directory] [-g group] [-h host] [-p

prompt] [-R directory] [-T timeout] [-u user] [VAR=value] [-i|-s] [<command>]

usage: sudo -e [-AknS] [-r role] [-t type] [-C num] [-D directory] [-g group] [-h host] [-p prompt]

[-R directory] [-T timeout] [-u user] file ...

[email protected]:~

$ sudo cat /etc/fstab

# /etc/fstab: static file system information.

#

# <file system> <mount point> <type> <options> <dump> <pass>

#Entry for /dev/sda2 :

UUID=974af4d0-b2c4-4689-9a46-c809bfd8f512/ext4noatime11

#Entry for /dev/sda1 :

UUID=A826-D279/boot/efivfatnoatime,dmask=0002,fmask=011300

#Entry for /dev/sdb1 :

UUID=0CFC9EF4FC9ED774/media/My_Passportntfs-3gdefaults,uid=1000,gid=100,dmask=0002,fmask=0113,utf8,x-gvfs-show00

#Entry for /dev/sda4 :

UUID=13bbab33-5981-43be-97ee-2d957d73ef8f/homeext4noatime10

#Entry for /dev/sda3 :

UUID=1e4b6110-0ac0-4eb3-abd9-368c80569e7bswapswapdefaults00

{Here are the quick results - minus the urls under repos}



Code:
System: Kernel: 5.10.0-11-amd64 x86_64 bits: 64 compiler: gcc v: 10.2.1
parameters: BOOT_IMAGE=/boot/vmlinuz-5.10.0-11-amd64
root=UUID=<filter> ro quiet splash
Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm 4.16.1 vt: 7
dm: LightDM 1.26.0 Distro: MX-21_x64 Wildflower October 20 2021
base: Debian GNU/Linux 11 (bullseye)
Machine: Type: Desktop Mobo: AMI model: Aptio CRB serial: <filter> UEFI: American Megatrends
v: 5.6.5 date: 02/25/2019
CPU: Info: Quad Core model: Intel Celeron J1900 bits: 64 type: MCP arch: Silvermont
family: 6 model-id: 37 (55) stepping: 9 microcode: 90C cache: L2: 1024 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 16000
Speed: 1333 MHz min/max: 1333/2416 MHz Core speeds (MHz): 1: 1333 2: 1333 3: 1333
4: 1333
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass status: Not affected
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW,
STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics: Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display driver: i915
v: kernel bus-ID: 00:02.0 chip-ID: 8086:0f31 class-ID: 0300
Display: x11 server: X.Org 1.20.11 compositor: xfwm4 v: 4.16.1 driver:
loaded: modesetting unloaded: fbdev,vesa display-ID: :0.0 screens: 1
Screen-1: 0 s-res: 1360x768 s-dpi: 96 s-size: 359x203mm (14.1x8.0")
s-diag: 412mm (16.2")
Monitor-1: HDMI-1 res: 1360x768 hz: 60 dpi: 57 size: 607x345mm (23.9x13.6")
diag: 698mm (27.5")
OpenGL: renderer: Mesa DRI Intel HD Graphics (BYT) v: 4.2 Mesa 20.3.5 compat-v: 3.0
direct render: Yes
Audio: Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:0f04 class-ID: 0403
Sound Server-1: ALSA v: k5.10.0-11-amd64 running: yes
Sound Server-2: PulseAudio v: 14.2 running: yes
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
v: kernel port: e000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
v: kernel port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: eth1 state: down mac: <filter>
Drives: Local Storage: total: 1.14 TiB used: 9.14 GiB (0.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Hoodisk model: SSD size: 238.47 GiB block-size:
physical: 512 B logical: 512 B speed: 3.0 Gb/s type: SSD serial: <filter> rev: J1.3
temp: 33 C scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Western Digital
model: WD My Passport 2626 size: 931.48 GiB block-size: physical: 512 B
logical: 512 B type: N/A serial: <filter> rev: 1028 scheme: GPT
Partition: ID-1: / raw-size: 101.29 GiB size: 99.15 GiB (97.88%) used: 8.25 GiB (8.3%) fs: ext4
dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 256 MiB size: 252 MiB (98.46%) used: 274 KiB (0.1%)
fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 128.92 GiB size: 125.84 GiB (97.61%) used: 914.9 MiB (0.7%)
fs: ext4 dev: /dev/sda4 maj-min: 8:4
Swap: Kernel: swappiness: 15 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda3 maj-min: 8:3
Sensors: System Temperatures: cpu: 39.0 C mobo: N/A
Fan Speeds (RPM): N/A
Repos: Packages: note: see --pkg apt: 2027 lib: 1013 flatpak: 0


Info: Processes: 216 Uptime: 1h 36m wakeups: 1 Memory: 7.6 GiB used: 1.29 GiB (16.9%)
Init: SysVinit v: 2.96 runlevel: 5 default: 5 tool: systemctl Compilers: gcc: 10.2.1
alt: 10 Shell: quick-system-in default: Bash v: 5.1.4 running-in: quick-system-in
inxi: 3.3.06
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!


Top